Pode utilizar a função SE.ERRO para detear e tratar erros numa fórmula. SE.ERRO devolve um valor especificado por si se uma fórmula devolver um erro; caso contrário, devolve o resultado da fórmula.

Sintaxe

SE.ERRO(valor, valor_se_erro)

A sintaxe da função SE.ERRO tem os seguintes argumentos:

  • valor    Obrigatório. É o argumento no qual pode ser detetado um erro.

  • value_if_error    Obrigatório. É o valor devolvido se ocorrer um erro na fórmula. São detetáveis os seguintes tipos de erro: #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME?, ou #NULO!.

Observações

  • Se o valor ou value_if_error for uma célula vazia, a inserção SE.RO for tratada como um valor de cadeia vazio ("").

  • Se o valor for uma fórmula de matriz, a fórmula SE.HISTÓRICO devolve uma matriz de resultados para cada célula do intervalo especificado no valor. Ver segundo exemplo em baixo.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Quota

Unidades Vendidas

210

35

55

0

23

Fórmula

Descrição

Resultado

=SE.ERRO(A2/B2; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide 210 por 35); não ocorre nenhum erro, portanto devolve o resultado da fórmula

6

=SE.ERRO(A3/B3; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide 55 por 0); deteta o erro de divisão por 0, portanto devolve o valor especificado no parâmetro valor_se_erro

Erro no cálculo

=SE.ERRO(A4/B4; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide "" por 23); não ocorre nenhum erro, portanto devolve o resultado da fórmula.

0

Exemplo 2

Quota

Unidades Vendidas

Razão

210

35

6

55

0

Erro no cálculo

23

0

Fórmula

Descrição

Resultado

=C2

Verifica se ocorre um erro na fórmula, no primeiro argumento, no primeiro elemento da matriz (A2/B2, que divide 210 por 35); não ocorre nenhum erro, portanto devolve o resultado da fórmula

6

=C3

Verifica se ocorre um erro na fórmula, no primeiro argumento, no segundo elemento da matriz (A3/B3, que divide 55 por 0); deteta o erro de divisão por 0, portanto devolve o valor especificado no parâmetro valor_se_erro

Erro no cálculo

=C4

Verifica se ocorre um erro na fórmula, no primeiro argumento, no terceiro elemento da matriz (A4/B4, que divide "" por 23); não ocorre nenhum erro, portanto devolve o resultado da fórmula

0

Nota: se tiver uma versão atual do Microsoft 365,pode introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Enter para confirmar a fórmula como uma fórmula de matriz dinâmica. Caso contrário, a fórmula tem de ser introduzida como uma fórmula de matriz legada ao selecionar primeiro o intervalo de saída, introduzir a fórmula na célula superior esquerda do intervalo de saída e, em seguida, premir Ctrl+Shift+Enter para confirmar. O Excel insere automaticamente parênteses retos no início e no fim da fórmula. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft Office insiders

As informações foram úteis?

Quão satisfeito está com a qualidade da tradução?
O que afetou a sua experiência?

Obrigado pelos seus comentários!

×