Guardar um livro do Excel para compatibilidade com versões anteriores do Excel

Guardar um livro do Excel para compatibilidade com versões anteriores do Excel

Atualizou para uma nova versão do Excel e apercebeu-se de que partilha livros com pessoas que ainda não atualizou. O Verificador de Compatibilidade pode ajudá-lo a identificar funcionalidades ou informações que poderão não estar disponíveis numa versão anterior, para que possa resolver alguns dos problemas antes de partilhar o seu livro.

Guarde um ficheiro no formato .xls e reveja problemas do Verificador de Compatibilidade.

Siga estes passos:

  1. Clique em Ficheiro > Exportar > Alterar Tipo de Ficheiro.

    Alterar Tipo de Ficheiro no separador Exportar

  2. Alterar Tipo de Ficheiro no separador Exportar

  3. Em Tipos de Ficheiro de Livro, faça duplo clique em Livro do Excel 97-2003 (*.xls).

    Formato Livro do Excel 97-2003

  4. Na janela de pop-up Guardar Como, escolha uma localização de pasta para o livro.

  5. Na caixa Nome de ficheiro, escreva um novo nome de ficheiro (ou utilize o que já está lá).

  6. Clique em Guardar.

  7. Se o Verificador de Compatibilidade aparecer, reveja os problemas de compatibilidade encontrados.

    O Verificador de Compatibilidade a mostrar uma descida mínima de problemas de fidelidade

    A ligação Detetá-lo leva-o até esse local na sua base de dados e a ligação de Ajuda leva-o até às informações sobre o problema e possíveis soluções.
     

Notas: 

  • Na sua nova versão do Excel, o livro que acabou de guardá-lo no .xls é aberto no Modo de Compatibilidade. Continue a trabalhar neste modo quando quiser partilhar e receber este livro com pessoas que o abrem na versão anterior do Excel.

  • Quando já não precisar de retrocompatibilidade, clique em Ficheiro > Informações > Converta para converter o livro para o formato de ficheiro atual, de modo a poder tirar partido das Novidades no Excel.

Executar o Verificador de Compatibilidade para Excel 2007 e posterior

Para verificar se um livro é compatível com o Excel 2013, 2010 ou 2007, execute o Verificador de Compatibilidade manualmente quando guardar o livro pela primeira vez. Em seguida, defina o Verificador de Compatibilidade de modo a ser executado automaticamente sempre que guardar o livro.

Siga estes passos:

  1. Clique em Ficheiro > Informações > Verificar Existência de Problemas.

    Verificar Compatibilidade

  2. Selecionar Verificar Compatibilidade.

  3. Para verificar a compatibilidade automaticamente, selecione a caixa Verificar a compatibilidade ao guardar o livro.
     

    Sugestão: Também pode especificar as versões do Excel que pretende incluir quando verificar a compatibilidade. Por predefinição, todas as versões estão selecionadas, por isso basta desmarcar as versões que não quer incluir.

    O Verificador de Compatibilidade, a mostrar as versões a verificar

    Se for encontrado algum problema, a ligação Encontrar leva-o a esse local na sua base de dados e a ligação de Ajuda leva-o a informações sobre o problema e possíveis soluções.

Utilizar o Access para combinar origens de dados para Funcionalidades de Dados que utilizam várias tabelas

Nota: Também pode utilizar a função PROCV no Excel para resolver este problema, mas o processo é algo complicado e torna-se mais complicado à medida que o número de origens de dados a combinar aumentos.

Excel 2010 e versões anteriores não suportam funcionalidades de dados que analisam várias tabelas, uma vez que essas Excel de dados não têm um Modelo de Dados. Se o seu livro contiver essas funcionalidades, poderá prepará-las para utilização em versões anteriores ao combinar as origens de dados da funcionalidade numa única tabela e, em seguida, utilizar essa nova tabela como origem de dados.

Uma forma de o fazer é utilizar o Access para combinar as origens de dados e reproduzi-las como uma consulta, que poderá importar para o seu livro. O processo é este:

  1. No Access, importe cada origem de dados original como uma nova tabela.

  2. No Excel, abra a caixa de diálogo Relações ao clicar em > de Dados > Relações e anote as relações entre as origens de dados originais.

  3. No Access, recria cada uma das relações.

  4. No Access, crie uma consulta que contenha todos os campos de que a Excel dados precisa.

  5. No Excel, importe a consulta para uma nova livro como uma tabela.

Assim que os seus dados estiverem numa tabela no Excel, escolha essa tabela como a origem de dados para as funcionalidades de dados que estavam a utilizar várias tabelas ou recria as funcionalidades de dados e escolha a nova tabela como origem de dados.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte Também

Excel formatação e funcionalidades que não são transferidas para outros formatos de ficheiro

Problemas de compatibilidade de folhas de cálculo

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

×