Células

Importar ou exportar ficheiros de texto (.txt ou .csv)

Importar ou exportar ficheiros de texto (.txt ou .csv)

Existem duas formas de importar dados de um ficheiro de texto com o Excel: pode abri-lo no Excel, ou pode importá-lo como intervalo de dados externos. Para exportar dados do Excel para um ficheiro de texto, utilize o comando Save As e altere o tipo de ficheiro do menu suspenso.

Existem dois formatos de ficheiro de texto comumente utilizados:

  • Ficheiros de textolimitados (.txt), nos quais o carácter TAB (código de caracteres ASCII 009) normalmente separa cada campo de texto.

  • A vírgula separou os ficheiros de texto (.csv), em que o carácter da vírgula (,) tipicamente separa cada campo de texto.

Pode alterar o carácter separador que é utilizado em ficheiros de texto delimitados e .csv. Isto pode ser necessário para garantir que a operação de importação ou exportação funciona como deseja.

Nota: Pode importar ou exportar até 1.048.576 linhas e 16.384 colunas.

Importe um ficheiro de texto abrindo-o no Excel

Pode abrir um ficheiro de texto que criou noutro programa como livro do Excel utilizando o comando Open. A abertura de um ficheiro de texto no Excel não altera o formato do ficheiro — pode ver isto na barra de títulos do Excel, onde o nome do ficheiro mantém a extensão do nome do ficheiro de texto (por exemplo, .txt ou .csv).

  1. Vá ao Arquivo > Abrir e navegue para o local que contém o ficheiro de texto.

  2. Selecione Ficheiros de texto na lista de desistências do tipo de ficheiro na caixa de diálogo Aberto.

  3. Localize e clique duas vezes no ficheiro de texto que pretende abrir.

    • Se o ficheiro for um ficheiro de texto (.txt), o Excel inicia o Assistente de Texto de Importação. Quando terminar os passos, clique em Terminar para concluir a operação de importação. Consulte o Assistente de Importação de Texto para obter mais informações sobre delimiters e opções avançadas.

    • Se o ficheiro for um ficheiro .csv, o Excel abre automaticamente o ficheiro de texto e exibe os dados num novo livro.

      Nota: Quando o Excel abre um ficheiro .csv, utiliza as definições de formato de dados predefinidos atuais para interpretar como importar cada coluna de dados. Se quiser mais flexibilidade na conversão de colunas para diferentes formatos de dados, pode utilizar o Assistente de Texto de Importação. Por exemplo, o formato de uma coluna de dados no ficheiro .csv pode ser MDY, mas o formato de dados padrão do Excel é YMD, ou pretende converter uma coluna de números que contém zeros principais para texto para que possa preservar os zeros principais. Para forçar o Excel a executar o Assistente de Texto de Importação, pode alterar a extensão do nome do ficheiro de .csv para .txt antes de o abrir, ou pode importar um ficheiro de texto ligando-o (para mais informações, consulte a seguinte secção).

Importar um ficheiro de texto ligando-o (Consulta de Energia)

Pode importar dados de um ficheiro de texto para uma folha de cálculo existente.

  1. No separador Dados, no grupo Obter & Transformar Dados, clique em Texto/CSV.

  2. Na caixa de diálogo de dados de importação, localize e clique duas vezes no ficheiro de texto que pretende importar e clique em Importar.

  3. Na caixa de diálogo de pré-visualização, tem várias opções:

    • Selecione Carregar se quiser carregar os dados diretamente para uma nova folha de cálculo.

    • Em alternativa, selecione Carregar para se pretender carregar os dados numa tabela, PivotTable/PivotChart, uma folha de cálculo excel existente/nova, ou simplesmente criar uma ligação. Também tem a opção de adicionar os seus dados ao Modelo de Dados.

    • Selecione Transform Data se quiser carregar os dados para a Consulta de Energia e editá-los antes de os levar para o Excel.

Se o Excel não converter uma determinada coluna de dados no formato que pretende, então pode converter os dados depois de os importar. Para obter mais informações, consulte Converter os números armazenados como texto para números e Converter as datas armazenadas como texto até às datas.

Dados de exportação para um ficheiro de texto, guardando-os

Pode converter uma folha de cálculo do Excel num ficheiro de texto utilizando o comando Save As.

  1. Aceda a Ficheiro > Guardar Como.

  2. Clique em Procurar.

  3. Na caixa de diálogo 'Guardar', em Guardar como caixa de tipo, escolha o formato de ficheiro de texto para a folha de cálculo; por exemplo, clique em Texto (Separador delimitado) ou CSV (comma delimitada).

    Nota: Os diferentes formatos suportam diferentes conjuntos de funcionalidades. Para obter mais informações sobre os conjuntos de funcionalidades suportados pelos diferentes formatos de ficheiros de texto, consulte os formatos de ficheiro que são suportados no Excel.

  4. Navegue para o local onde pretende guardar o novo ficheiro de texto e, em seguida, clique em Guardar.

  5. Aparece uma caixa de diálogo, lembrando-lhe que apenas a folha de cálculo atual será guardada para o novo ficheiro. Se tiver a certeza de que a folha de cálculo atual é a que pretende guardar como ficheiro de texto, clique em OK. Pode guardar outras folhas de cálculo como ficheiros de texto separados repetindo este procedimento para cada folha de cálculo.

    Também pode ver um alerta abaixo da fita que algumas funcionalidades podem perder se guardar o livro num formato CSV.

Para obter mais informações sobre a poupança de ficheiros noutros formatos, consulte Guardar um livro noutro formato de ficheiro.

Importar um ficheiro de texto ligando-o

Pode importar dados de um ficheiro de texto para uma folha de cálculo existente.

  1. Clique na célula onde pretende colocar os dados a partir do ficheiro de texto.

  2. No separador Dados, no grupo Obter Dados Externos, clique em Texto.

  3. Na caixa de diálogo de dados de importação, localize e clique duas vezes no ficheiro de texto que pretende importar e clique em Importar.

    Siga as instruções no Assistente de Importação de Texto. Clique em Help Imagem de botão em qualquer página do Assistente de Importação de Texto para obter mais informações sobre a utilização do assistente. Quando terminar os passos no assistente, clique em Terminar para concluir a operação de importação.

  4. Na caixa de diálogo de dados de importação, faça o seguinte:

    1. Em Onde pretende colocar os dados?

      • Para devolver os dados ao local que selecionou, clique na folha de cálculo existente.

      • Para devolver os dados ao canto superior esquerdo de uma nova folha de cálculo, clique em Nova folha de cálculo.

    2. Opcionalmente, clique em Propriedades para definir opções de atualização, formatação e layout para os dados importados.

    3. Clique em OK.

      O Excel coloca o intervalo de dados externos no local que especifica.

Se o Excel não converter uma coluna de dados no formato que pretende, pode converter os dados depois de os importar. Para obter mais informações, consulte Converter os números armazenados como texto para números e Converter as datas armazenadas como texto até às datas.

Dados de exportação para um ficheiro de texto, guardando-os

Pode converter uma folha de cálculo do Excel num ficheiro de texto utilizando o comando Save As.

  1. Aceda a Ficheiro > Guardar Como.

  2. A caixa de diálogo Guardar Como é apresentada.

  3. Na caixa de tipo Save, escolha o formato de ficheiro de texto para a folha de cálculo.

    • Por exemplo, clique em Texto (Separador delimitado) ou CSV (comma delimitada).

    • Nota: Os diferentes formatos suportam diferentes conjuntos de funcionalidades. Para obter mais informações sobre os conjuntos de funcionalidades suportados pelos diferentes formatos de ficheiros de texto, consulte os formatos de ficheiro que são suportados no Excel.

  4. Navegue para o local onde pretende guardar o novo ficheiro de texto e, em seguida, clique em Guardar.

  5. Aparece uma caixa de diálogo, lembrando-lhe que apenas a folha de cálculo atual será guardada para o novo ficheiro. Se tiver a certeza de que a folha de cálculo atual é a que pretende guardar como ficheiro de texto, clique em OK. Pode guardar outras folhas de cálculo como ficheiros de texto separados repetindo este procedimento para cada folha de cálculo.

  6. Aparece uma segunda caixa de diálogo, lembrando-lhe que a sua folha de cálculo pode conter funcionalidades que não são suportadas por formatos de ficheiros de texto. Se estiver interessado apenas em guardar os dados da folha de cálculo no novo ficheiro de texto, clique em Sim. Se não tiver a certeza e quiser saber mais sobre quais as funcionalidades do Excel que não são suportadas por formatos de ficheiros de texto, clique em Ajudar para obter mais informações.

Para obter mais informações sobre a poupança de ficheiros noutros formatos, consulte Guardar um livro noutro formato de ficheiro.

A forma como muda o limonista ao importar é diferente dependendo da forma como importa o texto.

  • Se utilizar & transformar dados > de texto/CSV,depois de escolher o ficheiro de texto e clicar em Importar,escolha um personagem a utilizar na lista em Delimiter. Pode ver o efeito da sua nova escolha imediatamente na pré-visualização dos dados, para que possa ter a certeza de que faz a escolha que deseja antes de prosseguir.

  • Se utilizar o Assistente de Importação de Texto para importar um ficheiro de texto, pode alterar o declimiter utilizado para a operação de importação no passo 2 do Assistente de Importação de Texto. Neste passo, também pode alterar a forma como os delimiters consecutivos, como as aspas consecutivas, são tratados.

    Consulte o Assistente de Importação de Texto para obter mais informações sobre delimiters e opções avançadas.

Se pretender utilizar um ponto semi-cólon como separador de lista padrão quando guardar como .csv, mas precisa limitar a alteração ao Excel, considere alterar o separador decimal padrão para uma vírgula - isto obriga o Excel a usar um ponto separador para o separador da lista. Obviamente, isto também mudará a forma como os números decimais são apresentados, por isso também considere mudar o separador de Milhares para limitar qualquer confusão.

  1. Opções Clear Excel> Opções avançadasde edição>> Utilize separadores do sistema.

  2. Definir separador decimal para , (uma vírgula).

  3. Desa estação de milhares de separadores para . (um período).

Quando guarda um livro como ficheiro .csv, o separador de listas predefinido (limiter) é uma vírgula. Pode alterá-lo para outro personagem separador utilizando as definições da Região do Windows. 

Atenção: A alteração da definição do Windows irá causar uma alteração global no seu computador, afetando todas as aplicações. Para alterar apenas o delimiter para Excel, consulte alterar o separador de lista padrão para guardar ficheiros como texto (.csv) no Excel.

  1. No Microsoft Windows 10, clique com o botão Iniciar e, em seguida, clique em Definições.

  2. Clique em Tempo & idiomae, em seguida, clique em Região no painel esquerdo.

  3. No painel principal, em definições regionais,clique em data, hora e configurações regionais adicionais.

  4. Na Região, clique em Alterar os formatos de data, hora ou números.

  5. No diálogo da Região, no separador Formato, clique em Definições Adicionais.

  6. No diálogo de formato personalizado, no separador Números, escreva um personagem para usar como novo separador na caixa separador lista.

  7. Clique duas vezes em OK.

  1. No Microsoft Windows, clique no botão Iniciar e, em seguida, clique em Painel de Controlo.

  2. Em Relógio, Idioma e Região, clique em Alterar os formatos de data, hora ou número.

  3. No diálogo da Região, no separador Formato, clique em Definições Adicionais.

  4. No diálogo de formato personalizado, no separador Números, escreva um personagem para usar como novo separador na caixa separador lista.

  5. Clique duas vezes em OK.

Nota:  Depois de alterar o carácter separador da lista para o seu computador, todos os programas utilizam o novo personagem como separador de lista. Pode alterar o personagem de volta para o caracteres predefinidos seguindo o mesmo procedimento.

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Consulte Também

Importar dados a partir de origens de dados externas (Power Query)

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×