SE.ERRO (função SE.ERRO)

Pode utilizar a função IFERROR para prender e lidar com erros numa fórmula. IfERROR devolve um valor que especifica se uma fórmula avalia um erro; caso contrário, devolve o resultado da fórmula.

Sintaxe

SE.ERRO(valor, valor_se_erro)

A sintaxe da função SE.ERRO tem os seguintes argumentos:

  • valor    Obrigatório. É o argumento no qual pode ser detetado um erro.

  • value_if_error    Obrigatório. É o valor devolvido se ocorrer um erro na fórmula. São detetáveis os seguintes tipos de erro: #N/D, #VALOR!, #REF!, #DIV/0!, #NÚM!, #NOME?, ou #NULO!.

Observações

  • Se o valor ou value_if_error for uma célula vazia, o IFERROR trata-a como um valor de cadeia vazio ("").

  • Se o valor for uma fórmula de matriz, o IFERROR devolve uma série de resultados para cada célula na gama especificada em valor. Ver segundo exemplo em baixo.

Exemplos

Copie os dados de exemplo que se encontram na seguinte tabela e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem os resultados, selecione-as, prima F2 e, em seguida, prima Enter.

Quota

Unidades Vendidas

210

35

55

0

23

Fórmula

Descrição

Resultado

=SE.ERRO(A2/B2; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide 210 por 35); não ocorre nenhum erro, portanto devolve o resultado da fórmula

6

=SE.ERRO(A3/B3; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide 55 por 0); deteta o erro de divisão por 0, portanto devolve o valor especificado no parâmetro valor_se_erro

Erro no cálculo

=SE.ERRO(A4/B4; "Erro no cálculo")

Verifica se ocorre um erro na fórmula, no primeiro argumento (que divide "" por 23); não ocorre nenhum erro, portanto devolve o resultado da fórmula.

0

Exemplo 2

Quota

Unidades Vendidas

Razão

210

35

6

55

0

Erro no cálculo

23

0

Fórmula

Descrição

Resultado

=C2

Verifica se ocorre um erro na fórmula, no primeiro argumento, no primeiro elemento da matriz (A2/B2, que divide 210 por 35); não ocorre nenhum erro, portanto devolve o resultado da fórmula

6

=C3

Verifica se ocorre um erro na fórmula, no primeiro argumento, no segundo elemento da matriz (A3/B3, que divide 55 por 0); deteta o erro de divisão por 0, portanto devolve o valor especificado no parâmetro valor_se_erro

Erro no cálculo

=C4

Verifica se ocorre um erro na fórmula, no primeiro argumento, no terceiro elemento da matriz (A4/B4, que divide "" por 23); não ocorre nenhum erro, portanto devolve o resultado da fórmula

0

Nota: Se tiver uma versão atual do Microsoft 365,pode inserir a fórmula na célula superior-esquerda da gama de saída, em seguida, prima ENTER para confirmar a fórmula como uma fórmula dinâmica de matriz. Caso contrário, a fórmula deve ser inserida como uma fórmula de matriz legado selecionando primeiro a gama de saída, insira a fórmula na célula superior-esquerda da gama de saída e, em seguida, prima CTRL+SHIFT+ENTER para confirmá-la. O Excel insere os suportes encaracolados no início e no fim da fórmula para si. Para obter mais informações sobre fórmulas de matriz, consulte Diretrizes e exemplos de fórmulas de matriz.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×