Utilizar funções aninhadas numa fórmula

Utilizar uma função como um dos argumentos numa fórmula que utiliza uma função é denominada aninhar e iremos fazer referência a essa função como uma função aninhada. Por exemplo, ao aninhar a função MÉDIA e SOMA nos argumentos da função SE, a fórmula seguinte soma um conjunto de números (G2:G5) apenas se a média de outro conjunto de números (F2:F5) for superior a 50. Caso contrário, devolve 0.

Funções aninhadas

As funções MÉDIA e SOMA estão aninhadas na função SE.

Pode aninhar até 64 níveis de funções numa fórmula.

  1. Clique na célula na qual pretende introduzir a fórmula.

  2. Para começar a fórmula com a função, clique em Inserir Função Imagem do botão na barra de fórmulas Imagem do botão .

    O Excel insere o sinal de igual (=) automaticamente.

  3. Na caixa Ou selecione uma categoria, selecione Todas.

    Se estiver familiarizado com as categorias de função, também pode selecionar uma categoria.

    Se não tiver a certeza sobre que função utilizar, escreva uma pergunta que descreva o que quer fazer na caixa Procurar uma função (por exemplo, "somar números" devolve a função SOMA).

  4. Para introduzir outra função como argumento, introduza a função na caixa de argumento que pretende.

    As partes da fórmula apresentadas na caixa de diálogo Argumentos de Função refletem a função que selecionou no passo anterior.

    Se clicou em SE,a caixa de diálogo Argumentos da função apresenta os argumentos da função SE. Para aninhar outra função, pode introduza-a na caixa de argumento. Por exemplo, pode introduzir SOMA(G2:G5)na Value_if_true da função SE.

  5. Introduza quaisquer argumentos adicionais necessários para concluir a sua fórmula.

    Em vez de introduzir referências de célula, pode selecionar as células que quer referenciar. Clique Imagem do botão para minimizar a caixa de diálogo, selecione as células que pretende referenciar e, em seguida, clique Imagem do botão para expandir novamente a caixa de diálogo.

    Sugestão: Para saber mais sobre a função e o seus argumentos, clique em Ajuda sobre esta função.

  6. Depois de completar os argumentos para a fórmula, clique em OK.

  1. Clique na célula na qual pretende introduzir a fórmula.

  2. Para começar a fórmula com a função, clique em Inserir Função Imagem do botão na barra de fórmulas Imagem do botão .

  3. Na caixa de diálogo Inserir Função, na caixa Selecionar uma categoria, selecione Tudo.

    Se estiver familiarizado com as categorias de função, também pode selecionar uma categoria.

  4. Para introduzir outra função como argumento, introduza a função na caixa de argumento no Construtor de Fórmulas ou diretamente na célula.

  5. Introduza quaisquer argumentos adicionais necessários para concluir a sua fórmula.

  6. Depois de concluir os argumentos da fórmula, prima ENTER.

Exemplos

Segue-se um exemplo da utilização de funções SE aninhadas para atribuir uma classificação de carta a um resultado de teste numérico.

Copie os dados de exemplo na tabela seguinte e cole-os na célula A1 de uma nova folha de cálculo do Excel. Para que as fórmulas mostrem resultados, selecione-as, prima F2 e, em seguida, prima Enter. Se quiser, pode ajustar as larguras das colunas para ver todos os dados.

Pontuação

45

90

78

Fórmula

Descrição

Resultado

'=SE(A2>89;"Muito Bom";SE(A2>79;"Bom"; SE(A2>69;"C";SE(A2>59;"D";"F"))))

Utiliza condições SE aninhadas para atribuir uma classificação por letras aos resultados na célula A2.

=SE(A2>89;"Muito Bom";SE(A2>79;"Bom";SE(A2>69;"C";SE(A2>59;"D";"F"))))

'=SE(A3>89;"Muito Bom";SE(A3>79;"Bom"; SE(A3>69;"C";SE(A3>59;"D";"F"))))

Utiliza condições SE aninhadas para atribuir uma classificação por letras aos resultados na célula A3.

=SE(A3>89;"Muito Bom";SE(A3>79;"Bom";SE(A3>69;"C";SE(A3>59;"D";"F"))))

'=SE(A4>89;"Muito Bom";SE(A4>79;"Bom"; SE(A4>69;"C";SE(A4>59;"D";"F"))))

Utiliza condições SE aninhadas para atribuir uma nota de carta à pontuação na célula A4.

=SE(A4>89;"Muito Bom";SE(A4>79;"Bom";SE(A4>69;"C";SE(A4>59;"D";"F"))))

Sugestões: 

Precisa de mais ajuda?

Pode sempre colocar uma pergunta a um especialista da Excel Tech Community (Comunidade Tecnológica do Excel) ou obter suporte na Comunidade de Respostas.

Consulte Também

Vídeo: Funções SE aninhadas

Precisa de mais ajuda?

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

×