VALORDOCAMPO (função)

Pode utilizar a função FIELDVALUE para recuperar dados de campo de tipos de dados ligados, como os tipos de dadosde Stocks ou Geografia. Existem métodos mais fáceis para escrever fórmulas que referenciam tiposde dados, pelo que a função FIELDVALUE deve ser utilizada principalmente para criar cálculos condicionais com base em tipos de dados ligados.

Nota: 28 de março de 2019: Foram divulgados tipos de dados para todos os subscritores do Windows Microsoft 365. Se é assinanteMicrosoft 365, certifique-sede que tem a versão mais recente do Office .

Detalhes técnicos

Sintaxe

=VALORDOCAMPO(valor; nome_do_campo)

A sintaxe da função VALORDOCAMPO tem os seguintes argumentos:

Argumento

Descrição

valor

A função devolve todos os campos correspondentes a partir do tipo de dados ligados especificado no argumento do valor.

nome_do_campo

O nome ou nomes dos campos que pretende extrair a partir do tipo de dados ligados.

Descrição

Exemplos

No seguinte exemplo simples, a fórmula =VALORDOCAMPO(A2;"Preço") extrai o campo Preço do tipo de dados de ações da JM Smucker Co.

  Obter um preço das ações da empresa com a fórmula =VALORDOCAMPO(A2;"Preço") .

O próximo exemplo é um exemplo mais típico para a função FIELDVALUE. Aqui estamos a usar a função IFERROR para verificar se há erros. Se não houver um nome de empresa na célula A2, a fórmula FIELDVALUE devolve um erro, e nesse caso não queremos mostrar nada (""). Mas se houver um nome de empresa, queremos recuperar o Preço do tipo de dados em A2 com =IFERROR($A2,B$1)").

Obter um preço das ações da empresa e ignorar os erros com a fórmula =SE.ERRO(VALORDOCAMPO($A2;B$1);"")

Tenha em atenção que a função VALORDOCAMPO lhe permite fazer referência a células de folhas de cálculo para o argumento nome_do_campo. A fórmula acima faz referência à célula B1 para o Preço em vez de introduzir manualmente o "Preço" na fórmula.  

Observações

Se tentar recuperar dados de um campo de tipo de dados inexistente, a função FIELDVALUE devolverá o erro #FIELD!. Por exemplo, pode ter entrado em "Preços", quando o campo de tipo de dados real é chamado de "Preço". Verifique duas vezes a sua fórmula para se certificar de que está a usar um nome de campo válido. Se quiser apresentar uma lista de nomes de campo para um registo, selecione a célula para o registo e prima Alt+Shift+F10.

Precisa de mais ajuda?

Pode sempre perguntar a um especialista na Comunidade Tecnológica do Excel, obter suporte na Comunidade de Respostas ou sugerir uma nova funcionalidade ou melhoria no UserVoice do Excel.

Consulte também

Tipos de dados geográficos e de ações

Como escrever fórmulas que fazem referência a tipos de dados

Erro #CAMPO! erro

Nota:  Esta página foi traduzida automaticamente e pode conter erros gramaticais ou imprecisões. O nosso objetivo é que estes conteúdos lhe sejam úteis. Pode indicar-nos se estas informações foram úteis? Eis o artigo em inglês para sua referência.​

Aumente os seus conhecimentos do Office
Explore as formações
Seja o primeiro a obter novas funcionalidades
Adira ao Office Insider

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×