Erro "Utilizador não foi autenticado" quando tenta aceder a uma unidade de rede que está mapeada para uma partilha web

Sintomas

Considere o seguinte cenário num computador baseado no Windows:

  • Mapeia uma unidade de rede para uma partilha web que requer credenciais de utilizador.

  • Configura a unidade para utilizar a religação na opção iniciar sessão.

  • Introduza as credenciais de utilizador e, em seguida, selecione a minha caixa de verificação de palavra-passe Quando aceder à unidade.

  • Reinicia o computador ou sai do Windows.

Neste cenário, quando volta a entrar no computador, recebe uma mensagem de erro que se assemelha ao seguinte quando tenta aceder à unidade mapeada:

Ocorreu um erro durante a ligação ao endereçoA operação que está a ser solicitada não foi realizada porque o utilizador não foi autenticado A ligação não foi restaurada.

Nota A unidade mapeada aparece como desligada depois de voltar a entrar no computador.

Causa

Este problema ocorre porque o redirector de autoria e versão distribuído pela Web (WebDAV) utiliza os Serviços Windows HTTP (WinHTTP) em vez da API da Internet do Windows (WinInet). Numa configuração de rede não proxy, winHTTP envia credenciais de utilizador apenas em resposta a pedidos que ocorrem em um site intranet local. Portanto, se não houver procuração configurada, poderá não conseguir aceder a uma parte que exija credenciais de utilizador.

Resolução

Importante Esta secção, método ou tarefa contém passos que explicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorreta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para maior segurança, faça uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como fazer uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:

Como fazer uma cópia de segurança e restaurar o registo no Windows

Para resolver este problema no Windows Vista, aplique hotfix 943280. O hotfix é apenas para o Windows Vista. Para versões posteriores do Windows, vá à secção seguinte para modificar as teclas de registo.

Nota

Este hotfix aplica-se apenas aos sistemas baseados no Windows Vista. No entanto, as alterações de registo descritas posteriormente nesta secção aplicam-se a todos os sistemas operativos da secção "Aplica-se a". Não é necessário um hotfix para sistemas que estejam a executar o Windows 7, Windows 8.1 ou Windows 10. Só as alterações de registo resolvem o problema nestes sistemas.

Para mais informações, clique no número de artigo seguinte para ver o artigo na Base de Conhecimento da Microsoft: É solicitado a introduzir as suas credenciais quando aceder a um site da FQDN utilizando um computador cliente baseado no Windows Vista que não tem qualquer procuração configurada

Depois de aplicar este hotfix, deve criar uma entrada de registo. Para tal, siga estes passos:

  1. Clique em Iniciar,digite o regedite na caixa 'Iniciar', e depois prima Enter.

  2. Localizar e clicar na seguinte subchave:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters

  3. No menu Editar, aponte para Novoe, em seguida, clique em Valor Multi-String.

  4. Digite AuthForwardServerList , e, em seguida, prima Enter.

  5. No menu Editar, clique em Modificar.

  6. Na caixa de data Valor, digite o URL do servidor que acolhe a partilha web e, em seguida, clique EM OK. Nota Também pode escrever uma lista de URLs na caixa de data valor. Para mais informações, consulte a secção "Sample URL list".

  7. Saia do Editor de Registo.

Após a criação desta entrada de registo, o serviço WebClient irá ler o valor de entrada. Se o computador cliente tentar aceder a um URL que corresponda a qualquer uma das expressões da lista, a credencial do utilizador será enviada com sucesso para autenticar o utilizador mesmo que não esteja configurado qualquer procuração. Nota Tem de reiniciar o serviço WebClient depois de modificar o registo.

Lista de URL da amostra

Segue-se uma lista de URL de amostra:

https://*.Contoso.com
http://*.dns.live.com
*.microsoft.com
https://172.169.4.6
 

Esta lista de URL permite ao serviço WebClient enviar credenciais através dos seguintes canais. Nota Depois de configurar esta lista de URL, as credenciais autenticar-se-ão automaticamente nos servidores do WebDAV, mesmo que estes servidores estejam na Internet.

  • Qualquer canal encriptado para um domínio infantil de um domínio cujo nome é Contoso.com.

  • Qualquer canal não seguro para um domínio infantil de um domínio cujo nome é dns.live.com.

  • Qualquer canal para um servidor cujo nome termina com ".microsoft.com".

  • Qualquer canal encriptado para um anfitrião cujo endereço IP é 172.169.4.6.

Coisas a evitar na lista de URL

  • Não adicione um asterisco (*) no final de um URL. Quando o fizer, pode resultar um risco de segurança. Por exemplo, não utilize o seguinte:

    http://*.dns.live.*

  • Não adicione um asterisco (*) antes ou depois de uma corda. Quando o fizer, o serviço WebClient pode enviar credenciais de utilizador para mais servidores. Por exemplo, não utilize o seguinte:

    • http://*Contoso.com Neste exemplo, o serviço também envia credenciais de utilizador para http://extra_charactersContoso.com.

    • http://Contoso*.com Neste exemplo, o serviço também enviaextra_characterscredenciais de utilizador para http://Contoso extra_characters.com.

  • Não digite o nome UNC de um hospedeiro na lista de URL. Por exemplo, não utilize o seguinte:

    *.contoso.com@SSL

  • Não inclua o nome da partilha ou o número da porta a utilizar na lista de URL. Por exemplo, não utilize o seguinte:

    • http://*.dns.live.com/DavShare

    • http://*dns.live.com:80

  • Não utilize o IPv6 na lista de URL.

Importante Esta lista de URL não tem qualquer efeito nas definições da zona de segurança, e esta lista de URL é usada apenas para o propósito específico de encaminhar as credenciais para servidores WebDAV. Crie a lista o mais restritiva possível para evitar quaisquer problemas de segurança. Além disso, note que não há uma lista de negação específica. Portanto, as credenciais são reencaminhadas para todos os servidores que correspondem a esta lista. Se a autenticação Básica ou a autenticação Digest for implementada na rede, o hotfix 943280 não pode alterar este comportamento. Este comportamento é por design no modo de autenticação Básica e no modo de autenticação Digest. O IIS não suporta a autenticação do Windows através da Internet. Portanto, este hotfix aplica-se apenas aos cenários intranet.

Estado

A Microsoft confirmou que este problema ocorre nos produtos da Microsoft listados na secção "Aplica-se a".

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Obrigado pelos seus comentários!

Obrigado pelo seu feedback! Parece que poderá ser benéfico reencaminhá-lo para um dos nossos agentes de suporte do Office.

×