Sign in with Microsoft
New to Microsoft? Create an account.

IMPORTANTE: Este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):

256986 Description of the Microsoft Windows Registry

Quando clica com o botão direito do rato numa hiperligação de uma página da Internet e, em seguida, clica em
Abrir numa nova janela, o comando Abrir numa nova janela pode não funcionar.

Sintomas

Este problema pode ocorrer caso se verifique uma ou mais das seguintes condições:

  • Os valores de registo do Windows que controlam esta função estão em falta ou incorrectos.

  • Os ficheiros do Internet Explorer que controlam esta função não estão correctamente registados.

Causa

AVISO: Se utilizar o Editor de registo de forma incorrecta, poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.

Para resolver este problema, utilize os seguintes métodos.

Verifique se existem valores de registo em falta ou incorrectos


Verifique se os seguintes valores de registo estão presentes e correctos:

HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}
Nome: (Predefinição)
Valor: IDispatch

HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid

Nome: (Predefinição) Valor: {00020420-0000-0000-C000-000000000046}

HKLM\SOFTWARE\Classes\Interface\{00020400-0000-0000-C000-000000000046}\ProxyStubClsid32
Nome: (Predefinição)
Valor: {00020420-0000-0000-C000-000000000046}

Verifique se existem ficheiros em falta ou danificados


O comando Abrir numa nova janela depende ainda dos ficheiros que se seguem. Verifique se os seguintes ficheiros estão presentes e se não estão danificados:

  • Shdocvw.dll

  • Shell32.dll

  • Oleaut32.dll

  • Actxprxy.dll

  • Mshtml.dll

  • Url.dll

Para obter informações adicionais sobre como extrair novamente ficheiros, clique no número de artigo abaixo para visualizar o artigo na base de dados de conhecimentos da Microsoft (KB, Microsoft Knowledge Base):

129605 Como extrair ficheiros originais comprimidos do Windows

Verifique se os ficheiros de biblioteca estão correctamente registados


Para se certificar de que os ficheiros de biblioteca do Internet Explorer estão correctamente registados:

  1. Clique em Iniciar e, em seguida, clique em Executar.

  2. Na caixa Abrir, escreva
    regsvr32
    nome_do_ficheiro
    , em que
    nome_do_ficheiro
    é um dos seguintes nomes de ficheiro e, em seguida, clique em OK:

    • Shdocvw.dll

    • Msjava.dll

    • Urlmon.dll

    • Mshtml.dll

    • Browseui.dll


  3. Quando receber uma mensagem que estabeleça que o registo foi efectuado com êxito, clique em OK.

  4. Repita os passos 1 a 3 para registar cada um dos ficheiros listados no passo 2.

Resolução

A lista que se segue descreve outros sintomas que podem ocorrer quando estas entradas de registo estiverem em falta:

  1. Alguns scripts de Java podem não funcionar. O Microsoft Internet Explorer e o Microsoft Outlook Express podem não imprimir. As hiperligações no Outlook Express podem não abrir no Internet Explorer.

  2. O Microsoft Internet Explorer e o Microsoft Outlook Express podem não imprimir. As hiperligações no Outlook Express podem não abrir no Internet Explorer.

  3. As hiperligações no Outlook Express podem não abrir no Internet Explorer.

Mais Informação

Precisa de mais ajuda?

Aumente os seus conhecimentos
Explore as formações
Seja o primeiro a obter novas funcionalidades
Aderir ao Microsoft insiders

As informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?

Obrigado pelo seu feedback!

×