Os aplicativos não conseguem encontrar um novo dispositivo de verificação depois que outro dispositivo é desconectado

Este artigo ajuda você a contornar o erro que ocorre quando um aplicativo não encontra um dispositivo de verificação se esse scanner estiver conectado depois que um scanner diferente for desconectado.

Versão original do produto: Windows 10, Windows 8.1
Número de KB original: 4537086

Sintomas

Considere o seguinte cenário:

  1. Você conecta um dispositivo de verificação dos Serviços Web em Dispositivos (WSD) a um computador baseado no Windows.
  2. Desconecte o scanner WSD.
  3. Você conecta um dispositivo de verificação diferente, como um scanner USB, ao computador.
  4. Você inicia um aplicativo que usa o novo scanner. Nesse cenário, o aplicativo pode não se comportar corretamente. Por exemplo, o aplicativo pode não encontrar o novo scanner. Quando esse problema ocorre, o driver do scanner pode sofrer um erro de WIA_ERROR_OFFLINE quando ele chama o IStiDevice::LockDevice método.

Observação

Esse problema é aplicável a Windows 10 versões de até 19H2 (ou seja, Windows 10 Versão 1909). O problema é corrigido em 20H1 (Windows 10 Versão 2004)

Motivo

Esse problema ocorrerá se ocorrer um erro no serviço "WiA (Aquisição de Imagens do Windows)" quando o serviço inicializar o scanner WSD. Se o processo de inicialização for bem-sucedido sem erros, esse problema não ocorrerá.

Solução alternativa

Para contornar esse problema, experimente qualquer um dos seguintes métodos:

  • Desinstale o dispositivo de scanner conectado (por exemplo, usando Gerenciador de Dispositivos) e reconecte o scanner.
  • Interrompa o serviço "Aquisição de Imagens do Windows (WIA)" e reinicie o serviço.
  • Reinicie o computador enquanto o scanner está conectado.

Mais informações

Para obter mais informações sobre erros que um aplicativo de scanner wia ou driver pode experimentar, consulte Códigos de Erro.