"Error 2203. An internal error occurred." when you install a Microsoft Office program

Symptoms

You receive the following error message when you install Visio, Project, or a different Microsoft Office program on Windows 7 or on Windows Vista:

"Error 2203. An internal error occurred"

Cause

The error occurs when Microsoft Office Setup cannot access the default temporary folder in Windows (%temp%). A third-party program may restrict access to this folder, or there may not be sufficient permissions assigned to it.

Resolution

To resolve this issue, we recommend that you perform a "Selective Startup" (also known as "clean restart") before you install the Microsoft Office program. To do this, follow these steps:

  1. Click Start Start button, typemsconfig.exe in the Start Search box, and then press Enter to start the System Configuration utility.

    User Account Control permission If you are prompted for an Administrator password or confirmation, type the password or provide confirmation.

  2. On the General tab, click Selective Startup.
  3. Clear the Load Startup Items check box.
  4. On the Services tab, select Hide all Microsoft Services, and then clickDisable All.
  5. Click OK, and then click Restart.

When the computer restarts, it will be in Selective Startup. Now try installing the Microsoft Office program. When the installation is complete (or if the error still occurs), you will have to get out of Selective Startup. To do this, follow these steps:

  1. Click Start Start button, typemsconfig.exe, and then press Enter to access the utility again.
  2. On the General tab, click Normal Startup - load all device drivers and services.
  3. Click OK, and then click Restart.

If the error continues to occur, you can change the permissions of the default temporary folder. To do this, follow these steps:

  1. Click Start, type %temp% in the Start Searchbox, and then press Enter to see the default temporary folder.
  2. In the address bar (at the top of the window), click the folder to the left of Temp (it is named "Local" by default).
  3. In the folder list, right-click the Temp folder, and then select Properties.
  4. Click the Security tab, and then click Edit.
  5. Click Add.
  6. Type Everyone, and then click Check Names. "Everyone" should now be underlined.
  7. Select Full Control under Allow, and then keep clickingOK to exit all windows.

Note If the steps do not work and you have Windows Vista Home edition, you may have to enable the Administrator account. To do this, see "More Information."

Now try installing your Microsoft Office program.

More Information

How to enable the Administrator account in Windows Vista Home edition 

  1. Click the Windows menu button or press the Windows button on the keyboard.
  2. In the Start Search box, type cmd, right-click the CMD.exe item at the top, and then select Run as Administrator.
  3. At the command prompt, type the following command, and then press Enter:
      NET USER ADMINISTRATOR /ACTIVE:YES
  4. Type the following command (where <password> is a password of your choice), and then press Enter:
      NET USER ADMINISTRATOR <password>
  5. Log on with the Administrator account, and then repeat the steps in the "Resolution" section. 

 

Microsoft Internal Support Information

Steps to reproduce.

Product Bug Number:  Content Maintenance #98347
Author ID (email alias): DJESS
Writer ID(email alias): DJESS
Tech Review ID (email alias): DJESS
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ID articol: 2000547 - Ultima examinare: 5 nov. 2013 - Revizie: 1

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