Erori SHIM legate de compatibilitatea cu cu versiunea și platforma .NET Framework

Notă Acest articol prezintă mesaje de eroare SHIM. Dacă sunteți un utilizator final, încercați rezolvarea atunci când întâlniți eroarea SHIM „Trebuie să activați .NET Framework din caseta de dialog Caracteristici Windows.” Pentru orice alte erori SHIM, conținutul se adresează distribuitorilor sau dezvoltatorilor de aplicații; trebuie să contactați distribuitorul aplicației pentru a-i spune că există o problemă în legătură cu aplicația.

Eroare: "Trebuie să activați .NET Framework din caseta de dialog Caracteristici Windows"

Această aplicație nu poate fi pornită. Trebuie să activați .NET Framework din caseta de dialog Caracteristici Windows (din Panoul de control, alegeți Programe, Activare sau dezactivare caracteristici Windows).
Această problemă apare deoarece aplicația nu este configurată într-un mod care să permită să se determine versiunea potrivită a timpul de funcționare .NET Framework. Codul de compatibilitate corespunzătoare este SHIM_GOTO_CONTROLPANEL.
Pentru a rezolva aceasta, activați .NET Framework 3.5 pe care este o caracteristică de sistem de operare Windows 7 şi Windows 8.


Pentru Windows 8
Pentru Windows 7



Exonerare de răspundere pentru soluțiile terțe

Eroare: "Această aplicație nu poate fi pornită"

Această aplicație nu poate fi pornită.
Aplicația nu este configurată într-un mod care să facă posibilă determinarea versiunea potrivite a runtime-ului .NET Framework. Codul SHIM corespunzător este SHIM_NOVERSION_FOUND.
Nu puteți rezolva singur problema de configurare. Contactați distribuitorul aplicației pentru a rezolva problema.

Eroare: "Se bazează pe o versiune de .NET Framework care nu este acceptată pe acest dispozitiv"

Această aplicație nu poate fi pornită. Se bazează pe o versiune de .NET Framework care nu este acceptată pe acest dispozitiv.
Această problemă apare deoarece aplicația nu a fost creată pentru a se executa pe acest dispozitiv. De exemplu, este posibil să încercați să executați o aplicație care este creată pentru un procesor Intel pe un dispozitiv care utilizează un procesor ARM. Codul SHIM corespunzător este SHIM_UNSUPPORTED_PLATFORM.
Nu puteți rezolva singur problema de configurare. Contactați distribuitorul aplicației pentru a instala versiunea corectă a aplicației.

Despre mesajele de eroare SHIM

Când porniți o aplicație Microsoft .NET Framework, un program SHIM determină ce versiune de Common Language Runtime (CLR) să încărce, apoi îl încarcă și pornește aplicația. Dacă programul SHIM întâlnește o eroare (de exemplu, dacă nu găsește o versiune compatibilă de .NET Framework pe computer), se afișează un mesaj de eroare cu instrucțiuni. Acest articol oferă informații despre codurile de eroare SHIM_NOVERSION_FOUND, SHIM_GOTO_CONTROLPANELși SHIM_UNSUPPORTED_PLATFORM.

Pentru mai multe informații despre erorile de inițializare .NET Framework, accesați și consultați următoarea pagină Web MSDN:

Proprietăți

ID articol: 2715633 - Ultima examinare: 8 ian. 2017 - Revizie: 1

Microsoft .NET Framework 4.5

Feedback