Certificate Propagation service crashes when you disconnect an RDS client from a Windows 7 or Windows Server 2008 R2-based RDS server

Symptoms

Assume that you have a Windows 7 or Windows Server 2008 R2-based Remote Desktop Services (RDS) server. You connect an RDS client to the server by using a smart card, and then you disconnect the connection immediately. In this situation, the Certificate Propagation service crashes and other services that are contained in the same Svchost group on the RDS server unexpectedly stop. Additionally, the following event is logged in the Application log:
 Note The following services that are contained in the same Svchost group as the Certification Propagation service are affected by this issue:
  • Application Experience service
  • Application Information service
  • Application Management service
  • Certificate Propagation service
  • Group Policy Client service
  • IP Helper service
  • Server service
  • User Profile service
  • Task Scheduler service
  • System Event Notification service
  • Remote Desktop Configuration service
  • Shell Hardware Detection service
  • Windows Management Instrumentation service
  • Windows Update service

Cause

This issue is caused by a race condition that occurs when the RDS client is connected to the server and then disconnected. Two separate threads are created to handle the connection and disconnection events. The session that is used by the first thread is deleted by the second thread because of the race condition. Therefore, an access violation occurs in the first thread.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows 7 Service Pack 1 (SP1) or Windows Server 2008 R2 SP1. You must have the Remote Desktop Services role installed on the computer that is running Windows Server 2008 R2, or have the Remote Server Administration Tools feature installed on the computer that is running Windows 7.

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To apply this hotfix, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.
File information

Workaround

To work around this issue, restart all the stopped services manually.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Additional file information
Proprietăți

ID articol: 2799035 - Ultima examinare: 13 feb. 2013 - Revizie: 1

Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Datacenter, Windows Server 2008 R2 for Itanium-Based Systems, Windows Server 2008 R2 Foundation, Windows Server 2008 R2 Standard, Windows Web Server 2008 R2, Windows 7 Enterprise, Windows 7 Home Basic, Windows 7 Home Premium, Windows 7 Professional, Windows 7 Starter, Windows 7 Ultimate

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