"Error occurred while configuring Search Foundation" when installing Exchange Server 2013 CU1 or CU2

Symptoms

When you install Microsoft Exchange Server 2013 Cumulative Update 1 (KB2816900) or Cumulative Update 2 (KB2859928) on Windows Server 2008 R2 Service Pack 1 (SP1) or Windows Server 2012, the installation of the Mailbox server role is not successful, and you receive the following error message:
[2] Beginning processing Write-ExchangeSetupLog


[2] [ERROR] Failure configuring SearchFoundation through installconfig.ps1 - Error occurred while configuring Search Foundation for Exchange.System.TimeoutException: Timed out waiting for Admin node to be up and running

at Microsoft.Ceres.Exchange.PostSetup.DeploymentManager.WaitForAdminNode(String hostControllerNetTcpWcfUrl)

at Microsoft.Ceres.Exchange.PostSetup.DeploymentManager.Install(String installDirectory, String dataDirectoryPath, Int32 basePort, String logFile, Boolean singleNode, String systemName, Boolean attachedMode) at CallSite.Target(Closure , CallSite , Type , Object , Object , Object , Object , Object , Object , Boolean )



[08/30/2013 08:29:04.0660] [2] Ending processing Write-ExchangeSetupLog

In addition, you see errors in the following log files:
In addition, you see errors in the following log files:




Cause

This issue occurs because of a trailing space in the PSModulePath variable in the environment variables.

PSModulePath Variable

Resolution

To resolve this issue, remove trailing spaces from the PSModulePath variable. If there are more PSModulePath variables, make sure that they do not contain any trailing spaces. After you remove the trailing space, restart the server.


More Information

For more information about how to configure Environment Variables, see Configure an Environment Variable item.
Proprietăți

ID articol: 2889663 - Ultima examinare: 22 sept. 2013 - Revizie: 1

Feedback