Mesaj de eroare atunci când instalați un pachet de actualizare .msu pe un computer care execută Windows: "instalare module Windows trebuie să fie actualizate înainte de a instala acest pachet"

Se aplică la: Windows 8.1 EnterpriseWindows 8.1Windows 8.1 Pro

Simptome


Când instalați un pachet de actualizare .msu pe un computer care execută Windows, este posibil să primiți următorul mesaj de eroare:
Windows Installer module trebuie să fie actualizate înainte de a instala acest pachet. Actualizați programul de instalare Windows Modules pe computer, apoi încercați din nou configurarea.
Când utilizați un script pentru a instala pachetul de actualizare .msu, instalarea nu reușește. Când apare această problemă, procesul de Wusa.exe returnează codul de eroare 0x800f0823.

Cauza


Această problemă se produce deoarece instalarea necesită o versiune nouă a programului de instalare a modulelor Windows sau stiva de întreținere.

Rezolvare


Pentru a rezolva această problemă, utilizați Windows Update pentru a actualiza Windows Installer module sau stiva de întreținere. Sau descărca actualizările care sunt listate în următorul tabel de la Microsoft Download Center.
Sistem de operareNumărul KB
Windows Vista și Windows Server 2008955430
Windows 7 și Windows Server 2008 R22533552
Windows 8 şi Windows Server 20122871777
Windows 8.1 și Windows Server 2012 R22919442

Mai multe informații


Când utilizați Windows Update, Windows Installer module sau actualizarea stiva de întreținere este necesar. Cu toate acestea, atunci când instalați un pachet de actualizare .msu, programul de instalare nu se conectează la Windows Update pentru a actualiza Windows Installer module sau stiva de întreținere.