SIFT totaluri se calculează incorect atunci când ștergeți înregistrările SIFT din opţiunea Microsoft SQL Server pentru Microsoft Dynamics NAV


Microsoft Business Solutions-Navision 4.0 și Microsoft Navision 4.0 sunt acum parte din Microsoft Dynamics NAV 4.0. Toate referințele la Microsoft Business Solutions-Navision sau la Microsoft Navision 4.0 se referă la Microsoft Dynamics NAV.
Acest articol se aplică la Microsoft Dynamics NAV pentru toate țările și toate limbi regionale.

Simptome


Suma Index domeniul tehnologiei (SIFT) totaluri care apar în FlowFields se calculează incorect atunci când ștergeți înregistrările SIFT din opţiunea Microsoft SQL Server pentru Microsoft Dynamics NAV 4.0.
Notă Exemple de FlowFields sunt stocuri în caseta de dialog Card element şi câmpul Sold în caseta de dialog De conturi .
Când apare această problemă, FlowFields afişează sumele incorecte. Cu toate acestea, dacă faceți clic pe butonul drill down în câmpurile, valorile corecte apare intrările de bază.

Cauza


Această problemă poate apărea dacă ștergeți o înregistrare de SIFT goală sau dacă ștergeți mai multe înregistrări gol SIFT. O înregistrare SIFT goală este o înregistrare în care toate sumele egală cu zero. Când Microsoft Dynamics NAV mai târziu încearcă să actualizați o înregistrare SIFT care a fost șters, actualizarea este revocată. De aceea, în total SIFT devine incorecte.

Rezolvare


Informații despre remedierea rapidă

Un hotfix acceptat este acum disponibil de la Microsoft. Remedierea rapidă corectează problema descrisă în acest articol. Aplicați remedierea rapidă numai pentru sistemele care întâmpină această problemă anume.

Pentru a rezolva imediat problema, contactaţi asistenţa tehnică pentru Microsoft Dynamics și produse asociate pentru a obține remedierea rapidă. Puteți face log on la site-ul Microsoft Dynamics și creați o nouă solicitare de suport. Pentru aceasta, vizitați următorul site Web Microsoft:De asemenea, posibilitatea să contactați asistența tehnică pentru Microsoft Dynamics și produse asociate prin telefon la (888) 477-7877.

Notă În cazuri speciale, costurile implicate de obicei pentru asistență apeluri pot fi anulate dacă un specialist în asistență tehnică pentru Microsoft Dynamics și produse asociate stabilește că o anumită actualizare va rezolva problema. Se vor aplica costurile uzuale de asistență pentru orice întrebări suplimentare de asistenţă şi pentru probleme ce nu fac obiectul actualizării în cauză.



Cum se obține remedierea rapidă Microsoft Dynamics NAV sau actualizați fișierele

După ce solicita o remediere rapidă Microsoft Dynamics NAV sau un fișier de actualizare de la asistență tehnică pentru Microsoft Dynamics, va fi trimis un hyperlink pentru a vă într-un e-mail.


Mesajul de poștă electronică va conține un hyperlink și o parolă. Puteţi utiliza hyperlink pentru a descărca remedierea rapidă Microsoft Dynamics NAV sau fișierele de actualizare. Când faceţi clic pe hyperlinkul, se deschide caseta de dialog Descărcare fișier – avertisment de securitate . Apoi, vi se solicită să se execute, pentru a salva sau a anula descărcarea.


Dacă faceți clic pe executare, fișierele începe descărcarea și procesul de extragere. Trebuie să specificați un folder pentru fișiere noi, și apoi tastați parola.


Dacă faceți clic pe Salvare, trebuie să specificați o cale pentru a salva fişierul comprimat. Când deschideți fișierul pe care l-ați salvat, vi se solicită să specificați calea pentru fișierele. Apoi, trebuie să furnizați parola furnizată în mesajul de poștă electronică.


Dacă faceți clic pe Revocare, se oprește procesul de descărcare.

Cum se instalează o remediere rapidă Microsoft Dynamics NAV sau un fișier de actualizare

Microsoft Dynamics NAV remedierile rapide și actualizări sunt făcute disponibile ca fișiere singur. Pentru a instala o remediere rapidă Microsoft Dynamics NAV sau actualizarea, utilizați remedierea rapidă sau fișierele de actualizare pentru a înlocui fişierele de instalare Microsoft Dynamics NAV existente. Pentru a face acest lucru, urmați acești pași:
  1. Utilizați remedierea rapidă sau fișierele de actualizare pentru a înlocui fişierele următoare în clientul Microsoft Dynamics NAV instalarea.
    Nume de fișierVersiune fișierDimensiune fișierDataOraPlatformă
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Fin.exe4.0.3.248438,119,76001-Jul-200721:32x86
    Fin.exe.manifestNu este aplicabil71101-Jul-200710:24Nu este aplicabil
    Finhlink.exe4.0.3.24843120,27201-Jul-200721:32x86
    Finsql.exe4.0.3.248438,168,91201-Jul-200721:32x86
    Finsql.exe.manifestNu este aplicabil71414-Dec-200616:41Nu este aplicabil
    Nc_netb.dll4.0.3.2484379,31201-Jul-200721:31x86
    Nc_tcp.dll4.0.3.2484383,40801-Jul-200721:31x86
    Nc_tcps.dll4.0.3.2484391,60001-Jul-200721:32x86
    Ndbcs.dll4.0.3.248431,086,92801-Jul-200721:32x86
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Notă Clientul Microsoft Dynamics NAV este instalat de obicei în următorul folder:
    C:\Program Files\Microsoft Business Solutions-Navision\Client\
    Pentru a înlocui fișierele existente, urmați acești pași:
    1. Închideți Microsoft Dynamics NAV.
    2. Găsiți folderul de instalare client Microsoft Dynamics NAV.
    3. Copiați fișierele pe care l-ați descărcat.
    4. Lipiți fișierele pe care l-ați descărcat în folderul de instalare client Microsoft Dynamics NAV.
    5. În caseta de dialog Confirmare Înlocuiți fișierul , faceți clic pe Da pentru a suprascrie fișierele din folderul de instalare.
    6. Dacă remedierea rapidă sau actualizarea include versiunile traduse din fişierul fin.stx sau a fișierului fin.etx, trebuie să înlocuiţi fişierul fin.stx sau fișierul fin.etx, care este instalat în folderele specifice limba folderului de instalare.

      Pentru a înlocui fișierul fin.stx sau fin.etx, urmați acești pași.
      Notă Următorul exemplu face referire la o instalare German.
      1. Copiați orice fișier de fin.stx W1 sau fin.etx în următorul folder:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\
      2. Copiați orice fișier fin.stx sau fin.etx din folderul ENU următorul folder:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\ENU\
      3. Copiați orice fișier fin.stx sau fin.etx din folderul DEU următorul folder:
        C:\Program Files\Microsoft Business Solutions-Navision\Client\DEU\
        În unele cazuri, nou fișierele executabile client conversia în format de bază de date. De aceea, trebuie să actualizați toți clienții. Pentru opțiunea nativ, de asemenea, trebuie să actualizați Instalarea serverului.
  2. Dacă aveți Microsoft Dynamics NAV Server de aplicație instalată, înlocuiți următoarele fișiere în Microsoft Dynamics NAV Application Server de instalare.
    Nume de fișierVersiune fișierDimensiune fișierDataOraPlatformă
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Nas.exe4.0.3.248431,422,80001-Jul-200721:32x86
    Nassql.exe4.0.3.248431,463,76001-Jul-200721:32x86
    Ndbcs.dll4.0.3.248431,086,92801-Jul-200721:32x86
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Pentru a înlocui fișierele existente, urmați acești pași:
    1. Stop Microsoft Dynamics NAV Application Server.
    2. Găsiți directorul de instalare Microsoft Dynamics NAV Application Server. Microsoft Dynamics NAV Application Server este instalat de obicei în următorul folder:
      C:\Program Files\Microsoft Business Solutions-Navision\Application Server\
    3. Copiați fișierele pe care l-ați descărcat.
    4. Lipiți fișierele pe care l-ați descărcat în directorul de instalare Microsoft Dynamics NAV Application Server.
    5. Faceți clic pe Da pentru a suprascrie fișierele din directorul.
    6. Porniți Microsoft Dynamics NAV Application Server.
  3. Dacă aveți instalat driverul de Microsoft Dynamics NAV ODBC, înlocuiți următoarele fișiere în Microsoft Dynamics NAV ODBC instalarea driverului.
    Nume de fișierVersiune fișierDimensiune fișierDataOraPlatformă
    Cfront.dll4.0.3.24843873,93601-Jul-200721:32x86
    Dbm.dll4.0.3.24843345,55201-Jul-200721:32x86
    Nc_netb.dll4.0.3.2484379,31201-Jul-200721:31x86
    Nc_tcp.dll4.0.3.2484383,40801-Jul-200721:31x86
    Nc_tcps.dll4.0.3.2484391,60001-Jul-200721:32x86
    Nodbc.dll4.0.3.248431,227,72801-Jul-200721:32x86
    Nodbccfg.cfg4.0.3.24843446,46401-Jul-200711:25Nu este aplicabil
    Nodbccfg.hlpNu este aplicabil12,94014-Dec-200616:42Nu este aplicabil
    Nodbccfg.xmlNu este aplicabil2,36014-Dec-200616:42Nu este aplicabil
    Slave.exe4.0.3.2484395,69601-Jul-200721:32x86
    Pentru a înlocui fișierele existente, urmați acești pași:
    1. Găsiți directorul de instalare Microsoft Dynamics NAV ODBC driver. Microsoft Dynamics NAV ODBC driverul este instalat de obicei în următorul folder:
      C:\Program Files\Common Files\Navision\NODBC\
    2. Copiați fișierele pe care l-ați descărcat.
    3. Lipiți fișierele pe care l-ați descărcat în directorul de instalare Microsoft Dynamics NAV ODBC driver.
    4. Faceți clic pe Da pentru a suprascrie fișierele din directorul.

Soluție


Pentru a rezolva această problemă, dezactivați proprietatea MaintainSIFTIndex cheile din tabelul afectat. Apoi, activați proprietatea MaintainSIFTIndex pe aceste taste. Tabelul SIFT acum va fi reconstruită utilizând valorile corecte.

Stare


Microsoft a confirmat că aceasta este o problemă în produsele Microsoft enumerate în secțiunea "Se aplică la".

Mai multe informații


Pentru a șterge înregistrări SIFT goală, utilizați una dintre următoarele metode.

Metoda 1

  1. În Microsoft SQL Server opțiunea pentru Microsoft Dynamics NAV, indicați spre baze de date din meniul fișier și apoi faceți clic pe informații.
  2. Faceți clic pe tabele. Apoi, faceți clic pe optimizare.

Metoda 2

Utilizați SQL script-uri externe.

Referințe


Pentru mai multe informaţii, faceţi clic pe următorul număr de articol pentru a vedea articolul în baza de cunoştinţe Microsoft:

824684 Descrierea terminologiei standard care este utilizat pentru a descrie actualizările de software Microsoft