Momentan sunteți offline, așteptați să vă reconectați la internet

Browserul dvs. nu este acceptat

Trebuie să vă actualizați browserul pentru a utiliza site-ul.

Actualizați la cea mai recentă versiune Internet Explorer

rezultatele căutării inconsistente după un index conţinut este reconstruit în Exchange Server

IMPORTANT: Acest articol a fost tradus de software-ul de traducere automată Microsoft, si nu de un traducător. Microsoft vă oferă atât articole traduse de persoane, cât şi articole traduse automat, astfel incat aveti access la toate articolele din Baza noastră de informatii în limba dvs. materna. Totuşi, un articol tradus automat nu este întotdeauna perfect. Acesta poate conţine greşeli de vocabular, sintaxă sau gramatică, la fel cum un vorbitor străin poate face greşeli vorbind limba dvs. materna. Compania Microsoft nu este responsabilă pentru nici o inexactitate, eroare sau daună cauzată de traducerea necorespunzătoare a conţinutului sau de utilizarea traducerii necorespunzătoare de către clienţii nostri. De asemenea, Microsoft actualizează frecvent software-ul de traducere automată.

Faceți clic aici pentru a vizualiza versiunea în limba engleză a acestui articol: 2704862
Simptome
Luaţi în considerare următorul scenariu:
  • Instalaţi Microsoft Exchange Server 2007 sau Microsoft Exchange Server 2010.
  • Vă reconstrui indexul conţinut pentru o bază acoperire de date.
  • Executaţi o căutare pe un computer client. De exemplu, rulaţi o căutare utilizând Microsoft Outlook, Microsoft Outlook Web App sau Windows Mobile.
  • Executaţi o căutare doua utilizând acelaşi termen de căutare.
  • Executaţi o căutare treia utilizând acelaşi termen de căutare.
În acest scenariu, rezultatele care sunt returnate de fiecare căutare poate fi inconsistente. De exemplu, dacă baza acoperire de date conţine 10 cazuri de termenul de căutare, primul cercetare poate returna două instanţe, doua căutare poate returna opt instanţe şi treia căutare poate returna 10 cazuri.
Cauză
Această problemă apare dacă serviciul Microsoft Exchange Search Indexer este început atunci când se elimină indicele care urmează să fie reconstruite.
Rezoluţie
Pentru a preveni această problemă, opriţi serviciul Microsoft Exchange Search Indexer atunci când se elimină indicele care urmează să fie reconstruite.

Notă Vă recomandăm să executaţi scriptul ResetSearchIndex.ps1 pentru a opri serviciul Microsoft Exchange cercetare a cresta, şterge index vechi şi apoi reporniţi serviciul. Acest lucru obligă Exchange Server pentru a recrea catalog index de text integral.

Notă Script-ul ResetSearchIndex.ps1 este amplasat în folderul \Program Files\Microsoft\Exchange Server\Scripts\.
Informaţii suplimentare
Problema menţionată în secţiunea „Simptome"apare deoarece serviciul Microsoft Exchange Search Indexer mentine un cache-ul mapări de proprietate pentru anumite elemente care sunt în index. De obicei, un subset al proprietăţile încadrate acelaşi ID de proprietate

Cu toate acestea, proprietăţile pot fi utilizate dacă serviciul Microsoft Exchange Search Indexer nu este repornit înainte de index este reconstruit. Prin urmare, Microsoft Exchange (de căutare) pot pune uzuale proprietăți în alte locaţii. Acest lucru provoacă simptome care sunt menţionate în secţiunea „Simptome".
Referinţe
Pentru mai multe informaţii despre cum să reconstruiască catalog Index text integral în Exchange Server 2007, vizitaţi website TechNet următoarele:

http://technet.Microsoft.com/en-us/library/aa995966 (v=exchg.80) .aspx


Avertisment: acest articol a fost tradus automat

Proprietăți

ID articol: 2704862 - Ultima examinare: 08/16/2012 19:14:00 - Revizie: 1.0

  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
  • kbsurveynew kbprb kbtshoot kbmt KB2704862 KbMtro
Feedback
nc=""> var varAutoFirePV = 1; var varClickTracking = 1; var varCustomerTracking = 1; var Route = "76500"; var Ctrl = ""; document.write("