Erori SHIM legate de compatibilitatea cu cu versiunea și platforma .NET Framework

IMPORTANT: Acest articol este tradus cu ajutorul software-ului Microsoft de traducere automată și poate fi corectat prin intermediul tehnologiei Community Translation Framework (CTF). Microsoft oferă articole traduse automat, post-editate de comunitate și articole traduse de oameni, pentru a permite accesul la toate articolele din Baza noastră de cunoștințe în mai multe limbi. Articolele traduse automat și post-editate pot conține greșeli de vocabular, sintaxă și/sau gramatică. Microsoft nu este responsabil de inexactitățile, erorile sau daunele cauzate de traducerea greșită a conținutului sau de utilizarea acestuia de către clienți. Găsiți mai multe informații despre traducerea în colaborare la http://support.microsoft.com/gp/machine-translation-corrections/ro.

Faceți clic aici pentru a vizualiza versiunea în limba engleză a acestui articol: 2715633
Notă Acest articol prezintă mesaje de eroare de compatibilitate. Dacă sunteți un utilizator final, încercați rezolvare Când întâlniți o eroare de compatibilitate "Trebuie să activați .NET Framework din casetă de dialog caracteristici Windows." Pentru orice alte erori de compatibilitate, public țintă pentru conținutul este distribuitorul aplicației sau dezvoltare, trebuie să Contactați distribuitorul aplicației pentru a le spune că există o problemă pentru această aplicație.
Eroare: "Trebuie să activați .NET Framework din casetă de dialog Caracteristici Windows"
Mesaj de eroare
Această aplicație nu poate fi pornită. Trebuie să activați .NET Framework din casetă de dialog Caracteristici Windows (din Panou de control, alegeți Programe, Activare sau dezactivare caracteristici Windows).
Cauză
Această problemă apare deoarece aplicația nu este configurată într-un mod care să permită să se determine versiunea potrivită a timpul de funcționare .NET Framework. Codul de compatibilitate corespunzătoare este SHIM_GOTO_CONTROLPANEL.
Rezoluţie
Pentru a rezolva aceasta, activați .NET Framework 3.5 pe care este o caracteristică de sistem de operare Windows 7 şi Windows 8.

Pentru Windows 8

implicit, .NET Framework 3.5 este dezactivat pe Windows 8. Pentru a activa aceasta, urmați acești pași:
  1. În Ecran de început de Start, tastați primele câteva litere dePanou de control, apoi alegețiPanou de controldin Listă tabel de aplicații.
  2. ÎnPanou de control, alegețiPrograme. (Sau alegețiPrograme și caracteristiciDacă nu utilizaţi vizualizarea pe categorii implicit.)
  3. ÎnPrograme și caracteristici, alegețiCaracteristici Windows de activare sau Dezactivarepentru a deschideCaracteristici Windowscasetă de dialog.
  4. ÎnCaracteristici Windows, selectați.NET Framework 3.5 (include .NET 2.0 şi 3.0)casetă de selectare şi apoi selectaţiok.

Pentru Windows 7

implicit, .NET Framework 3.5 este activat pe Windows 7, astfel încât această eroare apare numai în cazul în care caracteristica anterioră a fost dezactivată. Pentru a reactiva .NET Framework 3.5, urmați acești pași:
  1. Din meniu Start, alegețiPanou de control.
  2. ÎnPanou de control, alegețiPrograme. (Sau alegețiPrograme și caracteristiciDacă nu utilizaţi vizualizarea pe categorii implicit.)
  3. ÎnPrograme și caracteristici, alegețiCaracteristici Windows de activare sau Dezactivarepentru a deschideCaracteristici Windowscasetă de dialog.
  4. ÎnCaracteristici Windows, selectațiMicrosoft .NET Framework 3.5.1casetă de selectare şi apoi selectaţiok.

Exonerare de răspundere pentru soluțiile terțe

Informațiile și soluția din acest document reprezintă punctul de vedere actual al Microsoft Corporation cu privire la aceste probleme, valabil la data publicării. Această soluție este disponibilă prin Microsoft sau un furnizor terț. Nu recomandăm cu precădere niciun furnizor sau soluție terță care ar putea fi descrisă în acest articol. Este posibil să existe și alți furnizori terți sau alte soluții terțe care să nu fie prezentate în acest articol. Deoarece trebuie să răspundem la condițiilor variabile ale pieței, aceste informații nu trebuie interpretate ca un angajament al companiei Microsoft. Nu putem garanta sau subscrie la acuratețea informațiilor sau a oricărei soluții care este prezentată de Microsoft sau de oricare dintre furnizorii terți menționați.

Microsoft nu oferă nicio garanție și exclude toate reprezentările, garanțiile și condițiile, fie exprese, implicite sau statutare. Acestea includ, dar nu sunt limitate la reprezentări, garanții și condiții de titlu, NEÎNCĂLCARE, condiții satisfăcătoare, VANDABILITATE și potrivire pentru un anumit scop, cu privire la orice serviciu, soluţie, produs, sau orice alte materiale sau informații. În nicio situație compania Microsoft nu va fi responsabilă pentru nicio soluție terță menționată în acest articol.

Eroare: "Această aplicație nu poate fi pornită"
Mesaj de eroare
Această aplicație nu poate fi pornită.
Cauză
Aplicația nu este configurată într-un mod care să facă posibilă determinarea versiunea potrivite a runtime-ului .NET Framework. Codul SHIM corespunzător este SHIM_NOVERSION_FOUND.
Rezoluţie
Nu puteți rezolva singur problema de configurare. Contactați distribuitorul aplicației pentru a rezolva problema.
Eroare: "Se bazează pe o versiune de .NET Framework care nu este acceptată pe acest dispozitiv"
Mesaj de eroare
Această aplicație nu poate fi pornită. Se bazează pe o versiune de .NET Framework care nu este acceptată pe acest dispozitiv.
Cauză
Această problemă apare deoarece aplicația nu a fost creată pentru a se executa pe acest dispozitiv. De exemplu, este posibil să încercați să executați o aplicație care este creată pentru un procesor Intel pe un dispozitiv care utilizează un procesor ARM. Codul SHIM corespunzător este SHIM_UNSUPPORTED_PLATFORM.
Rezoluţie
Nu puteți rezolva singur problema de configurare. Contactați distribuitorul aplicației pentru a instala versiunea corectă a aplicației.
Despre mesajele de eroare SHIM
Când porniți o aplicație Microsoft .NET Framework, un program SHIM determină ce versiune de motor comun de execuţie pentru limbaje (CLR) să încărce, apoi îl încarcă și pornește aplicația. Dacă programul SHIM întâlnește o eroare (de exemplu, dacă nu găsește o versiune compatibilă de .NET Framework pe computer), se afișează un mesaj de eroare cu instrucțiuni. Acest articol oferă informații despre codurile de eroare SHIM_NOVERSION_FOUND, SHIM_GOTO_CONTROLPANELși SHIM_UNSUPPORTED_PLATFORM.

Pentru mai multe informații despre erorile de inițializare .NET Framework, accesați și consultați următoarea pagină Web MSDN:

Avertisment: acest articol a fost tradus automat

Свойства

Номер статьи: 2715633 — последний просмотр: 10/02/2016 07:16:00 — редакция: 20.0

Microsoft .NET Framework 4.5

  • kbquadranttechsupp kbconsumer kbsurveynew kbtshoot kbexpertiseinter kbmt KB2715633 KbMtro
Отзывы и предложения