Simptome
Să presupunem că utilizați Microsoft BizTalk Server 2010 sau 2013. Când utilizați o componentă de canal particularizat pentru a apela serviciul de transformare Enterprise Service Bus (ESB) pentru a transforma mesaje în ESB Toolkit 2.1, proprietatea DocumentSpecName context este configurată incorect pe mesajul de ieșire și primiți următorul mesaj de eroare:
Nume jurnal: aplicație
Sursă: BizTalk Server
ID eveniment: 5720
Categorie activitate: BizTalk Server
Nivel: eroare
Descriere: exista o eroare de executare canal de trimitere: "ESBTransform.SendPipeline1, ESBTransform, versiune = 1.0.0.0, Culture neutral, PublicKeyToken = = ca09cc62b15919a7" sursă: "Flat fișiere de asamblare" Send Port: "<SendPortName >" URI: "<SendPortURI>" motiv: tipul de document "http://ESBTransform.FlatFileSchema1#TargetRoot" nu se potrivesc cu oricare dintre schemele dat.
Cauza
Această problemă apare deoarece ESB transformare Service nu setează proprietatea context DocumentSpecName mesajul de ieșire pentru a fi tipul de schemă țintă după transformare.
Rezolvare
Informații despre remedierea rapidă
O remediere rapidă compatibilă este disponibilă de la Microsoft. Cu toate acestea, această remediere rapidă este destinată pentru a corecta doar problema descrisă în acest articol. Aplicați această remediere rapidă numai pentru sistemele care întâmpină această problemă anume.
Dacă remedierea rapidă este disponibilă pentru descărcare, există o secțiune "Descărcare disponibilă pentru remediere rapidă" în partea de sus a acestui articol din baza de cunoștințe. Dacă nu apare această secţiune, trimite o solicitare de la serviciul pentru clienți Microsoft de asistență pentru a obţine remedierea rapidă.
Notă Dacă se produc probleme suplimentare sau este necesară depanarea, poate fi necesar să creați o solicitare de asistenţă separată. Costurile de obicei pentru suport se vor aplica pentru sprijin suplimentar, întrebări și probleme care nu sunt specifice pentru această remediere rapidă . Pentru o listă completă cu numerele de telefon ale clienților servicii și asistență Microsoft sau pentru a crea o solicitare de asistenţă separată, vizitați următorul site Web Microsoft:
http://support.microsoft.com/contactus/?ws=supportNotă Formularul "Descărcare disponibilă pentru remediere rapidă" afişează limbile pentru care este disponibilă remedierea rapidă. Dacă nu vedeți limba dvs., înseamnă că o remediere rapidă nu este disponibilă pentru respectiva limbă.
Informații despre actualizarea cumulativă
Această problemă a fost rezolvată mai întâi în următoarea actualizare cumulativă de BizTalk Server 2013:
Cerințe preliminare
Pentru a aplica această remediere rapidă, trebuie să aveți BizTalk ESB Toolkit 2.1 instalat.
Cerinţă de repornire
Nu trebuie să reporniți computerul după aplicarea acestei remedieri rapide.
Informații despre înlocuirea remedierilor rapide
Această remediere rapidă nu înlocuiește nicio altă remediere rapidă.
Informații despre fișier
Versiunea în limba engleză a acestei remedieri rapide are atributele de fişier (sau atribute de fişier mai recente) enumerate în următorul tabel. Datele şi orele acestor fişiere sunt exprimate în listă în ora universală (UTC). Când vizualizaţi informaţiile despre fișier, acesta este convertit la ora locală. Pentru a găsi diferenţa dintre UTC şi ora locală, utilizaţi fila Fusul orar în elementul de Data şi ora în Panoul de Control.
Nume de fișier |
Versiune fișier |
Dimensiune fișier |
Data |
Ora |
Platformă |
---|---|---|---|---|---|
Microsoft.Practices.ESB.Itinerary.Services.dll |
2.1.1.0 |
24576 |
13-Oct-2014 |
13:11 |
x86 |
Mai multe informații
Pentru mai multe informaţii despre terminologia actualizărilor de software, consultați Descrierea terminologiei standard care este utilizat pentru a descrie actualizările de software Microsoft.
Stare
Microsoft a confirmat că aceasta este o problemă cu produsele Microsoft enumerate în secţiunea „Se aplică la".