Momentan sunteți offline, așteptați să vă reconectați la internet

Mesaj de eroare "Authorization_RequestDenied" atunci când încercați să modificați o parolă, dacă utilizați Graph API

IMPORTANT: Acest articol este tradus cu ajutorul software-ului Microsoft de traducere automată și poate fi corectat prin intermediul tehnologiei Community Translation Framework (CTF). Microsoft oferă articole traduse automat, post-editate de comunitate și articole traduse de oameni, pentru a permite accesul la toate articolele din Baza noastră de cunoștințe în mai multe limbi. Articolele traduse automat și post-editate pot conține greșeli de vocabular, sintaxă și/sau gramatică. Microsoft nu este responsabil de inexactitățile, erorile sau daunele cauzate de traducerea greșită a conținutului sau de utilizarea acestuia de către clienți. Găsiți mai multe informații despre traducerea în colaborare la http://support.microsoft.com/gp/machine-translation-corrections/ro.

Faceți clic aici pentru a vizualiza versiunea în limba engleză a acestui articol: 3004133
PROBLEMA
Dacă încercați să modificați parola unui utilizator Microsoft Azure Active Directory (Azure AD) și dacă setarea Organizațională rolpentru acel utilizator este setată la orice opțiune de "Administrator", procesul nu reușește și generează următorul mesaj de eroare:

{"odata.error":{"code":"Authorization_RequestDenied","message":{"lang":"en","value":"Insufficient privileges to complete the operation."}}}

Când permisiunea de citire și scriere date de Director la cerere sau principal al serviciului de aplicație, activați aplicația pentru a modifica parola o Azure obișnuite AD utilizator prin utilizarea API grafic. Această setare este arătată în următoarea fotografie de ecran.
permisiuni de ecran
Poate delega un utilizator Azure AD ca administrator prin modificarea setarea Organizațională rol utilizator, așa cum se arată în următoarea fotografie de ecran.
rol de ecran
CAUZA
Această problemă apare deoarece utilizatorii care au oricare din rolurile organizaţionale "Administrator" nu sunt membri ai "firmă" utilizator cont de Administrator"sau" în roluri administrative Office 365.
SOLUȚIE
Pentru a rezolva această problemă, adăugați aplicația "Administrator de firmă" în roluri administrative Office 365. Pentru aceasta, executați toate următoarele Azure AD modulul pentru cmdleturi Windows PowerShell (MSOL):

   #-----------------------------------------------------------   # This will prompt you for your tenant's credential   # You should be able to use your your Azure AD administrative user name   # (in the admin@tenant.onmicrosoft.com format)   #-----------------------------------------------------------   Connect-MsolService       #-----------------------------------------------------------   # Replace the Application Name with the name of your    # Application Service Principal   #-----------------------------------------------------------   $displayName = "Application Name"   $objectId = (Get-MsolServicePrincipal -SearchString $displayName).ObjectId       #-----------------------------------------------------------   # This will add your Application Service Prinicpal to    # the Company Administrator role   #-----------------------------------------------------------   $roleName = "Company Administrator"                 Add-MsolRoleMember -RoleName $roleName -RoleMemberType ServicePrincipal -RoleMemberObjectId $objectId
De asemenea, trebuie să adăugați aplicația "Administrator de cont utilizator" în Office 365 roluri administrative dacă utilizatorul Azure AD are oricare dintre următoarele roluri organizațională "Administrator":
  • administrator general
  • Administrator de facturare
  • Administrator de consolidare servicii

Pentru aceasta, executați toate cmdlet MSOL următoarele:

   #-----------------------------------------------------------   # This will prompt you for your tenant's credential   # You should be able to use your your Azure AD administrative user name   # (in the admin@tenant.onmicrosoft.com format)   #-----------------------------------------------------------   Connect-MsolService      #-----------------------------------------------------------   # Replace the Application Name with the name of your    # Application Service Principal   #-----------------------------------------------------------   $displayName = "Application Name"   $objectId = (Get-MsolServicePrincipal -SearchString $displayName).ObjectId      #-----------------------------------------------------------   # This will add your Application Service Principal to    # the Company Administrator role   #-----------------------------------------------------------   $roleName = "User Account Administrator"     Add-MsolRoleMember -RoleName $roleName -RoleMemberType ServicePrincipal -RoleMemberObjectId $objectId
După ce executați ambele seturi de caracteristici cmdlet, aplicația va fi activată pentru a modifica parola toate rolurile de "Administrator" organizațională.

Notă Aceasta poate dura până la 30 de minute pentru permisiunea de a fi aplicate la aplicarea Service Principal după ce adăugați permisiunile la rolurile de administrare Office 365.
MAI MULTE INFORMAȚII
Pentru mai multe informații despre resetarea parolelor de utilizator utilizând Graph API, consultaţi următorul site Web Microsoft Azure:

Încă mai aveți nevoie de ajutor? Accesați Comunitatea Office 365 site-ul sau Forumuri Azure Active Directory .

Avertisment: acest articol a fost tradus automat

Proprietăți

ID articol: 3004133 - Ultima examinare: 11/12/2015 18:49:00 - Revizie: 3.0

Microsoft Office 365, Microsoft Azure Active Directory

  • o365022013 o365 o365e o365m o365a kbgraphxlink kbmt KB3004133 KbMtro
Feedback