Conectați-vă cu Microsoft
Conectați-vă sau creați un cont
Salut,
Selectați un alt cont.
Aveți mai multe conturi
Alegeți contul cu care doriți să vă conectați.

Simptome

Să luăm în considerare următorul scenariu:

  • Utilizați Folder temporar într-un port de trimitere a FTP Microsoft BizTalk Server 2010.

  • Selectați ordonată de livrare și activați de rutare pentru mesaje nereușite opțiunile în pagina de Transport Advanced Options pentru FTP port de trimitere.

  • Setați valoarea de reprezentare ca binare în caseta de dialog Proprietăţi de FTP Transport pentru acest FTP portului de trimitere.

În acest scenariu, anumite mesaje nu pot fi transferate la serverul FTP intermitent. În plus, primiţi următorul mesaj de eroare:

Adaptorul nu a reușit să transmită mesajul va trimite port "< SendPortName >" cu URL-ul "< FTPAddress >". Acesta va fi retransmis după interval de reîncercare specificat pentru acest Port de trimitere. Detalii: "The remote server refuzat o conexiune de date. Verificați permisiunile pentru sistemul de la distanţă. "

După ce primiți mesajul de eroare precedent, mesajele sunt reîncearcă pentru a trimite la server FTP ca pe setările de port de trimitere. În timpul Reîncercare, primiţi următorul mesaj de eroare:

Adaptorul nu a reușit să transmită mesajul va trimite port "< SendPortName >" cu URL-ul "< FTPAddress >". Acesta va fi retransmis după interval de reîncercare specificat pentru acest Port de trimitere. Detalii: "o eroare neașteptată a apărut la procesarea unui mesaj. Textul asociate cu excepția este "element rădăcină lipsește.". "

Apoi, mesajele sunt distribuite în locația de livrare nereușită.

Notă Această problemă a fost deja rezolvată în Microsoft BizTalk Server 2013 şi BizTalk Server 2013 R2.

Cauza

Această problemă apare deoarece Reîncercare în modul binar confundă dezasamblor. De aceea, se produce eroarea "element rădăcină lipseşte".

Rezolvare

Informații despre actualizarea cumulativă

Această problemă a fost rezolvată mai întâi în următoarea actualizare cumulativă de BizTalk Server:

Stare

Microsoft a confirmat că aceasta este o problemă cu produsele Microsoft enumerate în secţiunea „Se aplică la".

Aveți nevoie de ajutor suplimentar?

Doriți mai multe opțiuni?

Explorați avantajele abonamentului, navigați prin cursurile de instruire, aflați cum să vă securizați dispozitivul și multe altele.

Comunitățile vă ajută să adresați întrebări și să răspundeți la întrebări, să oferiți feedback și să primiți feedback de la experți cu cunoștințe bogate.

Au fost utile aceste informații?

Cât de mulțumit sunteți de calitatea limbajului?
Ce v-a afectat experiența?
Apăsând pe Trimitere, feedbackul dvs. va fi utilizat pentru a îmbunătăți produsele și serviciile Microsoft. Administratorul dvs. IT va avea posibilitatea să colecteze aceste date. Angajamentul de respectare a confidențialității.

Vă mulțumim pentru feedback!

×