Simptom
Când faceți clic pe butonul Test și activați cutie poștală pe o înregistrare de cutie poștală în Dynamics 365, se înregistrează următorul și nu reușește rezervare, persoane de contact și activități de sincronizare:
"Rezervări, persoane de contact și activități nu poate fi sincronizat pentru cutia poștală < nume cutie poștală > deoarece cutie poștală utilizatorul nu are permisiuni suficiente pe această Căsuță poștală.
Cod de eroare Server de e-mail: Crm.80042f09.UserNotAssignedRoles "
Dacă faceți clic pentru a vedea detaliile, se afișează următoarele informații suplimentare:
T:1738ActivityId: 3594490d-96d3-493b-861e-023b016a6050 > Exception: excepție netratată: Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncException: nu a reușit să regăsească starea de sincronizare: excepție netratată: System.ServiceModel.FaultException'1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, versiune = 8.0.0.0, Culture neutral, PublicKeyToken = = 31bf3856ad364e35]]: SecLib::RetrievePrivilegeForUser failed - roluri nu sunt atribuite de utilizator. Returnează hr =-2147209463, User: < GUID > detalii: 3594490d-96d3-493b-861e-023b016a6050-2147209463 SecLib::RetrievePrivilegeForUser nu a reușit - roluri nu sunt atribuite de utilizator. Returnează hr =-2147209463, User: < GUID >...
Cauza
Un rol de securitate Dynamics 365 nu este atribuită utilizatorului.
Rezolvare
Atribui un rol de securitate Dynamics 365 utilizatorului. Pentru pas instrucţiuni despre cum se atribuie un rol de securitate, faceți clic pe aici.