După actualizarea la Dynamics 365 (decembrie 2016), o soluție care a fost importat într-o versiune anterioară (de exemplu, în Dynamics CRM) nu reușește în timpul dezinstalării/upgrade cu un mesaj de eroare similar cu "'Rol' cu ID-ul [RoleID] este necesară de soluția [SolutionName]."

Simptom

Înainte de upgrade la actualizarea din decembrie 2016 pentru Dynamics 365, se instalează o soluție care conține un rol particularizate. După upgrade-ul organizaţionale, soluția nu mai poate fi dezinstalat/upgrade din cauza o dependență între rolul și o altă soluție, cel mai frecvent soluția de sistem. Această problemă nu este introdus sau cauzate de utilizator.

Cauza

În Dynamics 365, Business Process fluxurilor (BPFs) sunt reprezentate de entități clasa care adere la modelul de securitate Dynamics 365 la fel ca orice altă entitate. Aceste entităţi sunt generate în timpul decembrie 2016 upgrade la Dynamics 365. Pentru a vă asigura că toate rolurile existente au accesul corespunzător la BPFs, BPF privilegii sunt atribuite automat existente roluri în timpul upgrade-ului. În anumite cazuri, aceste atribuirile de privilegii pot avea ca rezultat incorect dependențele între soluții.

Rezolvare

  1. În Dynamics 365, navigați la Setări > Securitate > roluri de securitate. Apoi selectați rolul de securitate care apare în eroare și deschideți fila Business Process fluxurile.

  2. Ia notă de privilegii care sunt atribuite pentru BPFs. O captură de ecran este utilă, deoarece este o reprezentare vizuală.

  3. Debifați toate privilegiile și apoi Salvați modificările. Acest lucru ar trebui să elimine toate dependențele.
    Notă: nu să poată edita privilegiile dacă rolul face parte dintr-o soluție și este marcat neparticularizabilă. Dacă soluția este negestionat, aveți posibilitatea să Actualizați'Particularizabil' gestionate de proprietate a rolului și continuați. În cazul în care o soluție gestionată, contactați Microsoft Support pentru a face rolul particularizabil.

  4. Reatribuire privilegii care s-au atribuite anterior, apoi Salvați și închideți caseta de dialog. Acest lucru va asigura că accesul necesar la diferite roluri s-a reținut.

Este posibil să existe dependențele între mai multe roluri și soluții. În acest caz, efectuați pașii anteriori pentru fiecare dintre roluri care sunt raportate cu probleme.

Aveți nevoie de ajutor suplimentar?

Extindeți-vă competențele
Explorați instruirea
Fiți primul care obține noile caracteristici
Alăturați-vă la Microsoft Insider

V-a fost de ajutor această informație?

Vă mulțumim pentru feedback!

Vă mulțumim pentru feedback! Se pare că ar fi util să luați legătura cu unul dintre agenții noștri de asistență Office.

×