Simptom

Când faceți clic pe butonul Test și activați cutie poștală pe o înregistrare de cutie poștală în Dynamics 365, secțiunea rezultate test arată eroare și se înregistrează următorul:

"Mesajul de poștă electronică"cutia poștală acum este conectat la Dynamics 365 "Imposibil de trimis, deoarece an error occurred while stabili o conexiune sigură la serverul de poștă electronică. Cutie poștală [nume cutie poștală] nu se sincronizeze. A fost notificat proprietarul profil de server de poștă electronică Microsoft Exchange Online.

Cod de eroare Server de e-mail: returnat de Http server interzis excepție. "

Dacă faceți clic pe detalii, apar următoarele detalii suplimentare:

"Eroare: System.Net.WebException: cererea nu a reușit cu stare HTTP 403: Forbidden.    la System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse (SoapClientMessage mesaj WebResponse răspuns, flux responseStream, Boolean asyncCall)    la System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke (IAsyncResult asyncResult)    la Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem (IAsyncResult asyncResult)    la Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()"

Cauză

Dynamics 365 comunică cu Microsoft Exchange utilizând Exchange Web Services (EWS) cereri. Dacă este dezactivat EWS, va apărea această eroare. Iată câteva metode potențiale EWS poate fi dezactivat sau restricționat în Exchange:

  1. EWS este dezactivată pentru cutia poștală

  2. EWS este dezactivată pentru întreaga organizaţie

  3. EwsApplicationAccessPolicy este setată la EnforceAllowList și EwsAllowList permite accesul la Dynamics 365 (CRM).

  4. EwsApplicationAccessPolicy este setată la EnforceBlockList și EwsBlockList include Dynamics 365 (CRM).

Rezolvare

Dacă problema apare numai pentru anumite cutii poștale, Verificați dacă EWS este dezactivată pentru cutia poștală:

  1. Verificați mai întâi pentru a vedea dacă a fost dezactivat EWS pentru cutia poștală. Utilizați următoarea comandă PowerShell: Get-CASMailbox < cutie poștală-alias > | Situat EwsEnabled

  2. Dacă EwsEnabled este setată la False, utilizați următoarea comandă PowerShell pentru a activa Exchange Web Services (EWS) pentru cutia poștală: Set-CASMailbox < cutie poștală-alias > - EwsEnabled $True IMPORTANT: După executarea acestei comenzi, este posibil să treacă până la 120 de minute înainte de a se aplică modificările setare.

Dacă problema se produce pentru toate cutiile poștale, Verificați dacă EWS este dezactivat la nivel de organizație sau dacă EwsAllowList este utilizată pentru a limita permisă ce trafic EWS.

  1. Utilizați următoarea comandă PowerShell pentru a vedea dacă există setări EWS sunt configurate: Get-OrganizationConfig | nume situat EwsEnabled, EwsApplicationAccessPolicy, EwsBlockList, EwsAllowList

  2. Verificați că EwsEnabled nu este setată la False. Pentru a seta EwsEnabled la adevărat dacă în prezent este setat la fals se poate utiliza următoarea comandă: Set-OrganizationConfig - EwsEnabled $True IMPORTANT: După executarea acestei comenzi, este posibil să treacă până la 120 de minute înainte de a se aplică modificările setare.

  3. Dacă EwsApplicationAccessPolicy este setat la EnforceAllowList și EwsAllowList nu conține o valoare pentru CRM (exemplu: CRM / *), aceasta va împiedica Dynamics 365 (CRM) pentru a comunica cu Exchange. Utilizați următoarea comandă pentru a actualiza lista pentru a include CRM / * și orice alte aplicații doriți să permiteți (< PreviousAllowList > în următorul exemplu): Set-OrganizationConfig - EwsApplicationAccessPolicy: EnforceAllowList - EwsAllowList: CRM / *, < PreviousAllowedList > IMPORTANT: După executarea acestei comenzi, este posibil să treacă până la 120 de minute înainte de a se aplică modificările setare.

  4. Dacă EwsApplicationAccessPolicy este setat la EnforceBlockList și EwsAllowList conține o valoare pentru CRM (exemplu: CRM / *), aceasta va împiedica Dynamics 365 (CRM) pentru a comunica cu Exchange. Utilizați următoarea comandă pentru a actualiza lista pentru a nu mai include CRM: Set-OrganizationConfig - EwsApplicationAccessPolicy: EnforceBlockList - EwsBlockList: < PreviousBlockList cu CRM eliminat > IMPORTANT: După executarea acestei comenzi, este posibil să treacă până la 120 de minute înainte de a se aplică modificările setare.

Mai multe informații

Consultați următoarele articole pentru mai multe informații modificarea setărilor Exchange utilizând PowerShell și controlul accesului EWS:

Exchange Server PowerShell (Exchange Management Shell) https://docs.Microsoft.com/PowerShell/Exchange/Exchange-Server/Exchange-Management-shell?view=Exchange-PS

Conectarea la Exchange Online PowerShell https://docs.Microsoft.com/PowerShell/Exchange/Exchange-Online/Connect-to-Exchange-Online-PowerShell/Connect-to-Exchange-Online-powershell?view=Exchange-PS

Control acces la EWS în Exchange https://docs.Microsoft.com/Exchange/Client-Developer/Exchange-Web-Services/How-to-control-Access-to-EWS-in-Exchange

Set-CASMailbox https://docs.Microsoft.com/PowerShell/module/Exchange/Client-Access/set-casmailbox?view=Exchange-PS

Aveți nevoie de ajutor suplimentar?

Extindeți-vă competențele
Explorați instruirea
Fiți primul care obține noile caracteristici
Alăturați-vă la Microsoft Insider

V-a fost de ajutor această informație?

Cât de mulțumit sunteți de calitatea traducerii?

Ce v-a afectat experiența?

Aveți feedback suplimentar? (Opțional)

Vă mulțumim pentru feedback!

×