Salt la conținutul principal
Asistență
Conectare

Pachetul de securitate și calitate pentru .NET Framework 4,6, 4.6.1, 4.6.2, 4,7, 4.7.1, 4.7.2 pentru Windows 7 SP1 și Windows Server 2008 R2 SP1 și Windows Server 2008 SP2 (KB4578963)

Se aplică la:

Microsoft .NET Framework 4,6 Microsoft .NET Framework 4.6.1 Microsoft .NET Framework 4.6.2 Microsoft .NET Framework 4,7 Microsoft .NET Framework 4.7.1 Microsoft .NET Framework 4.7.2

IMPORTANT Verificați dacă ați instalat actualizările necesare listate în secțiunea cum să obțineți această actualizare înainte de a instala această actualizare.

IMPORTANTE Unii clienți care utilizează Windows Server 2008 R2 SP1 și-au activat programul de completare ESU Multiple Activation Key (MAK) înainte de a instala actualizările de la 14 ianuarie, 2020 pot necesita reactivarea cheii. Reactivarea pe dispozitivele afectate ar trebui să fie necesară doar o singură dată.  Pentru informații despre activare, consultați această publicare pe blog .

IMPORTANT Fișierele cab de scanare WSUS vor fi disponibile în continuare pentru Windows 7 SP1 și Windows Server 2008 R2 SP1. Dacă aveți un subset de dispozitive care execută aceste sisteme de operare fără ESU, acestea pot apărea ca neconforme în seturile de instrumente de gestionare și conformitate.

IMPORTANT Clienții care au achiziționat actualizarea de securitate extinsă (ESU) pentru versiunile locale ale acestor sisteme de operare trebuie să urmeze procedurile din KB4522133 pentru a continua să primească actualizări de securitate după ce asistența extinsă se termină pe 14 ianuarie 2020. Pentru mai multe informații despre ESU și ce ediții sunt acceptate, consultați KB4497181.

IMPORTANT Începând cu data de 15 ianuarie 2020, va apărea o notificare pe ecran complet care descrie riscul de a continua să utilizați Windows 7 Service Pack 1 după ce ajunge la sfârșitul asistenței pe 14 ianuarie 2020. Notificarea va rămâne pe ecran până când interacționați cu aceasta. Această notificare va apărea doar în următoarele ediții de Windows 7 Service Pack 1:

Notă Notificarea nu va apărea pe mașini sau mașini asociate domeniului în modul chioșc.

IMPORTANT Începând din luna august, 2019, actualizările pentru .NET Framework 4,6 și versiunile de mai sus, pentru Windows Server 2008 R2 SP1 și Windows 7SP1, necesită asistență pentru semnarea codului SHA-2. Asigurați-vă că aveți cele mai recente actualizări Windows înainte de a aplica această actualizare pentru a evita problemele de instalare. Pentru mai multe informații detaliate despre actualizările de asistență pentru semnarea codului SHA-2, consultați KB 4474419.

IMPORTANT Toate actualizările pentru .NET Framework 4.7.2, 4.7.1, 4,7, 4.6.2, 4.6.1 și 4,6 necesită ca actualizarea d3dcompiler_47.dll să fie instalată. Vă recomandăm să instalați actualizarea d3dcompiler_47.dll inclusă înainte de a aplica această actualizare. Pentru mai multe informații despre d3dcompiler_47.dll, consultați KB 4019990.

IMPORTANT Dacă instalați un pachet lingvistic după ce instalați această actualizare, trebuie să reinstalați această actualizare. Prin urmare, vă recomandăm să instalați pachetele lingvistice de care aveți nevoie înainte să instalați această actualizare. Pentru mai multe informații, consultați adăugarea pachetelor lingvistice la Windows.

Rezumat

Îmbunătățiri de securitate

O vulnerabilitate de dezvăluire a informațiilor există atunci când .NET Framework gestionează în mod incorect obiectele din memorie. Un atacator care a exploatat cu succes vulnerabilitatea poate divulga conținutul memoriei unui sistem afectat. Pentru a exploata vulnerabilitatea, un atacator autentificat ar trebui să ruleze o aplicație special creată. Actualizarea abordează vulnerabilitatea prin corectarea modului în care .NET Framework gestionează obiectele din memorie.

Pentru a afla mai multe despre vulnerabilități, accesați următoarele vulnerabilități și expuneri comune (CVE).

Îmbunătățiri ale calității și fiabilității

SQL

-A abordat o eroare care a apărut uneori atunci când un utilizator se conectează la o bază de date SQL Azure, a efectuat o operațiune bazată pe enclavă, apoi conectată la o altă bază de date de sub același server care are același URL de atestare și a efectuat o operațiune de enclavă pe al doilea server.

CLR1

-S-a adăugat o variabilă de configurare CLR Thread_AssignCpuGroups (1 în mod implicit) care poate fi setată la 0 pentru a dezactiva atribuirea automată a grupului CPU efectuată de CLR pentru fire noi create de firele filet. Start () și filetate, astfel încât o aplicație să își poată răspândi propriul fir.

-S-au adresat o deteriorare rară a datelor care pot apărea atunci când se utilizează API-ul nou, cum ar fi nesigur. ByteOffset

ASP.NET

-Refacerea cu handicap a AppPathModifier în ieșirea din controlul ASP.Net.

-Obiectele HttpCookie din contextul solicitării ASP.Net vor fi create cu valori implicite configurate pentru semnalizările de module cookie în loc de. Valori implicite primitive în stil NET pentru a se potrivi cu comportamentul ' New HttpCookie (Name) '.

Probleme cunoscute în această actualizare

Simptom

Această actualizare nu se instalează și returnează oricare dintre următoarele mesaje de eroare:

  • -2146762495

  • Un certificat obligatoriu nu se află în perioada sa de valabilitate atunci când se verifică împotriva ceasului de sistem curent sau a timestamp-ului în fișierul semnat.

Soluție de evitare

Această problemă a fost corectată printr-o lansare versiunea 2 a acestui pachet.  Urmați instrucțiunile de la cum să obțineți și instalați actualizarea pentru a obține versiunea actualizată.

Dacă ați instalat deja versiunea 1 din această actualizare, nu este necesară nicio acțiune.

Aveți nevoie de ajutor suplimentar?

Extindeți-vă competențele
Explorați instruirea
Fiți primul care obține noile caracteristici
Alăturați-vă la Microsoft Insider

V-a fost de ajutor această informație?

Vă mulțumim pentru feedback!

Vă mulțumim pentru feedback! Se pare că ar fi util să luați legătura cu unul dintre agenții noștri de asistență Office.

×