Business Rules (Portable Business Logic) may not function correctly or create errors when a user runs Business Process Flows without sufficient privileges on the Process entity

This article provides a resolution for the issue that Business Rules (Portable Business Logic) may not work as expected or errors occur when a user runs Business Process Flows without sufficient privileges on the Process entity.

Applies to:   Microsoft Dynamics CRM
Original KB number:   4025533

Symptoms

Business Rules fail to execute or Business Process Flows show an error message that begins with Web Service Plug-in failed in SdkMessageProcessingStepId: (...).

Cause

If a user's security role has insufficient privileges on the Process entity, which refers to the internal Workflow table, Business Rules and Business Process Flows will fail to generate, load, and execute properly on first load, causing unexpected behavior or intermittent errors. When this occurs, the state is cached, and a subsequent user, whose security role has sufficient privileges tries to load and execute the same Business Rules and Business Process Flows, will experience failure.

To check for access levels, go to Settings > Security > Security Roles > select a security role > Customization tab > Process entity. The Read column should be full green (Organization-level access).

Resolution

To fix this issue, follow these steps:

  1. Make sure all security roles have full Organization-level read privileges for the Process entity.
  2. Publish the customizations by going to Settings > Customization > Customize the System.