Устранение неполадок с поврежденной публикацией в Publisher


Версия этой статьи для Microsoft Publisher 98 можно найти в статье 191131 .

Аннотация


Если вы столкнетесь с непредвиденным поведением при использовании публикации в приложении Microsoft Publisher, возможно, ее публикация повреждена. Признаки повреждения публикации включают в себя следующее:
  • Появляется сообщение об ошибке неверной страницы, Общая ошибка защиты или недопустимая инструкция.
  • При попытке открыть публикацию появляется одно из следующих сообщений об ошибке:
    -Это не публикация Publisher.
    -Publisher не может открыть тип файла, представленного <именем файла>.
    -Часть файла отсутствует.
  • Появляется сообщение об ошибке "недостаточно памяти" или сообщение об ошибке "недостаточно системных ресурсов".
Примечание. Вы можете получить одно из этих сообщений об ошибке по другим причинам, кроме поврежденной публикации. Однако если это происходит только в том случае, если вы используете определенную публикацию, эта публикация, скорее всего, повреждена.

Дополнительная информация


Чтобы устранить эту проблему, перезагрузите компьютер в безопасном режиме. Затем используйте соответствующие способы устранения проблемы.Примечание. Приведенные ниже действия могут отличаться в зависимости от версии установленной на компьютере операционной системы Microsoft Windows. В этом случае для выполнения этих действий см. документацию к продукту.

Перезагрузка компьютера в безопасном режиме

Чтобы перезагрузить компьютер в безопасном режиме, используйте соответствующий способ для вашей версии Microsoft Windows.
  1. Завершите работу и перезагрузите компьютер.
  2. Когда появится сообщение "выберите операционную систему для запуска", нажмите клавишу F8.
  3. В меню дополнительных вариантов Windows с помощью клавиш со стрелками выберите пункт безопасный режим, а затем нажмите клавишу ВВОД.
  4. Если у вас есть компьютер с двойной загрузкой или многозагрузочный компьютер, выберите в списке нужную операционную систему и нажмите клавишу ВВОД.
Чтобы получить дополнительные сведения о безопасном режиме, щелкните приведенные ниже номера статей базы знаний Майкрософт.
315222 Описание возможных вариантов безопасного режима загрузки Windows XP
202485 Описание режима безопасной загрузки в Windows 2000
180902 Запуск компьютера под управлением Windows 98 в безопасном режиме

Попытка открыть публикацию

После запуска компьютера в безопасном режиме попробуйте открыть публикацию. Если вы не получаете сообщение об ошибке, программа или устройство, которое загружено, когда компьютер находится в обычном режиме, может помешать публикации.

Если вы не можете открыть публикацию

Если вы не можете открыть публикацию после запуска компьютера в безопасном режиме, воспользуйтесь приведенными ниже способами в том порядке, в котором они представлены.

Вставка публикации в файл программы Publisher

Вы можете открыть публикацию, вставив ее в файл программы Publisher. Для этого выполните следующие действия:
  1. Откройте проводник.
  2. Найдите файл публикации.
  3. Щелкните файл публикации правой кнопкой мыши и выберите команду Копировать.
  4. Закройте проводник Windows.
  5. Нажмите кнопку Пуск, выберите пункт выполнить, введите в поле Открыть одну из указанных ниже строк и нажмите кнопку ОК.
    Для издателя 2003c:\Program Files\Microsoft Office\Office11для Publisher 2002c:\Program Files\Microsoft Office\Office10for Publisher 2000c:\Program Files\Microsoft Office\Office
  6. Щелкните файл программы MSPUB. exe правой кнопкой мыши и выберите команду Вставить.
Если вы не можете открыть публикацию, перейдите к следующему способу.

Дважды щелкните файл публикации в проводнике Windows

Чтобы дважды щелкнуть файл публикации в проводнике Windows, выполните указанные ниже действия.
  1. Нажмите кнопку Пуски выберите пункты программы, а затем — проводник.
  2. Найдите файл публикации.
  3. Дважды щелкните файл публикации.
Если вы не можете открыть публикацию, перейдите к следующему способу.

Настройка Publisher для скрытия изображений

Чтобы настроить Publisher для скрытия изображений, выполните указанные ниже действия.
  1. Запустите Publisher и откройте новую пустую публикацию.
  2. В меню вид выберите пункт Отображение рисунка в Publisher 2000 или щелкните рисунки в Publisher 2003 или Publisher 2002.
  3. Выберите команду скрыть рисунки, а затем нажмите кнопку ОК.
  4. В меню Файл выберите команду Открыть.
  5. Найдите файл публикации.
  6. Выберите публикацию и нажмите кнопку Открыть.
Если вы можете открыть публикацию, публикация может содержать поврежденный объект или заполнитель объекта. Чтобы удалить или заменить поврежденный объект или заполнитель объекта, перейдите к следующему способу. Если вы не можете открыть публикацию, перейдите к методу "Копирование публикации на другой компьютер".

Поиск и удаление поврежденного объекта или заполнителя объекта

Чтобы найти и удалить поврежденный объект или заполнитель объекта, выполните указанные ниже действия.
  1. В публикации щелкните заполнитель объекта правой кнопкой мыши и выберите команду удалить объект.
  2. В меню Файл выберите команду Сохранить как.
  3. В поле имя введите новое имя для публикации и нажмите кнопку сохранить.
  4. В меню вид выберите пункт Отображение рисунка в Publisher 2000 или щелкните рисунки в Publisher 2003 или Publisher 2002.
  5. Нажмите кнопку подробный показ, а затем нажмите кнопку ОК.Примечание. Если появится сообщение об ошибке, перейдите к действию 8.
  6. В меню Файл нажмите Закрыть.
  7. В меню файл выберите команду Открыть, а затем — публикацию, сохраненную в действии 3. Если вы можете открыть публикацию, объект или заполнитель объекта, который вы удалили на шаге 1, поврежден. Измените макет на отсутствующий объект или заполнитель объекта. Кроме того, вы можете нарисовать новый заполнитель объекта и заменить удаленный объект на тот, который не поврежден. Для этого используйте метод, который подходит для источника объектов.Из коллекции картинок
    1. В меню Вставка выберите пункт  Рисунок, а затем Картинка.
    2. В одной из доступных категорий щелкните, чтобы вставить рисунок, звуковое сопровождение или фильм из нужной ролика.
    3. Сохраните и закройте публикацию. Затем попробуйте снова открыть публикацию.
    Из расположения, отличного от коллекции рисунков
    1. С помощью инструмента "рамка рисунка" нарисовать заполнитель нового объекта.
    2. Щелкните заполнитель, выберите в меню Вставка команду Рисунок , а затем — из файла.
    3. Найдите рисунок, который вы хотите вставить, и щелкните его, чтобы выделить.
    4. Нажмите кнопку Вставить.
    5. Сохраните и закройте публикацию. Затем попробуйте снова открыть публикацию.
    Если вы не можете открыть публикацию, повторите метод "настроить Publisher, чтобы скрыть рисунки". Затем перейдите к действию 8.
  8. Повторите действия с 1 по 7, пока не откроется публикация с включенным параметром отображения подробных сведений .
  9. Чтобы открыть публикацию, воспользуйтесь одним из указанных ниже способов.
    • Замените удаляемый объект или заполнитель объекта на тот, который не поврежден.
    • Измените макет на отсутствующий объект или заполнитель объекта.
  10. В меню Файл выберите команду Сохранить.
Если вы по-прежнему не можете открыть публикацию, перейдите к следующему способу.

Перемещение файла публикации на другой диск

Если файл публикации находится на съемном диске, например дискете или ZIP-диске, Windows не сможет прочитать файл. В этом случае скопируйте файл на жесткий диск. Если вы не можете скопировать файл со съемного диска, возможно, он перекрестно связан с другими файлами или папками. Кроме того, файл может находиться в поврежденном секторе диска. В любом случае перейдите к методу "выполнить проверку ошибок на диске".

Копирование публикации на другой компьютер

В некоторых сценариях вы можете открыть поврежденную публикацию после копирования публикации на другой компьютер, на котором установлен Publisher. Для этого выполните следующие действия:
  1. Откройте проводник.
  2. Найдите файл публикации.
  3. Щелкните файл публикации правой кнопкой мыши и выберите команду Копировать.
  4. Чтобы скопировать публикацию на другой компьютер, воспользуйтесь одним из указанных ниже способов.
    • Скопируйте файл публикации на съемный диск, например на дискету или на ZIP-диск. Затем скопируйте публикацию со съемного диска на другой компьютер.
    • Скопируйте файл публикации на другой компьютер по сети.
  5. На втором компьютере запустите проводник Windows.
  6. Найдите и дважды щелкните файл публикации.
Если вы можете открыть публикацию, проверьте каждую страницу, чтобы определить наличие пустых заполнителей объектов. Щелкните файл правой кнопкой мыши и выберите команду " Удалить" для каждого пустого местозаполнителя объекта. Сохраните публикацию, а затем скопируйте файл публикации на первый компьютер. Если вы не можете открыть публикацию, перейдите к следующему способу.

Выполнение проверки ошибок на диске

Запустите проверку ошибок, чтобы исправить все ошибки на диске. Устраните ошибки, связанные с восстановлением всех перекрестных файлов и преобразуйте потерянные фрагменты в файлы.Примечание. Несмотря на то, что при проверке ошибок может быть обнаружено, что файл публикации связан с несколькими ссылками, а затем восстановлен файл, этот метод не гарантирует, что Publisher сможет прочитать файл после того, как проверка ошибок завершила сканирование и устранить ошибки. Чтобы запустить проверку ошибок, выполните указанные ниже действия.
  1. Закройте все запущенные программы.
  2. Дважды щелкните значок Мой компьютер на рабочем столе.
  3. Щелкните правой кнопкой мыши локальный диск, который нужно проверить, и выберите пункт Свойства.
  4. На вкладке Сервис нажмите кнопку Проверить сейчас в разделе Проверка ошибок.
  5. В разделе Проверка параметров дискаустановите флажок проверять и попытаться восстановить поврежденные сектора . Затем нажмите кнопку начать.
  6. Когда проверка ошибок завершает проверку и устранение ошибок, нажмите кнопку Закрыть.
  7. Запустите Publisher и попробуйте открыть публикацию.
Если вы не можете открыть публикацию, перейдите к следующему способу.

Попытаться восстановить текст в публикации

Этот метод описывает способ восстановления текста из поврежденной публикации и вставки восстановленного текста в новую пустую публикацию. После этого вы должны повторно создать макет и заново вставить в новую публикацию все объекты из поврежденной публикации. Чтобы восстановить текст из поврежденной публикации, а затем вставить его в новую публикацию, выполните указанные ниже действия.
  1. Запустите Publisher и создайте пустую полную публикацию на всю страницу.
  2. Чтобы нарисовать текстовую рамку на пустой странице, используйте инструмент "текст" в Publisher 2000 или "надпись" в Publisher 2003 или Publisher 2002.
  3. В меню Вставка выберите пункт текстовый файл.
  4. В поле тип файлов выберите пунктфайлы Publisher (*. pub).
  5. Выберите публикацию и нажмите кнопку ОК. Если появится сообщение о том, как текст, который вы хотите вставить, умещается на странице, нажмите кнопку Да.

Если вы можете открыть поврежденную публикацию

Если вы можете открыть публикацию в безопасном режиме, воспользуйтесь одним из описанных ниже способов, чтобы повторно создать публикацию.

Копирование страниц из поврежденной публикации в новую публикацию

Чтобы скопировать страницы из поврежденной публикации в новую публикацию, выполните указанные ниже действия.
  1. Запустите Publisher и откройте поврежденную публикацию.
  2. Запустите другой экземпляр Publisher.
  3. Создайте новую пустую публикацию, которая настроена так же, как у поврежденной публикации.
  4. В поврежденной публикации выберите все объекты на определенной странице.
  5. В меню Правка выберите Копировать.
  6. Нажмите клавиши ALT + TAB, чтобы перейти к новой публикации.
  7. В меню Правка выберите команду Вставить.
  8. Повторите действия 4 – 7, пока все страницы не будут вставлены в новую публикацию.
Примечание. Если при копировании страницы в новую публикацию вы заметили нерегулярное поведение в новой публикации, то, возможно, скопированная страница будет содержать поврежденный объект. В этом случае для устранения этой проблемы воспользуйтесь одним из указанных ниже способов.
  • Копирование одного объекта за один раз со страницы проблемы в новую публикацию для определения того, какой объект поврежден. Затем убедитесь, что вы не включали поврежденный объект в новую публикацию.
  • Перестройте страницу проблем в новой публикации.
Если страница публикации повреждена, перейдите к следующему способу.

Сохранение публикации в формате RTF (формат RTF)

Если повреждения публикации кажутся распространенными, сохраните публикацию в формате RTF, чтобы восстановить текст публикации. Для этого выполните следующие действия:
  1. Откройте публикацию.
  2. Щелкните текстовую рамку.
  3. В поле Тип файла выберитеФормат RTF (*. RTF).
  4. В поле имя файла введите нужное имя файла.
  5. В поле сохранить в выберите папку, в которой вы хотите сохранить текст публикации.
  6. Нажмите кнопку сохранить, а затем — кнопку ОК.
  7. Закройте публикацию.
  8. В меню Файл выберите команду Открыть.
  9. В поле тип файлов выберитеФормат RTF (*. RTF).
  10. В списке файлов выберите текстовый файл, сохраненный на шаге 6.
  11. Нажмите кнопку Открыть.  
  12. Расположите и отформатируйте текст так, как он будет размещен и отформатирован в поврежденной публикации.

Ссылки


Чтобы получить дополнительные сведения о том, как устранять поврежденные публикации в Publisher, щелкните приведенные ниже номера статей базы знаний Майкрософт.
315222 Описание возможных вариантов безопасного режима загрузки Windows XP
164519 Устранение неполадок, возникающих в Office kernel32. dll в Windows 95
179095 При открытии Publisher появляется сообщение об ошибке "ссылка на файл"