Не удается подключиться с помощью Exchange ActiveSync из-за потребления ресурсов Exchange


Симптомы


Начальные симптомы будет включать пользователи не могут синхронизировать свои устройства с Exchange.  Кроме того, могут возникнуть следующие неполадки:
  • В журнале приложений на сервере Exchange могут регистрироваться следующие события:

Источник события: Server ActiveSync
Код события: 3007
описание
Время ожидания ответа сервера почтовых ящиков Exchange: Server: [mail.contoso.com] пользователя: [user@contoso.com]. Сервер Exchange ActiveSync не удалось установить связь с сервером почтовых ящиков Exchange своевременно. Проверьте почтовый ящик Exchange сервер работает правильно и не перегружен.

Источник события: Server ActiveSync
Код события: 3014
Description:
Почтовый ящик Exchange Server: [mail.contoso.com] достигнут его порог тайм-аут. Сервер почтовых ящиков будет защищен от новых запросов [60] секунд.

  • Число разрешенных подключений RPC на сервере почтовых ящиков может превышать эти рекомендуемые пределы.
    Максимальное число запросов RPC, которые могут выполняться в любой момент времени до начала отклонения новых подключений банка 500 для Exchange 2007 и 2010, однако счетчик должен оставаться ниже 70 все время. Все, что выше это указывает общую производительность. Чтобы проверить это, один проверьте счетчик системного монитора «MSExchangeIS\RPC запросов» которого будут отображаться, если сервер не выше установленных ограничений.

    Ознакомьтесь с http://technet.microsoft.com/en-us/library/bb201689%28EXCHG.80%29.aspx

  • В журналах W3SVC вы увидите HTTP 409 и возвращается для запросов Microsoft-Server-ActiveSync ответы 503.
    Вы можете также увидеть код ошибки «TooManyJobsQueued» в журнале W3SVC. В следующих примерах:

    2010-09-09 21:35:35 W3SVC1 10.0.0.10 POST /Microsoft-Server-ActiveSync/default.eas пользователя = < пользователя > & DeviceId = < DeviceID > & DeviceType = < тип > & Cmd = синхронизация = Ping = < данных > 443 домен\пользователь 10.0.0.20 < UserAgent > 503 0 0

    2010-09-15 00:00:02 W3SVC1 155.109.199.51 учет /Microsoft-Server-ActiveSync/default.eas Cmd = Ping & пользователя = < пользователя > & DeviceId = < DeviceID > & DeviceType = < тип > & журнала = ошибка: TooManyJobsQueued_ 443 домен\пользователь 10.0.0.20 < UserAgent > 503 0 0

  • Журналы HTTPErr покажет Connection_Dropped для /Microsoft-Server-ActiveSync запросов.
    Вы сможете увидеть, что s порт или порт источника, откуда Connection_Dropped достигает довольно большое число. Например:

    2010-09-09 00:27:25 10.0.0.10 64637 10.0.0.20 443 HTTP/1.1 POST /Microsoft-Server-ActiveSync? Пользователь = < пользователя > & DeviceId = < DeviceID > & DeviceType = < тип > & Cmd = Ping - 1 Connection_Dropped MSExchangeSyncAppPool
  • Для Exchange 2003, сервер будет исчерпании памяти пула Non-Paged (NPP).
    Достигнут предел числа подключений NPP потребляется и HTTP.sys начинает игнорировать HTTP-подключений, когда сервер начинает пиковой NPP 100 МБ в зависимости от конфигурации сервера. При достижении сервер ближе к 108 МБ, HTTP.sys не удастся все подключения. NPP могут быть проверены с помощью диспетчера задач и просмотра производительности и проверки памяти ядра.    
  • Дополнительные сведения по Exchange и NPP см http://technet.microsoft.com/en-us/library/aa996269(EXCHG.80).aspx

    Дополнительные сведения об использовании Netstat см http://technet.microsoft.com/en-us/library/cc940097.aspx

    Дополнительные сведения о загрузке и использовании программа TCPView см http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

     

    Причина


    , Это может произойти из-за проблем с программным обеспечением устройства и подключения мобильного устройства.  Существуют основные причины сбоев подключения и причин истощения памяти:

    1. сервер начинает удаление подключения из-за количество запросов к серверу или запросы превышает число разрешенных подключений пула приложений IIS. Аналогично, достижения предела порта TCP на серверах Exchange является причиной.

    Примечание: Более чем вероятно серверов может доходить до одного из других ограничений (длина очереди пула приложений на ЦС или запросов RPC на сервере почтовых ящиков) перед получением рядом нехватки TCP-порт.

    Ниже рассмотрены нехватки порта:
    http://technet.microsoft.com/en-us/library/cc540453(EXCHG.80).aspx

    Следующие статьи упомянуть MaxUserPort и TCP-подключений в Windows и Exchange

    http://technet.microsoft.com/en-us/library/cc940037.aspx

    http://technet.microsoft.com/en-us/library/bb397382(EXCHG.80).aspx

    2. синхронизация мобильного устройства, с помощью Exchange ActiveSync может имитировать поведение DOS-атаки на сервере. Некоторые примеры, приведенные в следующей статье:
    http://technet.microsoft.com/en-us/library/cc182260.aspx

    3. пул приложений получает запросы быстрее, чем он может обрабатывать их.  Эта процедура рассматривается в следующей статье:
    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/9701f9dd-d40b-4d24-a2df-1d1abc13f764.mspx?mfr=true

     

    Решение


    Чтобы остановить эти устройства потребления ресурсов Exchange и предотвратить нагрузку, подозрительные устройства, должен быть заблокирован.  

    Внимание: Есть ли проблемы с iPhone OS 4.0, определяемый агента пользователя 801.293 - http://support.apple.com/kb/TS3398

    Должны быть отмечены все журналы IIS, содержащие этот агент пользователя и владельца этого устройства следует обновить OS 4.1 или выше (желательно версии iOS 4.3.x). Корпорация Майкрософт рекомендует блокировать, этих пользователей в промежутке.

    Устройства могут быть заблокированы, отключение доступа Exchange ActiveSync для владельца устройства, отключение устройства или воспользовавшись фильтром Internet Security and Acceleration (ISA) или ForeFront угроз Management Gateway (TMG).

    Дополнительные сведения о блокировки устройства см следующее сообщение в блоге группы Exchange Microsoft (EHLO):

    http://msexchangeteam.com/archive/2008/09/05/449757.aspx

    Примечание: Некоторые устройства могут продолжать попытки подключения к серверу Exchange (вызывает большое число TCP-подключений) даже если он отключен, для использования с Exchange ActiveSync. Мы рекомендуем отключение устройства или блокировать устройства с помощью фильтра ISA.

    Exchange Server 2010

    Если пользователя с устройство на другое устройство в почтовый ящик Exchange 2010, можно включить регулирование и для всех пользователей Exchange ActiveSync для предотвращения устройства overburdening Exchange server. Обратитесь к следующей статье Microsoft TechNet в Интернете:

     http://technet.microsoft.com/en-us/library/dd297964.aspx

    Необходимые для этого действия, включаются в статье, тем не менее, здесь приведены некоторые примеры:

    $ = Get-ThrottlingPolicy | WHERE-object {$_. IsDefault eq $true}

    $ | SET-ThrottlingPolicy – EASMaxConcurrency 10

    Дополнительные сведения о задании политики регулирования см от TechNet через Интернет:

     http://technet.microsoft.com/en-us/library/dd298094.aspx

    Дополнительные факторы, чтобы удостовериться, что влияет на подключения на устройство

    1. Существует большое количество элементов в основных папках (основной папки "Входящие")? Когда существует несколько тысяч элементов в папке "Входящие" и устройство пытается выполнить синхронизацию всех элементов, вы увидите большое количество запросам с этого устройства для загрузки всех этих элементов. Это решение включает в себя:

      а. Настройка устройства для синхронизации только последний день или не более 3 дней в зависимости от количества элементов пользователь получает в одном дне.
      б. Уменьшить число элементов в почтовом ящике
    2. Учетные записи отключены для Exchange ActiveSync? Это может увеличить число устройств подключения к серверу. Если устройство по-прежнему отправляет на сервер несколько запросов, отключите устройство, или поместить фильтр на место на ISA блокировать DeviceID.
    3. Пользователи превышении предела квоты почтового ящика? В этом случае устройство не сможет синхронизировать новые элементы в почтовый ящик и может повторить попытку снова и снова.
    4. Существуют ли ограничения на размер сообщения в организации? Если не предусмотрено ограничений, возможно, устройство, которое пытается синхронизировать больших объемов данных.

      Примечание: Помимо указанных выше следует проанализировать подключение устройств с помощью синтаксического анализа журнала подозрительные устройств. Дополнительную помощь, используя средство Log Parser дополнительная информация.

    При обнаружении подозрительных устройства, корпорация Майкрософт рекомендует, клиенты обратитесь к поставщику устройства за помощью в определении Почему устройство передает чрезмерное количество запросов к серверу Exchange.

    В разделе "действия, которые будут полезны администраторам при устранении неполадок:" в разделе "Дополнительная информация" для дополнительных действий Администраторы можно предпринять для повышения производительности при устранении неисправностей.

    Дополнительные сведения


    Какие устройства вызывают сомнения?
    Обычно если устройство отправляет более 1000 запросов в день, рекомендуется исследование.

    Если выше 1500 обращений (запросов), может вызвать проблемы на устройствах или среды. Следует исследовать устройство и действия пользователя.

    Просмотреть следующее сообщение в блоге группы Exchange и. Файл PS1, который может использоваться для синтаксического разбора файлов журнала IIS для любой версии Exchange Server с помощью Windows Powershell.

    Сценарий для устранения неполадок с Exchange ActiveSync.
    http://blogs.technet.com/b/exchange/archive/2012/01/31/a-script-to-troubleshoot-issues-with-exchange-activesync.aspx

    Сценарий ActiveSyncReport
    http://gallery.technet.microsoft.com/scriptcenter/ActiveSyncReport-script-a2417a84

    Средство log Parser можно использовать без сценария, но сценарий был разработан для фильтрации на основе критериев, указанных в командной строке используется.  С помощью сценария выше, оповещения по электронной почте или отчеты могут также создаваться.

    Действия, которые будут полезны администраторам при устранении неполадок:

    Следующие параметры не решит проблему. Они даст вам больше времени для анализа журналов IIS для определения устройства вызывают сомнения.

    • Уменьшите значение времени активности на серверах почтовых ящиков Exchange для отправки keep alive каждые 30 минут ЦС вместо каждые 2 часа.

      Поддерживать активность присвоено значение 30 минут (1800000) в реестре, описанные в следующей статье в базе знаний Майкрософт через Интернет:
      http://support.microsoft.com/kb/324270  

      Сведения о значении реестра используется следующим образом:
      Путь: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\
      Имя параметра: KeepAliveTime
      Тип значения: REG_DWORD-время в миллисекундах
      Допустимый диапазон значений: 1-0xFFFFFFFF
      По умолчанию: 7,200,000 (два часа)

      Это значение определяет количество попыток протокола TCP, для проверки неактивного неактивного подключения с помощью отправки пакета проверки активности. Если удаленный компьютер по-прежнему доступен, он подтверждает пакета проверки активности. По умолчанию пакеты проверки активности не отправляются. Программу можно использовать для настройки этого значения на подключение. Рекомендуемое значение — 1,800,000 (равно 30 минут). (Десятичное число) (Требуется перезапуск сервера)

      Отслеживать этот параметр, если порты сервера по-прежнему исчерпания, затем это может потребоваться снижен до 15 минут, а не 30 минут.
    • Увеличьте время ожидания подключения IIS в IIS

      Рекомендуется использовать значения по умолчанию и должен быть 120 секунд. Если он имеет значение на более высокое значение, он должен устанавливать между 120 секунд минимальные рекомендуемые значения 300 второй максимальное значение.
      В следующем разделе в TechNet для получения дополнительных сведений:

      http://technet.microsoft.com/en-us/library/cc182260.aspx

      Это можно сделать через свойства веб-узла по умолчанию путем изменения значения времени ожидания подключения (в секундах).
    • Увеличьте число подключений IIS (длина очереди) для ExchangeApplicationPool на серверы клиентского доступа и почтовых ящиков Exchange 2003:


      Чтобы отключить перезапуск IIS 6.0 рабочих процессов с помощью диспетчера служб IIS
      1. Запуска диспетчера Internet Information Services (IIS).
      2. Разверните ветвь локального компьютера, разверните Пулы приложений, щелкните правой кнопкой мыши Пулы приложений ExchangeApplicationPool и нажмите кнопку Свойства.
      3. Снимите флажок Корзина рабочие процессы через (мин.), а затем нажмите кнопку ОК.

      Используйте диспетчер служб IIS для увеличения длины очереди в IIS 6.0
      1. Запуска диспетчера Internet Information Services (IIS).
      2. Разверните ветвь локального компьютера, разверните Пулы приложений, щелкните правой кнопкой мыши пул приложений ExchangeApplicationPool и нажмите кнопку Свойства.
      3. Откройте вкладку быстродействие и измените значение в поле предел очереди запросов. Замените значение по умолчанию 1000 4000.
      4. Нажмите кнопку ОК.
    • Увеличить число подключений IIS (длина очереди) для MSExchangeSyncAppPool на серверах клиентского доступа Exchange 2010 и Exchange 2007

      Чтобы отключить перезапуск рабочего процесса в IIS 7.0 и выше с помощью диспетчера служб IIS (это должен быть отключен по умолчанию для MSExchangeSyncAppPool)

      1. Запустить диспетчер служб IIS.
      2. E Развернуть локального компьютера и щелкните пулы приложений.
      3. я n области пулы приложений щелкните соответствующий пул приложений, например MSExchangeSyncAppPool или новый пул приложений, который был создан и нажмите кнопку Дополнительные параметры.
      4. В повторное использование раздела, измените значение интервал времени (в минутах). Замените значение по умолчанию 1740 0 (ноль). Значение 0 отключает перезапуск рабочего процесса.
      5. Click OK.
    • Используйте диспетчер служб IIS для увеличения длины очереди в IIS 7.0 и выше.

      1. Запустить диспетчер служб IIS.
      2. Разверните узел локального компьютера и щелкните пулы приложений.
      3. В области пулы приложений щелкните соответствующий пул приложений, например MSExchangeSyncAppPool или новый пул приложений, который был создан и нажмите кнопку Дополнительные параметры.
      4. В общий раздел, измените значение длины очереди. Замените значение по умолчанию 1000 10000.
    • 5. Click OK

    Примечание: Если под управлением Windows 2003 (IIS 6) Exchange 2007, выполните шаги, описанные выше, чтобы увеличить предел очереди запросов для MSExchangeSyncAppPool.

    Дополнительные сведения о почему может быть необходимо изменить эти значения для пулов приложений, а также для дополнительных ссылок на «How To» сведения см от TechNet через Интернет:

    http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/9701f9dd-d40b-4d24-a2df-1d1abc13f764.mspx?mfr=true