Появляется сообщение об ошибке «Время ожидания соединения истекло» в Microsoft Business Portal при открытии страницы центра проектов


Симптомы


В Microsoft Business Solutions - портала для бизнеса, если щелкнуть проект , чтобы открыть страницу центра проектов, появляется следующее сообщение об ошибке в Communicator проекта веб-части:

Ошибка:

Время ожидания соединения: разъем.
Значение HRESULT = 0x800A1527 - клиент: произошла непредвиденная ошибка во время обработки этого запроса.
Значение HRESULT = 0x800A1527 - клиент: Сбой при отправке сообщения Soap или распознать ответ не был получен
Значение HRESULT = 0x800A1527 - клиент: Неизвестная ошибка клиента.
HRESULT=0x800A1527


faultcode=Client


faultstring = время ожидания соединения: разъем.


faultactor=


Подробности = время ожидания соединения: разъем.
Значение HRESULT = 0x800A1527 - клиент: произошла непредвиденная ошибка во время обработки этого запроса.
Значение HRESULT = 0x800A1527 - клиент: Сбой при отправке сообщения Soap или распознать ответ не был получен
Значение HRESULT = 0x800A1527 - клиент: Неизвестная ошибка клиента.
HRESULT=0x800A1527

Причина


Эта проблема возникает, так как порт протокола управления передачей (TCP), указанный для верхнего уровня веб-узла в диспетчере служб Microsoft IIS (IIS) содержит значение, отличное от значения, указанного в файле ProjectService.wsdl.

Решение


Чтобы устранить эту проблему, выполните следующие действия:
  1. В диспетчере Internet Information Services (IIS) поиск веб-узла верхнего уровня при установке Microsoft Business Portal. Чтобы сделать это, выполните следующие действия.
    1. Нажмите кнопку Пуск, выберите пункт Администрирование и щелкните Диспетчер IIS.
    2. В диалоговом окне диспетчера Internet Information Services (IIS) разверните узел имя_сервера.

      Примечание. В этой статье имя_сервера представляет имя сервера, на котором установлен Microsoft Business Portal.
    3. Разверните узел веб-узлы.
  2. Щелкните правой кнопкой мыши веб-узел верхнего уровня и выберите команду Свойства.
  3. Перейдите на вкладку веб-узел , проверьте значение в поле TCP-порт и нажмите кнопку Отмена.
  4. Откройте в блокноте файл ProjectService.wsdl.

    Примечание. По умолчанию файл ProjectService.wsdl используется Microsoft Business Solutions\Business Portal\Applications\PMA.
  5. Найдите следующую строку в конце файла:
     <soap:address location="HTTP://Server_name:80/BusinessPortal/Applications/PMA/PCService.asmx" /> 
    Примечание. В этой строке «Имя_сервера» представляет имя сервера, на котором установлен Microsoft Business Portal.
  6. Замените номер порта на значение, записанное на шаге 3. Строка в шаге 5 показывает порт 80.
  7. В меню Файл нажмите кнопку Сохранить.


Проблема, описанная в разделе «проблема» не применяется к Microsoft Dynamics SL 7.0.