Standard user: RunOnce and RunOnceEx are not being executed

Symptoms

A command set to execute via RunOnce or RunOnceEx may not execute as expected.

The registry keys effected are:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnceEx

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Runonce
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunonceEx

 

Cause

This will occur if you log on with a Standard User Account.

This is by design.

Resolution

To execute commands from those registry keys, you must log in with an Administrator account. This issue effects only users with a Standard User account. If the user has an Administrator or Split Token, the execution proceeds.

More Information

See also: Description of the RunOnceEx Registry Key

http://support.microsoft.com/kb/310593/en-us

Свойства

Номер статьи: 2021405 — последний просмотр: 7 мая 2010 г. — редакция: 1

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