Сведения о списке автозаполнения Outlook

Применимо к: Outlook 2016Outlook 2013Microsoft Office Outlook 2003 Больше

Аннотация


Данная статья содержит сведения о списке автозаполнения Microsoft Outlook (также известный как список автозаполнения Outlook). Кроме описания функции, эта статья содержит дополнительные сведения и пошаговые инструкции для опытных пользователей для управления списком.

Дополнительная информация


Outlook поддерживает список автозаполнения. Список используется функция автоматической проверки имен и функцию автоматического завершения. Список автозаполнения, также известный как кэш псевдонимов, создается автоматически при отправке сообщений электронной почты из Outlook. Список содержит адреса SMTP, LegacyExchangeDN записей и отображаемые имена для людей, которому было отправлено почты ранее.Примечание. Список автозаполнения для Outlook относится к Outlook и Outlook Web App (OWA) не является общим. OWA поддерживает свой собственный список автозаполнения.Следующие разделы содержат сведения о функции автозаполнения.

Ограничить количество записей

Outlook ограничивает количество записей, которые можно сохранить в списке автозаполнения. По достижении этого предела, Outlook использует внутренний алгоритм для определения наиболее оптимальных имен для удаления из списка. Это осуществляется на основе использования взвешивания. Таким образом можно найти некоторые имена неожиданно удаляется из кэша ваш псевдоним. Существует два общих подхода, которые можно использовать, чтобы избежать такой ситуации:
  1. Заранее можно удалить записи списка автозавершения, больше не нужны. Этот подход является предпочтительным. Дополнительные сведения приведены в разделе «Как удалить записи списка автозавершения один одновременно».
  2. Можно увеличить предел кэша псевдонимов. Так как эта конфигурация не проверялось, не рекомендуется. При наличии большего размера кэша псевдонимов, если кэш псевдонимов становится недоступным из-за повреждения также может потерять большее количество кэшированных записей. Дополнительные сведения о том, как увеличить предел приведены в разделе «Как изменить предельное список автозаполнения».
Существуют следующие ограничения.
  • Outlook 2016: 1000 записей
  • Outlook 2013: 1000 записей
  • Outlook 2010: 1000 записей
  • Outlook 2007: 2 000 записей
  • Outlook 2003: 1000 записей
 

Как включить функцию автозавершения

В этом разделе подробно описывается включение и отключение функции автозаполнения.
Outlook 2016, Outlook 2010 и Outlook 2013
Чтобы открыть этот параметр автозавершения, выполните следующие действия.
  1. В меню Файл выберите пункт Параметры.
  2. Перейдите на вкладку Почта .
  3. Прокрутите приблизительно посередине вниз до отправки сообщений. Убедитесь, что установлен флажок использовать автозаполнение предлагать имена при вводе в поле Кому, копия и СК строк списка.
Outlook 2003 и Outlook 2007
Чтобы получить доступ к параметрам автозавершения, выполните действия:
  1. Нажмите кнопку Сервис и выберите Параметры
  2. Нажмите кнопку Параметры электронной почты .
  3. Нажмите кнопку Дополнительные параметры .
  4. Убедитесь, что Предлагать имена при заполнении, копия и СК поля флажок установлен. (Ниже снимок экрана для этого шага.)The screen shot for this step.
 

Как импортировать файлы .nk2 Outlook 2016, Outlook 2010 и Outlook 2013

Microsoft Office Outlook 2007 и более ранних версиях хранить список автозаполнения в файле псевдоним (.nk2) на диске. Outlook 2016, Outlook 2010 и Outlook 2013 хранить как скрытое сообщение в банк сообщений основного списка автозавершения. Откройте Outlook 2010, Outlook 2013 и Outlook 2016 позволяют импортировать старые файлы .nk2.Дополнительные сведения об импорте файлов .nk2 в Outlook 2010 посетите следующий веб-узел корпорации Майкрософт:

Копирование списка автозавершения

Действия для экспорта и импорта списка автозавершения различны, в зависимости от версии Outlook, которую вы используете.
Outlook 2016, Outlook 2010 и Outlook 2013
Чтобы скопировать список автозаполнения в Outlook 2010, Outlook 2013 и Outlook 2016, выполните следующие действия.Шаг1Для экспорта сообщений почтового ящика автозавершения, выполните следующие действия.
  1. Закройте приложение Outlook, а затем закройте Outlook Web Access или Outlook Web App (OWA) на всех рабочих станций, подключенных к почтовому ящику.
  2. Загрузите и установите MFCMAPI из http://mfcmapi.codeplex.com.
  3. Запустите mfcmapi.exe.
  4. Сеанс в меню входа в систему.
  5. При появлении в профиле, выберите имя нужного профиля и нажмите кнопку ОК.
  6. В верхней области найдите строку, которая соответствует почтовому ящику и дважды щелкните его.
  7. В области переходов слева разверните Корневой контейнери разверните узел Хранилища или IPM_SUBTREE.
  8. Щелкните правой кнопкой мыши папку "Входящие" и нажмите кнопку Открыть связанную таблицу содержимого. Это действие открывает новое окно MFCMAPI, который содержит различные свойства.
  9. В столбце Тема щелкните правой кнопкой мыши элемент, который имеет тему IPM. Configuration.Autocompleteи выберите команду Экспортировать сообщение. Это действие открывает окно Сохранить сообщения в файл .
  10. В раскрывающемся списке выберите файл MSG (Юникод)и нажмите кнопку ОК.
  11. Выберите папку, в которой требуется сохранить сообщение и нажмите кнопку Сохранить. Запишите расположение.
Шаг 2Чтобы импортировать сообщения почтового ящика автозавершения, выполните следующие действия.
  1. Закройте приложение Outlook, а затем закройте Outlook Web Access или Outlook Web App (OWA) на всех рабочих станций, подключенных к почтовому ящику.
  2. Загрузите и установите MFCMAPI http://mfcmapi.codeplex.com
  3. Запустите mfcmapi.exe.
  4. Сеанс в меню входа в систему.
  5. При появлении в профиле, выберите имя нужного профиля и нажмите кнопку ОК.
  6. В верхней области найдите строку, которая соответствует почтовому ящику и дважды щелкните его.
  7. В области переходов слева разверните Корень - пи разверните узел Хранилища или IPM_SUBTREE.
  8. Щелкните правой кнопкой мыши папку "Входящие" и нажмите кнопку Открыть связанную таблицу содержимого. Это действие открывает новое окно MFCMAPI, который содержит различные свойства.
  9. Чтобы избежать повторяющихся записей, необходимо удалить существующее сообщение автозаполнения. Примечание. Прежде чем удалить IPM. Configuration.Autocomplete сообщение, следуя инструкциям, приведенным в разделе «экспортировать кэш Автозаполнение» необходимо экспортировать сообщение. Чтобы удалить существующее сообщение автозавершения, выполните следующие действия.
    1. В столбце Тема найдите элемент, который имеет тему IPM. Configuration.Autocomplete.
    2. Щелкните правой кнопкой мыши элемент и выберите команду Удалить сообщение. Откроется окно Удалить элемент .
    3. В раскрывающемся списке выберите Удалить без возможности восстановления (удаление для хранения удаленных элементов, если поддерживается)и нажмите кнопку ОК.
  10. В меню папки нажмите кнопку Импорти нажмите кнопку С MSG.
  11. Найдите файл MSG-файл, созданный на шаге 11 в разделе «Как чтобы экспортировать список автозавершения» и нажмите кнопку ОК.
  12. В появившемся окне Загрузки сообщений выберите в списке стиль загрузкиЗагрузка сообщения в текущей папке и нажмите кнопку ОК.
Данные автозавершения импортируются с классом сообщений IPM. Configuration.Autocomplete_ .msg< шестнадцатеричный код >, где< шестнадцатеричный код > заполнитель представляет длинную строку из букв и цифр.
Outlook 2003 и Outlook 2007

Действия, необходимые для копирования списка автозавершения в Outlook 2003 и Outlook 2007 различаются. Это происходит потому, что Outlook 2003 и Outlook 2007 хранить список автозаполнения в файле .nk2.

Копирование списка автозавершения в Outlook 2007, посетите следующий веб-узел корпорации Майкрософт:

Копирование списка автозавершения на другой компьютер

Удаление записей из списка автозавершения один за один раз

Чтобы удалить записи из одной записи кэша автозаполнения одновременно, выполните следующие действия.
  1. Откройте новое сообщение электронной почты.
  2. Введите первые несколько символов автозаполнения записи, которую требуется удалить.
  3. Когда операция появляется в списке предложенные имена, наведите указатель мыши на имя выделяется, но не щелкните имя.
  4. При появлении значка «X» рядом с выделенным именем щелкните X , чтобы удалить имя из списка или нажмите клавишу Delete на клавиатуре.

Как очистить весь список автозаполнения

В этом разделе объясняется, как удалить список автозаполнения.
Outlook 2016, Outlook 2010 и Outlook 2013

Используйте один из двух следующих методов для удаления список автозаполнения в Outlook 2016, Outlook 2010 и Outlook 2013.Способ 1

  1. Запустите Outlook.
  2. На вкладке Файл выберите пункт Параметры.
  3. Перейдите на вкладку Почта .
  4. В разделе Отправки сообщенийвыберите Пустой список автозаполнения.
  5. Нажмите кнопку Да.
Способ 2Запустите Outlook, используя параметр /CleanAutoCompleteCache. Чтобы сделать это, выполните следующие действия.
  1. В меню Пуск выберите пункт Выполнить.
  2. Тип Outlook.exe /CleanAutoCompleteCache. Примечание. Если Outlook не установлен в папку по умолчанию, необходимо указать путь Outlook.exe.
Outlook 2003 и Outlook 2007
Чтобы удалить список автозаполнения в Outlook 2003 и Outlook 2007, необходимо вручную удалить файл .nk2. Чтобы удалить файл .nk2, выполните следующие действия.
  1. Закройте приложение Outlook.
  2. Нажмите кнопку Пуски выберите пункт компьютер.
  3. Нажмите кнопку организоватьи выберите Свойства папок и поиска.
  4. На вкладке Вид щелкните Показывать скрытые файлы, папки и диски.
  5. Нажмите кнопку ОК.
  6. Нажмите кнопку Пуск, выберите пункт Все программы, Стандартные и выберите команду выполнить.
  7. В диалоговом окне запуска введите следующую команду (включая кавычки) и нажмите кнопку ОК. «C:\ Имя пользователя\AppData\Roaming\Microsoft\Outlook Users\»Примечаниепользователя на этом пути — это имя текущего вошедшего в систему пользователя Windows.
  8. Щелкните правой кнопкой мыши. Nk2 файл, имеющий имя профиля, который требуется восстановить и нажмите кнопку Переименовать.
  9. Переименовать файл как Имя_профиля.bakи нажмите клавишу ВВОД.
  10. апустить Outlook.
 

Проблемы с кэшем автозаполнения

В этом разделе описаны известные проблемы, которые могут возникнуть в кэше автозаполнения. Автозаполнение кэша могут повредиться со временем и не может сохранять новые записи. В этом случае можно попытаться удалить отдельные записи из списка. Чтобы это сделать, обратитесь к разделу «Как удалить записи списка автозавершения один одновременно». Если это не устраняет проблему, можно сбросить весь список автозаполнения. Чтобы это сделать, обратитесь к разделу «Как очистить весь список автозаполнения».

Как изменить ограничение для списка автозавершения

Так как эта конфигурация не проверялось, не рекомендуется. При наличии более длинный список автозаполнения, если автозаполнение кэш становится недоступным из-за повреждения также может потерять большее количество кэшированных записей. Учитывая этот отказ от ответственности, можно использовать следующие данные реестра увеличить список автозаполнения в Outlook.Важно. Этот раздел, метод или задача содержат действия, содержащие указания по изменению реестра. Однако, при некорректных изменениях реестра могут возникнуть серьезные проблемы. Поэтому выполняйте следующие действия внимательно. Для дополнительной защиты сделайте резервную копию реестра перед внесением изменений. В таком случае при возникновении неполадок можно будет восстановить реестр. Чтобы узнать дополнительные сведения о резервном копировании и восстановлении реестра, щелкните следующий номер статьи базы знаний Майкрософт:
322756 Как выполнять резервное копирование и восстановление реестра Windows
  1. Закройте приложение Outlook.
  2. Откройте редактор реестра.
    • В Windows 8.x, нажмите клавиши Windows, введите команду regedit и нажмите клавишу Ввод.
    • В Windows 7 и Windows Vista нажмите кнопку Пуск, введите в поле Начать поисккоманду regedit и нажмите клавишу Ввод.
  3. Найдите и выделите следующий подраздел реестра:
    HKEY_CURRENT_USER\Software\Microsoft\Office\x.0\Outlook\AutoNameCheck
    Примечание. Заполнитель x.0 в этом подразделе реестра представляет версию Microsoft Office. Используйте соответствующее значение из следующего списка. Outlook 2016 = 16.0 Outlook 2013 = 15.0 Outlook 2010 = 14,0 Outlook 2007 = 12.0 Outlook 2003 = 11.0
  4. В меню Правка выберите пункт Создатьи затем щелкните значение DWORD.
  5. Введите MaxNickNamesи нажмите клавишу Ввод.
  6. В меню Правка щелкните Изменить.
  7. Введите новое значение для ограничения, а затем нажмите кнопку ОК. Заметки
    • Убедитесь в том, введите номер в dДесятичная формы. Это правильная форма для ввода числа.
    • Попробуйте увеличить предел маржинальной прибыли величину для тестирования нового предела. Например чтобы создать ограничение в Outlook 2013 увеличение на 20 процентов, указываются 1200 для значения MaxNickNames.
  8. Закройте редактор реестра.
  9. Запустите приложение Outlook.
Примечание. Значение параметра реестра MaxNickNames просто определяет предел не по умолчанию. Таким образом это значение можно также использовать нижний предел кэша псевдонимов.