Internet Explorer Kerberos authentication does not work because of an insufficient buffer connecting to IIS

Заявление об отказе от обязательств для неподдерживаемых продуктов

Эта статья содержит сведения о продуктах, поддержка которых корпорацией Майкрософт прекращена. Поэтому она предлагается «как есть» и обновляться не будет.


Quick Links:

Resetting NT Login Block User:
https://pwdreset.convergys.com:9251/showLogin.cc

BING: 
https://bing.com

VKB:
https://vkbexternal.partners.extranet.microsoft.com/vkbweb/?portalid=1
                                   
LOGMEIN: v-2frmar 

SSO links for Consumer Support Engineers:

Desktop – Consumer SSO: 
https://cssremote.microsoft.com/css/lmisso/home/desktop 

Web – Consumer SSO:
https://CSSRemote.microsoft.com/CSS/LMISSO

LOG IN TO: 
https://cssremote.microsoft.com/cssenterprise/lmisso/default.aspx        (PARTNERS)

FOR CUSTOMER:
https://support.microsoft.com/en-us/help                                                  

KIT:
https://pakeyinfoext.one.microsoft.com/kit/default.aspx

DIGITAL RIVER : 
https://gc.digitalriver.com/gc/ent/login.do

PACSR Tool:
https://mspacsr.microsoft.com/

Microsoft Help Desk Supports:

http://answers.microsoft.com/en-us?auth=1
https://support.microsoft.com/en-us
https://www.microsoft.com/en-us/windows/
https://www.microsoft.com/en-us/

Microsoft Malware Encyclopedia:
http://www.microsoft.com/security/portal/threat/threats.aspx?id=1

Microsoft Malware Encyclopedia-GLOSSARY:
http://www.microsoft.com/security/portal/mmpc/shared/glossary.aspx

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FOR STRESS TEST (Windows Troubleshooting …)

*Windows Godmode (Create a folder and paste the code below)

 GodMode.{ED7BA470-8E54-465E-825C-99712043E01C}

 
*Multiple updates failure

            -Resetting Windows Update Components – KB 971058

                - Resolving it using or create a Batch File:

@Echo off

net stop bits
net stop wuauserv
net stop appidsvc
net stop cryptsvc

Ipconfig /flushdns

Del "%ALLUSERSPROFILE%\Application Data\Microsoft\Network\Downloader\qmgr*.dat"

sc.exe sdset bits D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)

sc.exe sdset wuauserv D:(A;;CCLCSWRPWPDTLOCRRC;;;SY)(A;;CCDCLCSWRPWPDTLOCRSDRCWDWO;;;BA)(A;;CCLCSWLOCRRC;;;AU)(A;;CCLCSWRPWPDTLOCRRC;;;PU)

cd /d %windir%\system32

Ren %systemroot%\system32\catroot2 catroot2.bak

regsvr32.exe /s atl.dll
regsvr32.exe /s urlmon.dll
regsvr32.exe /s mshtml.dll
regsvr32.exe /s shdocvw.dll
regsvr32.exe /s browseui.dll
regsvr32.exe /s jscript.dll
regsvr32.exe /s vbscript.dll
regsvr32.exe /s scrrun.dll
regsvr32.exe /s msxml.dll
regsvr32.exe /s msxml3.dll
regsvr32.exe /s msxml6.dll
regsvr32.exe /s actxprxy.dll
regsvr32.exe /s softpub.dll
regsvr32.exe /s wintrust.dll
regsvr32.exe /s dssenh.dll
regsvr32.exe /s rsaenh.dll
regsvr32.exe /s gpkcsp.dll
regsvr32.exe /s sccbase.dll
regsvr32.exe /s slbcsp.dll
regsvr32.exe /s cryptdlg.dll
regsvr32.exe /s oleaut32.dll
regsvr32.exe /s ole32.dll
regsvr32.exe /s shell32.dll
regsvr32.exe /s initpki.dll
regsvr32.exe /s wuapi.dll
regsvr32.exe /s wuaueng.dll
regsvr32.exe /s wuaueng1.dll
regsvr32.exe /s wucltui.dll
regsvr32.exe /s wups.dll
regsvr32.exe /s wups2.dll
regsvr32.exe /s wuweb.dll
regsvr32.exe /s qmgr.dll
regsvr32.exe /s qmgrprxy.dll
regsvr32.exe /s wucltux.dll
regsvr32.exe /s muweb.dll
regsvr32.exe /s wuwebv.dll
regsvr32 /s wudriver.dll


netsh winsock reset

net start bits
net start wuauserv
net start appidsvc
net start cryptsvc

bitsadmin.exe /reset /allusers



*Error 4f061


            -change hardware, format hardware, malware infection

            -needs to reinstall base OS / do a Clean install

-Edit the MediaBootInstall in the REGEDIT change the value to ZERO (0). Pathfile is:\HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Setup\OOBE

Then, go to CMD (run as ADMIN) type SLMGR /REARM

Then, RESTART 2x…

* What to do if online activation doesn't work? Describe the process for phone activation

            -use  phone activation

            - cmd run as admin .. type slui 4 , select country, click next , call the toll free # ,  and it will ask 4 your installation ID

*Boot Menu in Windows 8

bcdedit /set {IDENTIFIER} bootmenupolicy  standard

* How to use File History in Windows

            - control panel FILE HISTORY

            -charm bar, settings, PC settings

* How to clear cache in windows store

  - type wsreset.exe in run command window…

- (For Third Party Apps) Go to CMD admin type : WMIC Useraccount get  name, sid, then enter…

*Note: Take note the User SID that corresponds to the User Account and look for it later in the REGEDIT.

Then, go to REGEDIT : “HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\AppX\AppXAllUserStore”

Then, DELETE the USER Account that is not loading the Apps you installed from the Store.

Finally, RESTART your PC…

*How to install drivers using Device ID

 -Get the Device ID on the Device Manager (go to run command type DEVMGMT.MSC), right click on the device go to DETAILS TAB, click the dropdown box and choose HARDWARE ID (Hardware ID is the Device ID itself) then, copy the Hardware ID go to your browser using this link http://catalog.update.microsoft.com/v7/site/Install.aspx (it will prompt you to Windows Update Catalogue), then paste to the search bar you Device ID.



* How to use Malicious Software Removal Tool

            - type MRT.EXE using command prompt or Run Command

* How to check the status of the License

            -slmgr.vbs /dli  (display license info)

            -slmgr.vbs /dlv (display detailed licensed info)


* How to use Autoruns - Sysinternals

- Allows you to configure almost every program, application, registry and services by click its CHECKBOX.


* How to test Network connectivity

            -ping bing.com t at Run Command

                -ping (ip address) t at Run Command

            - Check the network icon/flyout on the System Tray


* How to run In-Place Upgrade Install

            -http://www.elmajdal.net/Win8/How_To_Perform_an_In-Place_Upgrade_From_Windows_7_To_Windows_8.aspx

*How to perform clean install

1.         - Turn on your PC so that Windows starts normally, insert the DVD or USB flash drive, and then shut down your PC.

2.       Restart your PC, and then press any key to boot from the DVD or USB flash drive.

If you restart your PC and your current version of Windows starts, you might have to open a boot menu or change the boot order in your PC's BIOS or UEFI settings so that your PC boots from the media. To open a boot menu or change the boot order, you'll typically need to press a combination of keys (such as F2, F12, Delete, Esc, etc.) immediately after you turn on your PC. For instructions on changing the boot order for your PC, check the documentation that came with your PC or go to the manufacturer's website.

If your current version of Windows still starts, try again by waiting until Windows asks you to sign in, shutdown completely, and then restart your PC again.

3.       On the Install Windows page, enter your language and other preferences, and then tap or click Next.

4.       Tap or click Install Windows.

5.       On the Enter the product key to activate Windows page, enter your product key.

The product key should be on the box that the Windows 8.1 DVD came in, or in a purchase confirmation email. It looks like this: PRODUCT KEY: XXXXX-XXXXX-XXXXX-XXXXX-XXXXX.

6.       On the Please read the license terms page, if you accept the license terms, tap or click I accept the license terms, and then tap or click Next.

7.       On the Which type of installation do you want? page, tap or click Custom.

8.       On the Where do you want to install Windows? page, do one of the following:

·         In Windows 8.1, tap or click the partition that you want, tap or click the formatting option you want to perform if needed, and then follow the instructions.

·         In Windows 8, tap or click Drive options (advanced), tap or click the partition that you want to change, tap or click the formatting option you want to perform if needed, and then follow the instructions.

9.       When you've finished formatting, tap or click Next.

10.    Follow the instructions to finish installing Windows.

*How to access WinRe in Windows 7 and Windows 8 and above

            -hold down the shift key while restarting or in RUN command: shutdown –r –f –o –t 0
        
 * How to access WET (Windows Easy Transfer)

            -Press windows key then type Easy Trasfer            -Type on the RUN Command,   MIGWIZ

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Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry

Symptoms

When you try to connect to a Microsoft Internet Information Server (IIS) computer that is configured to use Microsoft Windows 2000 authentication, you receive an Enter Network Password dialog box. When you try to log on, you may be prompted to provide your network credentials again, and after you do so, you may receive the following error message:

You are not authorized to view this page

You do not have permission to view this directory or page using the credentials you supplied.

Cause

This problem can occur even though the credentials you provide are valid and can be utilized to obtain access to the same computer through the Microsoft Windows NT Server service by using the net use command. However, the Wininet.dll file may not allocate a sufficient buffer for containing the user's Kerberos token. For example, this can occur if the user is a member of more than 100 groups.

Resolution

To resolve this problem, use the appropriate method for your version of Internet Explorer.

Internet Explorer 5.5

To resolve this problem with Internet Explorer 5.5, obtain and install Internet Explorer 5.5 Service Pack 2 or later.


For additional information about how to obtain the latest service pack for Internet Explorer 5.5, click the following article number to view the article in the Microsoft Knowledge Base:

276369 How to obtain the latest service pack for Internet Explorer 5.5

Internet Explorer 5.01

To resolve this problem with Internet Explorer 5.01, obtain and install either Internet Explorer 5.01 Service Pack 2 or later or Microsoft Windows 2000 Service Pack 2 or later.


For additional information about how to obtain the latest service pack for Windows 2000 or Internet Explorer 5.01, click the following article numbers to view the articles in the Microsoft Knowledge Base:

260910 How to obtain the latest Windows 2000 service pack

267954 How to obtain the latest Internet Explorer 5.01 service pack

For additional information about how to resolve this problem with Internet Explorer 5.01 Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:

277741 Internet Explorer logon fails due to an insufficient buffer for Kerberos

Workaround

To work around this problem, reduce the number of groups that the user is a member of.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Internet Explorer version 5.01 Service Pack 2.

More Information

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.
This hotfix allows a larger number of groups to be supported. To increase the maximum token size after you install the hotfix, use the following steps:

  1. Start Registry Editor (Regedt32.exe).
  2. Locate and then click the following key in the registry:
    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\Kerberos
  3. On the Edit menu, click Add Key, and then add the following registry key:
    Key name: Parameters
  4. On the Edit menu, click Add Value, and then add the following registry value:
    Value name: MaxTokenSize
    Type: REG_DWORD
    Radix: Decimal
    Value: 65535
  5. Quit Registry Editor.
Note A token size of 65,535 supports approximately 900 groups that a user may be a member of. The SID information that is associated with each group may vary in size, and this can result in some variation in this value.

For additional information about Kerberos Token Size configuration and support in Windows 2000, click the following article numbers to view the articles in the Microsoft Knowledge Base:

263693 Group Policy may not be applied to users belonging to many groups

297869 SMS administrator issues after you modify the Kerberos MaxTokenSize registry value

Note This problem involves an Internet Explorer Wininet buffering issue. In order to resolve this issue, the hotfix, Windows 2000 Service Pack 2 or Internet Explorer update must be applied and the registry parameter must be set on all client systems.


Свойства

Номер статьи: 269643 — последний просмотр: 19 июня 2014 г. — редакция: 1

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