Проблемы с производительностью Outlook в OST- или PST-файле в режиме кэширования Exchange

Оригинальный номер базы знаний: 2768656

Симптомы

В Microsoft Outlook возникают следующие симптомы:

  • При использовании режима кэширования Exchange или PST-файла данных Outlook вы заметите снижение производительности при выполнении определенных действий.
  • Если папки "Входящие", "Календарь", "Задачи", "Отправленные" или "Удаленные" содержат много элементов, производительность снижается.
  • Производительность календаря не согласована Например, обновления по собранию могут не отображаться в основном, общем или делегированном календаре.
  • Для отображения папок требуется много времени или они отображаются неправильно.
  • Если профиль Outlook содержит общие почтовые ящики и включено кэширование (выбран параметр Скачать общие папки ), возникают проблемы с синхронизацией папок, снижение производительности или другие проблемы, если количество общих папок на почтовый ящик превышает 500. Дополнительные сведения см. в статье Проблемы с производительностью и синхронизацией при работе с папками в дополнительном почтовом ящике в Outlook. Кроме того, ошибки регистрируются в папке Проблемы синхронизации, а события "9646" регистрируются в журнале приложений.
  • В крайних случаях, когда имеется более 10 000 папок, Outlook очень медленно открывается. Это происходит из-за времени, необходимого для перечисления большого количества папок.

Причина

Эти проблемы могут возникать, если почтовый ящик содержит много папок или в одной папке много элементов. Не существует жесткого ограничения на количество папок, которые может содержать почтовый ящик, или количество элементов, которые могут содержаться в папке. Однако производительность может снизиться, так как количество элементов приближается к 10 000 элементов календаря, 10 000 папок или 100 000 почтовых элементов на папку. Большое количество повторяющихся собраний или длительных повторяющихся собраний также может оказать преувеличенное влияние на производительность.

Разрешение

Чтобы устранить проблемы с производительностью, влияющие на календарь, почту или общие папки, используйте следующие решения.

Решения проблем с календарем

Чтобы устранить проблемы с производительностью, влияющие на календарь, попробуйте следующие методы.

Способ 1. Управление ростом исключений для повторяющихся собраний

Не все элементы календаря одинаково влияют на производительность. Однократные собрания имеют относительно небольшой эффект, а длительные, повторяющиеся собрания имеют больший эффект. Изменение, внесенное в экземпляре повторяющегося собрания, создает исключения, которые хранятся в серии повторяющихся собраний. Каждое изменение атрибутов собрания, таких как тема, текст, расположение или время, создает соответствующее исключение. В конечном итоге эти исключения завысят размер повторяющегося собрания и налагают более высокую стоимость производительности. Вы можете снизить эту более высокую стоимость, используя параметры повторения встречи, чтобы задать время окончания или максимальное число повторений. Затем можно создать новое повторяющееся собрание вместо расширения существующего повторения.

Способ 2. Включение улучшений общего календаря

Используйте параметр Включить улучшения общего календаря для пользователей, имеющих разрешения на изменение общего календаря, чтобы повысить производительность. Если этот параметр включен, действия календаря отправляются непосредственно на сервер, а не из локального хранилища. Это повышает эффективность разрешения конфликтов.

Дополнительные сведения об активации улучшений общего календаря и управлении ими см. в статье Включение и отключение обновлений общего доступа к календарю Outlook.

Способ 3. Ограничение окна синхронизации

Вы можете ограничить окно синхронизации, используемое для папок календаря, чтобы уменьшить количество элементов, хранящихся локально в папках календаря. Это может повысить производительность.

Важно!

Точно следуйте всем указаниям из этого раздела. Внесение неправильных изменений в реестр может привести к возникновению серьезных проблем. Прежде чем приступить к изменениям, создайте резервную копию реестра для восстановления на случай возникновения проблем.

В разделе Параметры окна синхронизации настройте количество месяцев данных, синхронизированных для основных общих календарей. Для этого найдите следующие разделы реестра.

Примечание. Этот метод применяется к версии 1810 или более поздней версии Приложения Microsoft 365 для предприятий (нажми и работай).

Описание Параметр для включения окна синхронизации календаря
Путь реестра HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Имя CalendarSyncWindowSetting
Тип REG_DWORD
Значение Значение = 0 (неактивный)
Значение = 1 (папка основного календаря)
Значение = 2 (все папки календаря)
По умолчанию используется значение 0, если не задано.
Описание Параметр для управления количеством месяцев в окне синхронизации календаря
Путь реестра HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Имя CalendarSyncWindowSettingMonths
Тип REG_DWORD
Значение Value = Выберите десятичное значение, чтобы задать количество месяцев в окне синхронизации календаря. Например, выберите 1, 3, 6 или 12.
Значение по умолчанию — 6, если не задано.
Описание Параметр для управления сохранением всех повторяющихся элементов вместо их фильтрации
Путь реестра HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Имя CalendarSyncWindowAllRecurring
Тип REG_DWORD
Значение Значение = 0: будут синхронизированы только повторяющиеся ряды собраний с датой окончания в будущем или в пределах текущего окна синхронизации календаря.
Значение = 1: все повторяющиеся ряды собраний будут синхронизированы независимо от даты окончания.
По умолчанию используется значение 0, если не задано.
Объяснение По умолчанию (если значение не задано или равно 0) будет синхронизирован ряд повторяющихся собраний с датой окончания, которая еще не наступила или попадает в текущий параметр окна синхронизации календаря. Например, если текущая дата — 3 мая 2022 года, а для окна синхронизации календаря установлено значение «1 месяц», весь ряд повторяющихся собраний с датой окончания 3 апреля 2022 года или после нее будет синхронизирован. Если дата окончания находится за пределами параметра окна синхронизации, повторяющийся ряд собраний будет удален из OST-файла.
Чтобы синхронизировать весь ряд повторяющихся собраний независимо от даты окончания, задайте CalendarSyncWindowAllRecurring значение 1.

Эти разделы реестра обновляют ограничение синхронизации, чтобы клиент, использующий режим кэширования Exchange, скачивал меньше элементов календаря даже для календаря с многолетней историей на сервере. Эти разделы не очищают устаревший контент календаря, который был уже загружен. Однако этот метод может быть эффективным в том случае, если вы хотите удалить автономные элементы и повторно синхронизировать календарь (вместо массового удаления старых элементов). Если у вас уже есть календарь в профиле, необходимо удалить автономные элементы после настройки разделов реестра и перезапуска Outlook.

Чтобы удалить автономные элементы календаря, выполните следующие действия:

  1. Откройте панель Календарь в Outlook и щелкните правой кнопкой мыши папку Календарь .
  2. Выберите пункт Свойства.
  3. На вкладке Общие нажмите Удалить автономные элементы.
  4. Нажмите кнопку ОК.

Решения проблем с почтой

Если у вас есть папки, содержимое которых приближается к ограничению в 10 000 элементов календаря, 10 000 папок или 100 000 почтовых элементов, и эти элементы хранятся в файле данных Outlook (PST) или автономном файле данных Outlook (.ost), переместите элементы из больших папок в отдельные или меньшие папки в том же почтовом ящике или файле данных. При необходимости, если у вас есть онлайн-архив Microsoft Exchange, вы можете переместить элементы в этот архив или создать политики хранения для автоматического удаления старых элементов.

Архивирование элементов почты

Если вы включили поддержку онлайн-архива почты, архивируйте в нем элементы.

Применение политики хранения

Чтобы удалить старые элементы из папки "Почта" или "Календарь", примените политику хранения. Например, любой элемент, который не был изменен в течение одного года, перемещается в папку Удаленные.

Решение проблем с общими папками

Чтобы устранить проблемы с производительностью, влияющие на общие папки, попробуйте использовать следующий метод.

Ограничение окна синхронизации

Чтобы уменьшить количество элементов, хранящихся локально, ограничьте окно синхронизации, используемое для общих папок. Это может повысить производительность.

Важно!

Точно следуйте всем указаниям из этого раздела. Внесение неправильных изменений в реестр может привести к возникновению серьезных проблем. Прежде чем приступить к изменениям, создайте резервную копию реестра для восстановления на случай возникновения проблем.

Чтобы изменить количество дней синхронизации данных для общих папок, добавьте следующие значения реестра.

Описание Параметр для включения окна "Общие папки"
Путь реестра HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Cached Mode
Имя SharedFolderSyncWindowSettingDays
Тип REG_DWORD
Значение Value = Выберите десятичное значение, чтобы задать количество дней (1–365) для окна синхронизации общих папок.

Запустить Помощник по поддержке и восстановлению Microsoft

Примечание.

Сценарии служба поддержки Майкрософт и помощника по восстановлению недоступны для новых версий Outlook для Windows.

С помощью служба поддержки Майкрософт и помощника по восстановлению можно диагностировать проблемы с календарем и почтой, влияющие на Outlook. Сведения о том, как скачать и установить помощник, см. в разделе Сведения о служба поддержки Майкрософт и помощнике по восстановлению.

Чтобы определить причину проблем с производительностью, запустите помощник и запустите диагностику Outlook в разделе Расширенная диагностика .

Дополнительная информация

Чтобы просмотреть количество элементов в Календарь Outlook при использовании режима кэширования Exchange, используйте диалоговое окно Свойства календаря:

  1. В Outlook откройте панель Календарь и щелкните правой кнопкой мыши папку Календарь .
  2. Выберите пункт Свойства.
  3. На вкладке Общие выберите Показать полное число элементов.
  4. Выберите вкладку Синхронизация.
  5. Просмотр количества месяцев в разделе Просмотр статистики для этой папки.

Outlook использует файл .ost только в том случае, если учетная запись электронной почты Exchange настроена для использования режима кэширования Exchange. Если Outlook настроен для подключения к почтовому ящику Exchange в режиме .ost "в сети", файл не используется.

Если клиент Outlook подключен к Exchange в интерактивном режиме и у вас нет папок с высоким количеством элементов в PST-файле, на сервере могут возникнуть проблемы с производительностью. Дополнительные сведения см. в статье При наличии большого файла данных Outlook могут возникать приостановки приложений.