Использование функции vCalendar в Outlook

Для версии Microsoft Outlook 2000 в данной статье см.
197025 .
Для версии Microsoft Outlook 98 в данной статье см.
179431 .

Обзор

Microsoft Outlook поддерживает vCalendar, мощный подход для электронных личных данных обмена (PDI). PDI возникает каждый раз при общении пользователей в деловых или личных контекста. Такое общение часто включает обмен информацией, например, визитных карточек, телефонные номера, адреса, даты и времени встреч и т.п. Функции vCard и vCalendar облегчения PDI электронным способом.

Дополнительные сведения

Файлы vCalendar используются для обмена информацией о встречах и расписаниях с пользователями, не находятся в рабочей группе или организации. Их также можно использовать для планирования встреч с пользователями, которые несовместимы с вашими программами.

Как создать файл vCalendar

Чтобы создать файл vCalendar, выполните следующие действия.

В Microsoft Office Outlook 2007 и более ранних версий

  1. В папке Календарь щелкните встречу, для которого требуется файл vCalendar.
  2. В меню Файл выберите команду Сохранить как.
  3. В поле Тип файла выберите вариант vCalendar формате (* .vcs).
  4. В поле Папка щелкните папку, в которой вы хотите сохранить файл vCalendar и нажмите кнопку Сохранить.

В Microsoft Outlook 2013 и Microsoft Outlook 2010, русская версия

  1. В папке Календарь щелкните встречу, для которого требуется файл vCalendar.
  2. Перейдите на вкладку " файл " в представлении Backstage, выберите команду Сохранить как.
  3. В списке Тип файла выберите vCalendar формате (* .vcs).
  4. В списке Сохранить в выберите папку, где вы хотите сохранить файл vCalendar и нажмите кнопку Сохранить.

При распространении файла vCalendar

Можно распространять файлы vCard, как другие компьютерные файлы. Отправьте ее как вложение электронной почты, выполните следующие действия.

В Outlook 2007 и более ранних версий

  1. Откройте новое сообщение электронной почты и адрес получателя.
  2. В меню Вставка выберите команду файл.
  3. Выберите файл vCalendar (.vcs) и нажмите кнопку ОК.

В Outlook 2010 и Outlook 2013

  1. Откройте новое сообщение электронной почты и адрес получателя.
  2. На вкладке « Вставка » нажмите кнопку Вложить файл.
  3. Выберите файл vCalendar (.vcs) и нажмите кнопку Вставить.

Как автоматически процесса в файл vCalendar

С помощью Outlook можно автоматически преобразовывать файл vCalendar, полученный из внешнего источника, в запись встречи Outlook. При получении файла vCalendar в виде вложения электронной почты, можно дважды щелкнуть vCalendar, а затем нажмите кнопку Сохранить и закрыть , чтобы добавить встречу в выбранную по умолчанию папку Календарь.


При получении файла vCalendar в виде файла, возможно на диске, его можно импортировать в папке календаря по умолчанию с помощью Outlook мастер импорта и экспорта. Чтобы сделать...


В Outlook 2007 и более ранних версий

  1. В меню Файл выберите пункт Импорт и экспорт.
  2. Установите импортировать файл iCalendar или vCalendar (* .vcs)и нажмите кнопку Далее.
  3. Выберите файл vCalendar и нажмите кнопку Открыть.

В Outlook 2010

  1. На вкладке « файл » выберите команду Открытьи нажмите кнопку Импорт.
  2. Выберите Импорт файла iCalendar (.ics) или vCalendar (.vcs)и нажмите кнопку Далее.
  3. Выберите файл vCalendar и нажмите кнопку ОК.

В Outlook 2013

  1. На вкладке файл щелкните Открыть & экспортаи нажмите кнопку Импорт/экспорт.
  2. Выберите Импорт файла iCalendar (.ics) или vCalendar (.vcs)и нажмите кнопку Далее.
  3. Выберите файл vCalendar и нажмите кнопку ОК.

Обработка файла как текстового файла vCalendar вручную

Запись vCalendar — в текстовый файл. При отсутствии средства автоматической обработки записей vCalendar, можно открыть их с помощью текстового редактора и использовать информацию. Информация, указываемая создателем файла зависит от содержимого файла vCalendar, но стандартный файл, созданный во встречах Outlook будет выглядеть как в следующем примере в текстовом редакторе:
BEGIN:VCALENDAR
PRODID:-//Microsoft Corporation//Outlook MIMEDIR//EN
VERSION:1.0
BEGIN:VEVENT
DTSTART:19980114T210000Z
DTEND:19980114T230000Z
LOCATION:My office
CATEGORIES:Business
DESCRIPTION;ENCODING=QUOTED-PRINTABLE:This is a note associated with the
meeting=0D=0A
SUMMARY:Meeting to discuss salaries
PRIORITY:3
END:VEVENT
END:VCALENDAR

Примечание: элементы DTSTART и DTEND представляют собой сочетание даты и времени в формате ГГГГMMДДTччммссZ, где ГГГГ = год, MM = месяц, ДД = день месяца, T = знак начала времени, чч = часы, мм = минуты, сс = секунды, Z = знак конца. Данная строка отображает время по Гринвичу (GMT), в 24-часовом формате, поэтому должны быть скорректированы для вашего часового пояса.

Например если вы находитесь в центральном часовом поясе, время является 6 часов за GMT. Таким образом необходимо вычесть 6 часов из времени начала и окончания, чтобы получить правильный отрезок времени для встречи. В предыдущем примере встречи время начала будет 210000-060000 или 150000 в 24-часовом формате. Если время преобразуется часовой, время начала будет 150000-120000 или 3:00 P.M.

Внимание: сведения о как корпорация Майкрософт предоставляет поддержку для общих протоколов щелкните следующий номер статьи базы знаний Майкрософт:
2269506 разработчиков поддерживают ограничения для общих протоколов
Свойства

Номер статьи: 287625 — последний просмотр: 23 февр. 2017 г. — редакция: 1

Microsoft Outlook 2013, Microsoft Outlook 2010, Microsoft Office Outlook 2007, русская версия, Microsoft Office Outlook 2003, Microsoft Outlook 2002 Standard Edition, Microsoft Exchange 2000 Server Standard Edition, Microsoft Exchange Server 2003 Standard Edition, Microsoft Exchange Server 2003 Enterprise Edition, Microsoft Exchange Server 2007 Standard Edition, Microsoft Exchange Server 2007 Enterprise Edition, Microsoft Exchange Server 2010 Standard, Microsoft Exchange Server 2010 Enterprise

Отзывы и предложения