Ошибка возникает во время установки рабочего стола и расположение рабочего стола недоступно при первом входе в Windows
Эта статья поможет решить проблему, из-за которой загрузка профиля завершается сбоем, если ntuser.dat или usrclass.dat файл определен как доступный только для чтения, или пользователь профиля не имеет соответствующих разрешений для этих двух .dat файлов.
Область применения: Windows 10 — все выпуски, Windows Server 2012 R2
Исходный номер базы знаний: 3048895
Симптомы
После установки обновления в статье Уязвимость в службе профилей пользователей Windows может разрешить повышение привилегий: 13 января 2015 г. (MS15-003) вы можете устранить следующие проблемы:
Профили не загружаются при первом входе пользователей на компьютер. Кроме того, вы входите на компьютер, где политика удаляет кэшированный профиль после интервала даты при выходе из системы.
Примечание.
Также могут быть затронуты входы, использующие обязательные профили пользователей или инфраструктура виртуальных рабочих столов (VDI).
Профили не загружаются, когда пользователи входят в систему с помощью кэшированных профилей пользователей.
Службы не запускаются из-за сбоев загрузки профиля. Затронутые службы включают, но не ограничиваются следующими:
- Локальная служба
- Сетевая служба
- MSSQL
При возникновении этой проблемы регистрируются связанные события. Просмотрите события, зарегистрированные в Просмотр событий.
Монитор процессов может указывать на сбой операции CreateFile с результатом ACCESS DENIED по следующему пути в зависимости от того, как ограничен доступ к файлам: <drive>:\documents & settings\<username>\local settings\Application Data\Microsoft\Windows\UsrClasss.dat.
Снимок экрана монитора процессов можно увидеть здесь:
См . сведения о сбое, отображаемые в мониторе процессов.
Причина
Обновление 3021674 добавляет проверки доступа к файлам Ntuser.dat и Usrclass.dat.
Разрешение
Чтобы устранить эту проблему, выполните следующие действия.
Проверьте, установлен ли флаг READ ONLY для NTUSER. DAT или USERCLASS. DAT-файл для профиля, который не загружается.
Новые профили пользователей являются производными от C:\users\default\ при первом входе в учетную запись. Если в профилях не удается загрузить сигнатуры, соответствующие описанным в разделе "Симптомы", проверка, включен ли бит Read-Only в NTUSER. DAT и USRCLASS. DAT-файлы в каталоге профиля для пользователей или учетных записей служб.
NTUSER. DAT в Windows Vista и более поздних версиях Windows находится в папке C:\users\default\ntuser.dat. Более ранние операционные системы имеют другие пути, например C:\Documents и Settings\<username>\ntuser.dat.
The USRCLASS. DAT-файл обычно находится по пути, например C:\Documents and Settings<user_name>\Local Settings\Application Data\Microsoft\Windows\UsrClass.dat или C:\Users<user_name>\AppData\Local\Microsoft\Windows.
В Windows Обозреватель щелкните правой кнопкой мыши NTUSER. DAT или USRCLASS-файл для соответствующего пользователя по умолчанию или кэшированного профиля пользователя. Поле проверка только для чтения должно быть очищено. Если выбрано это поле проверка, это приведет к сбою загрузки профиля.
Проверьте параметр разрешений файловой системы NTFS в NTUSER. DAT или USERCLASS. DAT-файл в каталоге кэшированного профиля, который не удается загрузить.
На следующем снимке экрана тестовый пользователь CONTOSO/testUser имеет полный контроль над NTUSER. DAT (не отображается) и USRCLASS.DAT. Все пользователи не перечислены в группе ACL Редактор.
Файловая система NTFS ACLS в DAT-файлах | Расширенные ACLS файловой системы NTFS в DAT-файлах |
---|---|
|
Состояние
Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Применимо к».
Дополнительная информация
События, зарегистрированные в Просмотр событий
Имя журнала | Отправитель событий | Идентификатор события | Текст сообщения о событии |
---|---|---|---|
Приложение | Служба профилей пользователей Microsoft-Windows | 1542 | Windows не удается загрузить файл реестра классов. DETAIL — не указанная ошибка Die Klassenregistrierungsdatei kann nicht geladen werden. DETAIL - Unbekannter Fehler |
Приложение | Диспетчер управления службами | 7005 | Сбой вызова LoadUserProfile со следующей ошибкой: Не удается найти указанный файл. |
Приложение | Диспетчер управления службами | 7024 | Служба SQL Server (MSSQLSERVER) завершилась с 2148081668 ошибок для конкретной службы (0x80092004). |
Приложение | Userenv | 1500 | Windows не может войти в систему, так как не удается загрузить профиль. Убедитесь, что вы подключены к сети или что сеть работает правильно. Если эта проблема не исчезнет, обратитесь к администратору сети. DETAIL — системе не удается найти указанный файл. |
Приложение | Userenv | 1502 | Windows не удается загрузить локально сохраненный профиль. Возможные причины этой ошибки включают недостаточные права безопасности или поврежденный локальный профиль. Если эта проблема не исчезнет, обратитесь к администратору сети. |
Сведения о сбое, отображаемые в мониторе процессов
Сведения о ProMonВ мониторе процессов отображается следующее сообщение:
Желаемый доступ: универсальный режим чтения и записи, ликвидация: Открыть, параметры: синхронный ввод-вывод без предупреждения, файл, не относясь к каталогу, атрибуты: H, ShareMode: чтение, запись, выделение: n/a, олицетворение: <SID>
На следующем снимку экрана показаны сведения о мониторе процессов:
Обратная связь
https://aka.ms/ContentUserFeedback.
Ожидается в ближайшее время: в течение 2024 года мы постепенно откажемся от GitHub Issues как механизма обратной связи для контента и заменим его новой системой обратной связи. Дополнительные сведения см. в разделеОтправить и просмотреть отзыв по