Компьютер под управлением Windows 2000 не отвечает, не удается войти в Windows или загрузка центрального процессора для процесса System достигает 100%

Проблема

В Windows 2000 после установки обновления безопасности, описанного в бюллетене по безопасности MS04-011, может наблюдаться следующее поведение.
  • При загрузке компьютер перестает отвечать.
  • Не удается войти в Windows.
  • Процесс System занимает 100% ресурсов процессора.
Примечание. На компьютерах под управлением Microsoft Windows XP и Microsoft Windows Server 2003 установка указанного обновления безопасности не приводит к появлению рассматриваемой проблемы.

Чтобы ознакомиться с полной версией бюллетеня по безопасности MS04-011, обратитесь на веб-узел корпорации Майкрософт по адресу:

Причина

Обновление безопасности, описанное в бюллетене по безопасности MS04-011, содержит ошибку, заставляющую операционную систему Microsoft Windows 2000 многократно загружать драйверы, при загрузке которых возникают сбои. Корпорация Майкрософт подтверждает, что данная проблема возникает при использовании одного из следующих драйверов.
  • Ipsecw2k.sys
  • Imcide.sys
  • Dlttape.sys
Например, корпорация Майкрософт подтверждает, что данная ошибка возникает при использовании клиента Nortel Networks VPN client, если параметру «Тип запуска» службы «Агент политики IPSEC» присвоено значение «Авто» или «Вручную».

Решение

Сведения об исправлении

Данная проблема может быть решена с помощью исправления, выпущенного корпорацией Майкрософт. Предлагаемое исправление должно применяться исключительно в системах, где наблюдается вышеописанная проблема.

Чтобы получить исправление, свяжитесь со службами технической поддержки Майкрософт. Полный список телефонов служб поддержки, а также сведения об условиях обслуживания см. на веб-узле корпорации Майкрософт по адресу:Примечание. В отдельных случаях, если специалистом службы технической поддержки Майкрософт будет определено, что решением проблемы является специально выпущенное исправление, оплата, предусмотренная за обращение в службы технической поддержки, может быть отменена. Дополнительные услуги по технической поддержке, не связанные с данным исправлением, оплачиваются на стандартных условиях.

Необходимые условия

Для установки исправления требуется Windows 2000 с пакетом обновления 3 (SP3).

Необходимость перезагрузки

После установки исправления компьютер необходимо перезагрузить.

Сведения о замене исправлений

Это исправление не заменяет других исправлений.

Сведения о файлах

Английская версия обновления содержит версии файлов, приведенные в следующей таблице, или более поздние. Дата и время указаны в формате универсального всемирного времени (по Гринвичу). При просмотре сведений о файле в системе происходит автоматическое преобразование соответствующих значений к местному времени. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать вкладку Часовой пояс элемента «Дата и время» на панели управления.

Дата Время Версия Размер Имя файла
--------------------------------------------------------------
24-мар-2004 02:17 5.0.2195.6824 42 256 Basesrv.dll
21-сен-2003 00:45 5.0.2195.6824 236 304 Cmd.exe
24-мар-2004 02:17 5.0.2195.6898 242 448 Gdi32.dll
24-мар-2004 00:46 502 Hfsecper.inf
17-мар-2004 21:50 502 Hfsecupd.inf
24-мар-2004 02:17 5.0.2195.6897 742 160 Kernel32.dll
10-фев-2004 19:47 5.0.2195.6897 30 160 Mountmgr.sys
24-мар-2004 02:17 5.0.2195.6824 54 544 Mpr.dll
24-мар-2004 02:17 5.0.2195.6895 335 120 Msgina.dll
24-мар-2004 02:17 5.0.2195.6899 497 936 Ntdll.dll
30-апр-2004 02:35 5.0.2195.6927 1 701 312 Ntkrnlmp.exe
30-апр-2004 02:35 5.0.2195.6927 1 700 992 Ntkrnlpa.exe
30-апр-2004 02:35 5.0.2195.6927 1 722 624 Ntkrpamp.exe
30-апр-2004 02:35 5.0.2195.6927 1 678 144 Ntoskrnl.exe
24-мар-2004 02:17 5.0.2195.6892 90 264 Rdpwd.sys
05-фев-2004 20:18 5.0.2195.6896 5 869 056 Sp3res.dll
24-мар-2004 02:17 5.0.2195.6897 403 216 User32.dll
05-авг-2003 22:14 5.0.2195.6794 385 808 Userenv.dll
11-мар-2004 02:37 5.0.2195.6897 1 720 368 Win32k.sys
11-мар-2004 02:37 5.0.2195.6898 181 520 Winlogon.exe
25-сен-2003 18:08 5.0.2195.6826 243 984 Winsrv.dll
24-мар-2004 02:17 5.0.2195.6897 742 160 Kernel32.dll
24-мар-2004 02:17 5.0.2195.6899 497 936 Ntdll.dll
11-мар-2004 02:37 5.0.2195.6897 1 720 368 Win32k.sys
25-сен-2003 18:08 5.0.2195.6826 243 984 Winsrv.dll
03-мая-2004 21:50 14 478 Kb841382.cat

Временное решение

На компьютерах, использующих клиент Nortel Networks VPN, для временного решения проблемы следует загрузить компьютер в безопасном режиме или запустить консоль восстановления и отключить службу «Агент политики IPSEC».

Примечание. Данная проблема может возникать, если при загрузке каких-либо служб или устройств происходит сбой. Приведенное временное решение предназначено только для устранения рассматриваемой проблемы на компьютерах, использующих драйверы клиента Nortel Networks VPN client.

Загрузка компьютера в безопасном режиме и отключение службы «Агент политики IPSEC»

  1. Перезагрузите компьютер.
  2. При появлении сообщения «Выберите операционную систему для запуска» нажмите клавишу F8.
  3. Выберите пункт Безопасный режим и нажмите клавишу ВВОД. После появления экрана выбора операционной системы нажмите клавишу ВВОД.
  4. Нажмите кнопку Пуск, выберите пункт Выполнить, введите команду compmgmt.msc /s и нажмите кнопку ОК.
  5. В оснастке «Управление компьютером» разверните узел Службы и приложения, щелкните элемент Службы и дважды щелкните службу Агент политики IPSec.
  6. На вкладке Общие установите для параметра «Тип запуска» значение Отключено.
  7. Нажмите кнопку OK и перезагрузите компьютер.

Загрузка консоли восстановления и отключение службы «Агент политики IPSEC»

  1. Вставьте компакт-диск Windows 2000 или загрузочную дискету Windows 2000 и перезапустите компьютер.
  2. Если необходимо, укажите дополнительные параметры, требуемые для загрузки компьютера с компакт-диска или DVD-диска.
  3. При появлении сообщения Вас приветствует программа установки нажмите клавишу R, чтобы выбрать режим восстановления, а затем нажмите клавишу C, чтобы запустить консоль восстановления.
  4. При наличии двух или более операционных систем выберите экземпляр Windows, к которому требуется получить доступ с консоли восстановления.
  5. Введите пароль администратора.

    Если пароль для учетной записи администратора не установлен, нажмите клавишу ВВОД.
  6. Чтобы отключить службу «Агент политики IPSec», выполните в командной строке команду disable policyagent.
  7. Чтобы завершить работу консоли восстановления, введите команду exit и нажмите клавишу ВВОД.
  8. Перезагрузите компьютер.

Статус

Данное поведение является подтвержденной ошибкой продуктов Майкрософт, перечисленных в разделе «Информация в данной статье применима к».

Корпорация Майкрософт работает над устранением этой проблемы. Дополнительная информация будет размещаться по мере ее появления.

Дополнительная информация

В данной статье упомянуты программные продукты сторонних производителей. Корпорация Майкрософт не дает никаких явных или подразумеваемых гарантий относительно корректной работы или надежности таких продуктов.
Свойства

Номер статьи: 841382 — последний просмотр: 1 окт. 2008 г. — редакция: 1

Отзывы и предложения