Сообщение об ошибке в экранов в Microsoft Dynamics SL: «Системное сообщение 10232 - ошибка»


Симптомы


Появляется сообщение об ошибке, подобное приведенному ниже различных диалоговых окнах Microsoft Dynamics SL 7.0: o{17944DF6-4CA9-4C98-98D7-03952B59E82Ct{17944DF6-4CA9-4C98-98D7-03952B59E82C. { 03952B59E82C-17944DF6-4CA9 - 4C-98-98D 7:
Системное сообщение 10232 - ошибка! Файл: % строки: % выражение: %s нажмите ОК, чтобы остановить программу и отчет об этой ошибке в службу технической поддержки Майкрософт, отметить неудачных выражение имя файла и номер строки.

Причина


Это сообщение об ошибке может возникать по нескольким причинам.
  • Происходит, когда повреждена или конфликтует с другой настройки настройки экрана. Решение 1 см.
  • Поскольку макрос данных файла или элемента управления не соответствует экрана, импортируются в правильно происходит во время операции импорта. Решение 2 см.
  • Происходит, когда версия файла swimapi.dll, установленного на локальном диске отличается от версии, установленной на файловом сервере Microsoft Dynamics SL. Решение 3 см.
  • Происходит при нажатии кнопки вставки в экране шаблона (98.230.00) . Решение 4 см.
  • Происходит при открытии экрана, содержащую таблицу. Разрешение 5 см.
  • Происходит при попытке выбрать принтер для шаблона отчета. Разрешение 6 см.

Решение


Решение 1


Определите, является ли экран настройки повреждена или конфликтует с другой настройки путем открытия экрана в стандартном режиме. Чтобы сделать это, выполните следующие действия.


Если вы используете Microsoft Dynamics SL 7.0 и более поздних версиях, выполните следующие действия:
  1. В строке состояния щелкните Self.
  2. Выберите стандартныйи нажмите кнопку ОК..
  3. Откройте пользовательский экран.
    Примечание. Если системное сообщение 10232 не возникает при открытии экрана в стандартном режиме, настройки, является источником проблемы и придется создавать заново.

Если вы используете Microsoft Dynamics SL 6.5, выполните следующие действия:
  1. В меню Настройка нажмите кнопку Выбрать.
  2. Выберите стандартныйи нажмите кнопку ОК.
  3. Откройте пользовательский экран.
    Примечание. Если системное сообщение 10232 не возникает при открытии экрана в стандартном режиме, настройки, является источником проблемы и придется создавать заново.

Решение 2


Создание макроса данных файла и элемента управления, на соответствие на экран, который вы импортируете данные.
Примечание см. файл справки для операции импорта или импорта транзакций вручную Дополнительные сведения о том, как создать файлы данных и управления макросами, которые правильно отформатирован.

Решение 3


Убедитесь, что построение ядра Microsoft Dyamics SL, установленный на локальном жестком диске так же, как и на файловом сервере. Чтобы сделать это, выполните следующие действия.
  1. Запустите Microsoft Dynamics SL и выберите команду Справка.
  2. В меню Справка выберите пункт О SL Microsoft Dynamicsи запишите номер версии.
  3. Повторите шаги 1 и 2 на файловом сервере Microsoft Dynamics SL.

Примечание. Если номера версий различаются, установите соответствующее обновление Microsoft Dynamics SL на локальный диск.
Для получения дополнительных сведений о Microsoft Dynamics SL ядра построения, щелкните следующий номер статьи базы знаний Майкрософт:

Список 850447 версии, выпуски и версии ядра Microsoft Dynamics SL


Решение 4


Удалить и заново создать шаблон. Чтобы сделать это, выполните следующие действия.
  1. Откройте соответствующее окно.
  2. Нажмите кнопку действия, выберите шаблони введите код в поле Код шаблона .
  3. Нажмите кнопку Удалитьи затем нажмите кнопку Да при появлении следующее сообщение с подтверждением:
    Системное сообщение 12 - вы уверены, что хотите удалить?
  4. Повторно создайте шаблон, используя соответствующие значения.

Решение 5


Вручную зарегистрируйте MSIGRID. OCX-файл. Чтобы сделать это, выполните следующие действия.
  1. Найдите MSIGRID. OCX-файл следующие пути:
    32-разрядная операционная система: < SystemDrive >: \Windows\System32
    64-разрядная операционная система: < SystemDrive >: \Windows\SysWOW64

    Примечание < SystemDrive > представляет диск, на котором установлена Microsoft Windows.
  2. Щелкните правой кнопкой мыши MSIGRID. OCX файла и нажмите кнопку Открыть с помощью .
  3. В диалоговом окне Windows щелкните выбрать программу из списка и нажмите кнопку ОК .
  4. Нажмите кнопку Обзор в диалоговом окне Открыть с помощью .
  5. Найдите и откройте следующую папку: 32-разрядной операционной системе: < SystemDrive >: \Windows\System32 64-разрядная операционная система: < SystemDrive >: \Windows\SysWOW64
  6. Дважды щелкните файл Regsvr32.exe, а затем нажмите кнопку ОК .
  7. Найдите и откройте следующую папку: 32-разрядной операционной системе: < SystemDrive >: \Windows\System32 64-разрядная операционная система: < SystemDrive >: \Windows\SysWOW64
  8. Нажмите кнопку OK , когда появится следующее сообщение:
    RegSvr32 - Функция DllRegisterServer в системный_диск: успешно \windows\system32\msigrid.ocx.

Решение 6


Удалить шаблон и выберите нужный принтер в окне Параметры принтера (98.220.00) до повторного создания шаблона.
Примечание: При создании шаблона на конечный принтер сведения о драйвере принтера, который указан в окне Параметры принтера (98.220.00) кодируется в шаблон.