Сообщение об ошибке при попытке войти в Microsoft Dynamics SL: «системное сообщение 5003 - не удалось открыть указанный сервер базы данных»


Симптомы


При попытке войти в Microsoft Business Solutions - Соломоновы или Microsoft Dynamics SL, появляется следующее сообщение об ошибке:
Системное сообщение 5003 - не удалось открыть указанный сервер базы данных

Причина


Причина 1

Значение имя_сервера в таблице в базе данных системы Microsoft Dynamics SL домена не соответствует имени экземпляра SQL Server, содержащий базы данных Microsoft Dynamics SL. Решение 1 см.

Причина 2

Старый сервер указывает псевдоним в Client Network Utility. Убедитесь в правильности псевдоним в Client Network Utility. Решение 2 см.

Причина 3

Протокол TCP/IP и протокол именованных каналов не включены в Client Network Utility. Решение 3 см.

Причина 4

Происходит при попытке войти в новую базу данных Microsoft Dynamics SL приложения и имя базы данных начинается с числа. Из-за ограничений в SQL Server, имена баз данных должны начинаться с буквенного знака. Решение 4 см.

Причина 5

Из-за недостаточных разрешений Windows не удается установить подключение к серверу именованные каналы. Разрешение 5 см.

Причина 6

Неправильно настроен протокол TCP/IP. Разрешение 6 см.

Причина 7

База данных устанавливается в однопользовательском режиме. Разрешение 7 см.

Причина 8

Файл Capicom.dll на компьютере, где получения ошибки либо поврежден, либо версия неверна. Разрешение 8 см.

Причина 9

Брандмауэр Windows на SQL Server блокирует доступ к базам данных SQL Server / SL. Разрешение 9 см.

Причина 10

В Microsoft Dynamics SL используется модель безопасности проверки подлинности Windows. Тем не менее есть не связан идентификатор пользователя в Microsoft Dynamics SL идентификатор пользователя в Windows. Кроме того вручную созданный идентификатор пользователя в базе данных системы Microsoft Dynamics SL в SQL Server. Разрешение 10 см.

Причина 11

Учетная запись пользователя Microsoft Dynamics SL является членом группы «АДМИНИСТРАТОРЫ» в Microsoft Dynamics SL. Тем не менее связанной учетной записи пользователя домена Windows, не является членом роли sysadmin в SQL Server. Решение 11 и 12 разрешения см.

Причина 12

Брандмауэр Windows в Windows Server 2008 R2 блокирует доступ к базам данных SQL Server / SL. Разрешение 13 см.

Причина 13

В случае в окне Find Database (98.000.01) используется для выбора базы данных приложения в поле Имя базы данных . Разрешение 14 см.



Cause 14

При нажатии кнопки ОК после выбора имя сервера и имя базы данных происходит в окне Find Database (98.000.01). Разрешение 15 см.



Решение


Решение 1

Проверьте значение имя_сервера в таблице домена убедитесь, что значение соответствует имени экземпляра SQL Server, где находится установка Microsoft Dynamics SL.
  1. В среде SQL Server Management Studio выполните следующую инструкцию в базе данных системы Microsoft Dynamics SL.
    Select servername, * from domain
  2. Если значение имя сервера не соответствует имени экземпляра SQL Server, выполните следующую инструкцию, чтобы обновить значение имя_сервера:
    UPDATE Domain SET ServerName = '<Nameofserver>'--Replace the <Nameofserver> placeholder with the instance name of SQL Server.
  3. Войдите в систему обслуживания базы данных.
  4. На вкладке Обновления баз данных выберите базу данных системы Microsoft Dynamics SL и всех связанных приложений баз данных и нажмите кнопку Обновление представления.

Решение 2

Удаляет псевдоним, который ссылается на старом сервере. Чтобы сделать это, выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт выполнить, введите cliconfgи нажмите клавишу Ввод.
  2. На вкладке « псевдоним » убедитесь, что все псевдонимы в списке являются точными и предназначены для текущего сервера. Если все псевдонимы ссылаются на старые серверы, использование указателя для переключения фокуса, который требуется удалить и нажмите кнопку Удалить.
  3. Нажмите кнопку ОК.

На компьютер с 32-разрядной.
Последовательно выберите пункты Пуск > выполнить > введите cliconfg

На 64-разрядном компьютере:
1. Перейдите к C:\Windows\SysWOW64
2. Запустите cliconfg.exe в этой папке

Решение 3

Проверьте TCP/IP и именованные каналы включены в Client Network Utility.
  1. Нажмите кнопку Пуск, выберите пункт выполнить, введите cliconfgи нажмите клавишу Ввод.
  2. На вкладке Общие убедитесь, что протокол TCP/IP и протокол именованных каналов отображаются в Включенные протоколы по порядку. Если эти протоколы не включены, поместить фокус на каждый из них с помощью указателя и нажмите кнопку Включить.
  3. Если протокол именованных каналов не является первым протоколом в списке, выберите протокол именованных каналов и используйте клавиши со стрелками для перемещения.
  4. Нажмите кнопку ОК.

    Примечание. Как правило нет нет рекомендации набор, на котором сначала следует загрузить протокол. В зависимости от конфигурации сети один протокол может работать лучше, чем другой.

На компьютер с 32-разрядной.
1. Перейдите Пуск > выполнить > введите cliconfg
2. Убедитесь что TCP/IP и именованные каналы включены.

На 64-разрядном компьютере:
1. Перейдите к C:\Windows\SysWOW64
2. Запустите cliconfg.exe в этой папке
3. Убедитесь что TCP/IP и именованные каналы включены.

Решение 4

Создать резервную копию существующего приложения Microsoft Dynamics SL и системные базы данных и затем восстановить базы данных на том же сервере, используя имена альфа-базы данных. Сведения о том, как резервное копирование и восстановление баз данных, щелкните следующий номер статьи базы знаний Майкрософт:

846350 шаги по базы данных Microsoft Dynamics SL переместить на другой компьютер, на котором запущен SQL Server 2000, SQL Server 2005 или SQL Server 2008

Примечание. На шаге 4 убедитесь, что восстановление базы данных в одном SQL Server.

Решение 5

Предоставление прав пользователя в Windows.


Примечание. SQL Server не удается прочитать параметры реестра для установления подключения именованного канала, так как пользователь не имеет достаточных разрешений в Windows. Обратитесь к администратору сети за помощью.


Решение 6

Проверьте правильность настройки TCP/IP.
  1. Использовать DHCP для назначения IP-адресов, убедитесь, что компьютер, создающий ошибку извещает назначить адрес, вместо присвоения статического IP-адреса DHCP-сервера.
  2. Убедитесь, что связь с сервером рабочей станции. Чтобы сделать это, выполните следующие действия.
    1. Нажмите кнопку Пуск, выберите пункт выполнить, введите cmdи нажмите клавишу Ввод.
    2. В командной строке DOS введите ping < имя_сервера > или < ServerIPAddress >ping.

      Примечание. Замените заполнитель < имя_сервера > имя сервера. Вместо элемента < ServerIPAddress > — IP-адрес сервера.
  3. При использовании статического разрешение имен DNS, добавьте сервер, на котором выполняется SQL Server, в списке Порядок поиска DNS сервера в конфигурации DNS - свойства TCP/IP - сети или к файлу узлов на компьютере рабочей станции. Обратитесь к администратору сети за помощью.

Решение 7

Снимите флажок одного пользователя доступ в свойствах базы данных.

  1. Откройте среду SQL Server Management Studio.
  2. Разверните узел базы данных.
  3. Щелкните правой кнопкой мыши базу данных приложения Microsoft Dynamics SL, нажмите кнопку Свойства.
  4. Параметры страницы и убедитесь, что Один пользователь не установлен в значение Ограничения доступа .

Решение 8

Проверка версии файла Capicom.dll и зарегистрировать файл вручную.
  1. Найдите файл Capicom.dll следующие пути:


    32-разрядной операционной системе: < SystemDrive > : \Windows\System32

    64-разрядной операционной системе: < SystemDrive > : \Windows\SysWOW64

    Примечание. < SystemDrive > — это буква диска, на котором установлена Microsoft Windows.
  2. Убедитесь, что версия файла Capicom.dll 2.1.0.1. Чтобы сделать это, выполните следующие действия.
    1. Файл Capicom.dll правой кнопкой мыши и выберите команду Свойства. Появится диалоговое окно свойств файла capicom.dll .
    2. На вкладке версия убедитесь, что версия файла значение 2.1.0.1.
    3. Нажмите кнопку ОК.
  3. Файл Capicom.dll правой кнопкой мыши и выберите команду Открыть с помощью.
  4. В диалоговом окне Windows щелкните выбрать программу из спискаи нажмите кнопку ОК.
  5. Нажмите кнопку Обзорв диалоговом окне Открыть с помощью .
  6. Найдите и откройте следующую папку:

    32-разрядной операционной системе: < SystemDrive > : \Windows\System32
    64-разрядной операционной системе: < SystemDrive > : \Windows\SysWOW64
  7. Дважды щелкните файл Regsvr32.exe, а затем нажмите кнопку ОК.
  8. Нажмите кнопку OK , когда появится следующее сообщение:
    RegSvr32 - Функция DllRegisterServer в системный_диск: успешно \windows\system32\capicom.dll.

Решение 9

Откройте порт 1433 на SQL Server. Чтобы сделать это, выполните следующие действия.
  1. Выберите Брандмауэр Windowsв панели управления.
  2. На вкладке исключения щелкните Добавить порт.
  3. Укажите следующие параметры:
    • Имя: 1433
    • Номер порта: 1433
    • Выберите TCP.
  4. Два раза нажмите кнопку ОК .

Разрешение 10

Удалить пользователя, код, созданный в SQL, а затем ссылку Microsoft Dynamics SL идентификатор пользователя для пользователя Windows код. Чтобы сделать это, выполните следующие действия.
  1. Удалите идентификатор пользователя, который был создан в SQL:
    1. В среде SQL Server Management Studio разверните узел базы данных, разверните базу данных системы Microsoft Dynamics SL, разверните узел Безопасностьи разверните пользователей.
    2. Щелкните правой кнопкой мыши идентификатор пользователя, который был создан и нажмите кнопку Удалить.
    3. В диалоговом окне Удаление объекта нажмите кнопку ОК.
  2. Свяжите идентификатор пользователя Microsoft Dynamics SL идентификатор пользователя Windows:
    1. Войдите в Microsoft Dynamics SL, используя идентификатор пользователя SYSADMIN
    2. В области переходов щелкните ссылку Администрирование.
    3. В области сведений Администрирование безопасности, нажмите кнопку Обслуживание.
    4. В поле Код пользователя введите идентификатор пользователя, не может войти в систему Microsoft Dynamics SL.
    5. На вкладке сведения в поле Имя пользователя Windows введите < имя_домена >\< имя пользователя >.

      Примечание. Замена местозаполнителя < имя_домена > с именем домена Windows и заменить заполнитель < имя_пользователя > идентификатор пользователя Windows.
    6. Нажмите кнопку Сохранить, а затем закройте окно Обслуживание (95.260.00) .

Решение 11

Синхронизируйте владельца и параметров безопасности для баз данных Microsoft Dynamics SL. Чтобы сделать это, выполните следующие действия.
  1. Откройте окно Обслуживания базы данных (98.290.00) .
  2. В поле Имя назначения SQL Server введите имя сервера.
  3. Введите в поле Код входа sa.
  4. В поле пароль введите пароль для пользователя SYSADMIN.
  5. Нажмите кнопку подключения.

  6. На вкладке Обновить базы данных iIn поле Имя системной базы данных нажмите кнопку Системная база данных.
  7. В столбце « базы данных » выберите базу данных приложения.
  8. В области Скриптов обновления выберите синхронизировать все владения и безопасности.
  9. Нажмите кнопку Обновить базу данных.
  10. Закройте окно Обслуживания базы данных (98.290.00) .

Разрешение 12

Удалить и повторно добавить всех пользователей в группы «АДМИНИСТРАТОРЫ» в Microsoft Dynamics SL. Чтобы сделать это, выполните следующие действия.

Примечание. Данное решение предполагает, что одно или более чем одной учетной записи пользователя Microsoft Dynamics SL, обладающей административными разрешениями может войти в Microsoft Dynamics SL.
  1. Войдите в домен с использованием учетной записи пользователя домена Windows, связанного с Microsoft Dynamics SL учетной записи пользователя, обладающего правами администратора.
  2. Щелкните ссылку Администрирование.
  3. В области Диспетчер системы пункт Обслуживания группы безопасности.
  4. В поле Код группы введите АДМИНИСТРАТОРЫи нажмите клавишу TAB.
  5. Обратите внимание, что идентификаторы пользователей отображаются в области сведений .
  6. Удалите всех пользователей из списка, за исключением пользователь вошел как идентификатор пользователя.
  7. Нажмите кнопку Сохранить.
  8. Добавьте идентификаторы пользователей и нажмите кнопку Сохранить.
  9. Закрыть
    Экран Группы обслуживания (95.280.00) .


Разрешение 13


Откройте номера порта 1433 и 1434. Чтобы сделать это, выполните следующие действия.
  1. На компьютере, на котором выполняется SQL Server нажмите кнопку Пуск, выберите пункт Администрированиеи выберите Брандмауэр Windows в режиме повышенной безопасности.
  2. Щелкните правой кнопкой мыши Правила для входящих подключений, нажмите кнопку Новое правилои нажмите кнопку Далее.
  3. Выберите Все программыи нажмите кнопку Далее.
  4. Нажмите кнопку Далее, снимите флажок « Public » и нажмите кнопку Далее.
  5. В поле имя введите SQL SERVER и нажмите кнопку Готово.
  6. В области Правила для входящих подключений щелкните правой кнопкой мыши SQL SERVERи выберите команду Свойства.
  7. На вкладке « протоколы и порты » выберитеTCP в поле тип протокола .
  8. В поле Локальный порт выберите Определенные портыи введите 1433.
  9. Нажмите кнопку Применить и нажмите кнопку ОК.
  10. Щелкните правой кнопкой мыши Правила для входящих подключений, нажмите кнопку Новое правилои нажмите кнопку Далее
  11. Выберите Все программы и нажмите кнопку Далее.
  12. Нажмите кнопку Далее, снимите флажок « Public » и нажмите кнопку Далее.
  13. В поле имя введите SQL SERVER, ОБОЗРЕВАТЕЛЬ и нажмите кнопку Готово.
  14. В области Правила для входящих подключений щелкните правой кнопкой мыши ОБОЗРЕВАТЕЛЬ SQL SERVERи выберите команду Свойства.
  15. На вкладке « протоколы и порты » выберите в поле тип протокола UDP .
  16. В поле Локальный порт выберитеОпределенные портыи введите 1434.
  17. Нажмите кнопку Применить, а затем нажмите кнопку ОК , чтобы закрыть диалоговое окно Свойства ОБОЗРЕВАТЕЛЯ SQL SERVER.

Разрешение 13


Выберите имя базы данных системы appropiate в поле Имя базы данных и нажмите кнопку ОК.

Resolution 15


Добавьте псевдоним SQL server в SQL Server Client Network Utility:

На 32-разрядном компьютере:
1. Перейдите Пуск > выполнить > введите cliconfg
2. Убедитесь что TCP/IP и именованные каналы включены.
3. на вкладке псевдоним нажмите кнопку Добавить
4. для псевдоним сервера введите имя вашего сервера точно так, как вы печатаете на экране Поиск баз данных
5. оставьте все еще по умолчанию. (по умолчанию как псевдоним именованные каналы)
6. нажмите кнопку ОК.
7. нажмите кнопку Применить.
8. нажмите кнопку ОК.

На 64-разрядном компьютере:
1. Перейдите к C:\Windows\SysWOW64
2. Запустите cliconfg.exe в этой папке
3. Убедитесь что TCP/IP и именованные каналы включены.
4. на вкладке псевдоним нажмите кнопку Добавить
5 для псевдоним сервера введите имя вашего сервера точно так, как вы печатаете на экране Поиск баз данных
6 оставить все еще по умолчанию. (по умолчанию как псевдоним именованные каналы)
7 нажмите кнопку OK.
8. нажмите кнопку Применить.
9 нажмите кнопку OK.


Дополнительные сведения


Чтобы исключить проблемы сети, создайте подключение ODBC тест на компьютере, где появляется сообщение об ошибке. Чтобы сделать это, выполните следующие действия.
  1. В панели управления выберите пункт Администрированиеи щелкните Источники данных (ODBC).
  2. На вкладке « Пользовательское DSN » нажмите кнопку Добавить, перейдите к концу списка, нажмите кнопку SQL Serverи нажмите кнопку Готово.
  3. Укажите следующие параметры:
    • Имя: Тест
    • Описание: Тест
    • Сервер: Введите SQL Server, к которому требуется подключиться.
  4. Нажмите кнопку Далее.
  5. Выберите проверку подлинности windows или проверку подлинности SQL и введите sa пользователя и пароль, если это необходимо.
  6. Два раза нажмите кнопку Далее , нажмите кнопку Готовои нажмите кнопку Проверить источник данных.