Как восстановить поврежденные документы Word

Аннотация

В статье описываются способы выявления поврежденных документов в программе Word 2007 и ее более поздних версиях. Кроме того, в статье содержатся рекомендации по восстановлению текста и данных, содержащихся в выявленных поврежденных документах.

Данная статья рассчитана на начинающих пользователей компьютера и пользователей со средним уровнем подготовки.
Для удобства выполнения описанных действий рекомендуется начать с распечатки этой статьи.

Как определить поврежденный документ

Способ 1. Проверьте отсутствие неисправностей в документе

Многие поврежденные документы демонстрируют странное поведение. Такое поведение может быть вызвано повреждением документа или шаблона, на котором основан документ. Ниже перечислены некоторые типы такого поведения:
  • Многократное перенумерование существующих страниц документа
  • Многократное восстановление разрывов страниц в документе
  • Неправильная структура и форматирование документа.
  • Вывод на экран нечитаемых знаков.
  • Вывод сообщений об ошибках во время обработки.
  • Зависание компьютера при открытии файла.
  • Любое другое нестандартное поведение, которое не соответствует обычной работе программы.
При наличии каких-либо из этих симптомов или если документ невозможно открыть, перейдите к способу 2.

Способ 2. Проверьте другие документы и программы

В некоторых случаях повреждение документа не является причиной подобного поведения. Для устранения этих факторов выполните следующие действия.
  1. Убедитесь, что подобное поведение не наблюдается при работе с другими документами.
  2. Убедитесь, что подобное поведение не наблюдается при использовании других программ Microsoft Office.
Если при выполнении какого-либо из этих действий будет выявлено, что проблема заключается не в документе, необходимо устранить проблему с Word, набором Office или установленной на компьютере операционной системе.

Действия по устранению проблем, если поврежденный документ можно открыть

Способ 1. Замените используемый документом шаблон

Шаг 1. Определите используемый документом шаблон

  1. Откройте поврежденный документ в приложении Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Параметры.
  3. Выберите пункт Надстройки.
  4. В окне Управление щелкните Шаблоны в области Просмотр и управление надстройками Office
  5. Нажмите кнопку Перейти.
В окне Шаблон документа появится список шаблонов документа. Если отображенные шаблоны помечены как Нормальные, перейдите к шагу 2. В противном случае перейдите к шагу 3.

Шаг 2. Переименуйте общий шаблон (Normal.dotm)

Выполните описанные ниже действия в зависимости от установленной операционной системы.
  1. Закройте приложение Word.
  2. Нажмите кнопку Пуск  Кнопка «Пуск»  .
  3. Найдите в вашей операционной системе файл normal.dotm, обычно он располагается по адресу:
    %userprofile%\appdata\roaming\microsoft\templates
  4. Щелкните правой кнопкой файл Normal.dotm и выберите команду Переименовать.
  5. Введите имя Oldword.old и нажмите клавишу ВВОД.
  6. Закройте проводник.
  7. Запустите приложение Word и откройте документ.

Шаг 3. Измените шаблон документа

  1. Откройте поврежденный документ в приложении Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Параметры.
  3. Выберите пункт Надстройки.
  4. В списке Управление выберите пункт Шаблоны и нажмите кнопку Перейти.
  5. Нажмите кнопку Вложить.
  6. В папке Шаблоны выберите файл Normal.dotm, а затем нажмите кнопку Открыть.
  7. Нажмите кнопку OK, чтобы закрыть окно Шаблоны и надстройки.
  8. Закройте приложение Word.

Шаг 4. Проверьте изменение шаблонов.

  1. Запустите приложение Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Параметры.
  3. Щелкните поврежденный документ, затем выберите Открыть.
Если неисправность сохраняется, перейдите к способу 2.

Способ 2. Запустите программу Word с параметрами по умолчанию.

Для запуска Word с параметрами по умолчанию вы можете использовать параметр командной строки /a. При использовании параметра /a Word не загружает никакие надстройки. Кроме того, Word не использует имеющийся шаблон Normal.dotm. Перезапустите Word с помощью параметра /a.

Шаг 1. Запустите Word, используя параметр /a.

  1. Закройте приложение Word.
  2. В своей операционной системе найдите команду Выполнить. В диалоговом окне «Выполнить» введите команду winword.exe /a

Шаг 2. Откройте документ

  1. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  2. Щелкните поврежденный документ, затем выберите Открыть.
Если неисправность сохраняется, перейдите к способу 3.

Способ 3. Изменение драйверов принтера.

Шаг 1. Попробуйте заменить драйвер принтера

Шаг а. Откройте средство «Добавить принтер»
  1. Найдите в вашей операционной системе меню Устройства и принтеры.
  2. Нажмите кнопку Добавить принтер.
Шаг б. Добавление нового принтера
  1. В диалоговом окне Добавить принтер щелкните Добавить локальный принтер.
  2. Выберите Использовать существующий порт и нажмите кнопку Далее.
  3. В списке Изготовитель выберите Microsoft.
  4. Выберите Средство записи XPS-документов Microsoft и нажмите кнопку Далее.
  5. Выберите пункт Использовать уже установленный драйвер (рекомендуется) и нажмите кнопку Далее.
  6. Установите флажок Использовать в качестве принтера по умолчанию и нажмите кнопку Далее.
  7. Нажмите кнопку Завершить.

Шаг 2. Убедитесь, что изменение драйверов принтера привело к разрешению проблемы

  1. Запустите приложение Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.
Если странное поведение не было устранено, перейдите к шагу 3.

Шаг 3. Переустановите исходный драйвер принтера.

Windows Vista и Windows 7
  1. Найдите в вашей операционной системе меню Устройства и принтеры.
  2. Щелкните правой кнопкой мыши значок исходного принтера по умолчанию и выберите команду Удалить.
    Разрешение контроля учетных записей При запросе пароля администратора или подтверждения введите пароль или нажмите кнопку Продолжить.
  3. Если будет предложено удалить все файлы, связанные с принтером, нажмите кнопку Да.
  4. Щелкните Установка принтера и следуйте инструкциям Мастера установки принтера для переустановки драйвера принтера.

Шаг 4. Убедитесь, что изменение драйверов принтера привело к разрешению проблемы

  1. Запустите приложение Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.
Если неисправность сохраняется, перейдите к способу 4.

Способ 4. Попытка принудительного восстановления файла в Word.

Шаг 1. Восстановление документа

  1. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  2. В диалоговом окне Открытие документа выберите нужный документ Word.
  3. Щелкните стрелку рядом с кнопкой Открыть и выберите команду Открыть и восстановить.

Шаг 2. Убедитесь, что восстановление документа привело к разрешению проблемы

Убедитесь, что неисправность устранена. Если неисправность сохраняется, перезагрузите Windows и перейдите к способу 6.

Способ 5. Изменение формата документа с последующим преобразованием документа обратно в формат Word.

Шаг 1. Откройте документ

  1. Запустите приложение Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Шаг 2. Сохраните документ в другом формате

  1. В Word откройте меню Файл на ленте и выберите пункт Сохранить как.
  2. В Word выберите пункт Другие форматы.
  3. В списке Тип сохраняемого файла выберите Rich Text Format (*.rtf).
  4. Нажмите кнопку Сохранить.
  5. В Word откройте меню Файл на ленте и выберите пункт Закрыть.

Шаг 3. Откройте документ, затем сконвертируйте его обратно в формат Word

  1. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  2. Щелкните конвертированный документ, затем выберите Открыть.
  3. В Word откройте меню Файл на ленте и выберите пункт Сохранить как.
  4. Выберите Документ Word в поле Сохранить как.
  5. Переименуйте файл и нажмите кнопку Сохранить.

Шаг 4. Убедитесь, что конвертация формата файла решила проблему

Убедитесь, что странное поведение больше не возникает. Если проблема не устранена, попробуйте сохранить файл в другом формате. Повторите шаги 1 – 4, затем попробуйте сохранить файл в других форматах в следующем порядке:
  • в виде веб-страницы (HTM, HTML);
  • в любом другом формате обработки текста;
  • в формате обычного текста (TXT).
Примечание. При сохранении файлов в формате обычного текста (TXT) удается устранить поврежденные фрагменты в документах. Однако все форматирование документа, все рисунки и макросы при этом теряются. При сохранении файлов в формате обычного текста (TXT) необходимо повторно форматировать документ. Поэтому формат обычного текста (TXT) необходимо использовать только в том случае, если другие форматы не разрешают проблему.

Если неисправность сохраняется, перейдите к способу 7.

Способ 6. Скопируйте все содержимое, за исключением последнего знака абзаца, в новый документ.

Шаг 1. Создание нового документа

  1. В Word откройте меню Файл на ленте и выберите пункт Создать.
  2. Выберите Новый документ, а затем — Создать.

Шаг 2. Откройте поврежденный документ

  1. Запустите приложение Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Шаг 3. Скопируйте содержимое документа и вставьте его в новый документ

Примечание. Если документ содержит разрывы разделов, копируйте только текст между разрывами. Разрывы разделов не следует копировать, так как они могут повредить новый документ. При копировании и вставке между документами необходимо изменить вид документа на черновой режим, чтобы избежать переноса разрывов разделов. Для перехода в режим черновика на вкладке Вид щелкните Черновик в группе Представления документа.
  1. В поврежденном документе нажмите сочетание клавиш CTRL+END, затем нажмите сочетание клавиш CTRL+SHIFT+HOME.
  2. На вкладке Домашняя страница в группе Буфер обмена щелкните Копировать.
  3. В вкладке Вид в группе Окно щелкните Переключение окон.
  4. Щелкните новый документ, созданный в шаге 1.
  5. На вкладке Домашняя страница в группе Буфер обмена щелкните Вставить.
Если неисправность сохраняется, перейдите к способу 8.

Способ 7. Скопируйте неповрежденные части поврежденного документа в новый документ.

Шаг 1. Создание нового документа

  1. В Word откройте меню Файл на ленте и выберите пункт Создать.
  2. Выберите Новый документ, а затем — Создать.

Шаг 2. Откройте поврежденный документ

  1. Запустите приложение Word.
  2. В Word откройте меню Файл на ленте и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.

Шаг 3. Скопируйте неповрежденные части поврежденного документа, а затем вставьте их в новый документ

Примечание. Если документ содержит разрывы разделов, копируйте только текст между разрывами. Разрывы разделов не следует копировать, так как они могут повредить новый документ. При копировании и вставке между документами необходимо изменить вид документа на черновой режим, чтобы избежать переноса разрывов разделов. Для перехода в черновой режим на вкладке Вид щелкните Черновик в группе Представления документа.
  1. В поврежденном документе найдите и выделите неповрежденню часть содержания документа.
  2. На вкладке Домашняя страница в группе Буфер обмена щелкните Копировать.
  3. В вкладке Вид в группе Окно щелкните Переключение окон.
  4. Щелкните новый документ, созданный в шаге 1.
  5. На вкладке Домашняя страница в группе Буфер обмена щелкните Вставить.
  6. Повторите шаги 3a – 3e для всех неповрежденных частей документа. Необходимо воссоздать поврежденные части документа.

Способ 8. Переключите представление документа и удалите поврежденное содержимое

В обрезанных документах, в которых отображаются не все страницы, можно переключить представление и удалить поврежденное содержимое.
  1. Определите номер страницы с поврежденным содержимым, из-за которого документ обрезается.
    1. В Word откройте меню Файл на ленте и выберите пункт Открыть.
    2. Щелкните поврежденный документ, затем выберите Открыть.
    3. Прокрутите документ до той страницы, после которой он обрезается. Запомните содержимое этой страницы.
  2. Переключите представление документа и удалите поврежденное содержимое.
    1. На вкладке Вид в группе Представления документа выберите элемент Веб-документ или Черновик.
    2. Прокрутите документ и найдите содержимое, после которого он обрезается.
    3. Выделите и удалите следующий абзац, таблицу или объект.
    4. На вкладке Вид в группе Представления документа выберите элемент Режим разметки. Переключайте представления и удаляйте содержимое до тех пор, пока документ не отобразится в полном виде в представлении Режим разметки.
    5. Сохраните документ.

Действия при невозможности открытия поврежденного документа

Способ 1. Откройте поврежденный документ в черновом режиме без поврежденных ссылок.

Шаг 1. Настройка Word

  1. Запустите приложение Word.
  2. В вкладке Вид в группе Представления документа щелкните Черновик.
  3. В Word выберите меню Файл, а затем щелкните Настройки и Дополнительно.
  4. В разделе Отобразить содержимое документаотметьте пункты Использовать шрифт черновика в режимах отображения «Черновик» и «Разметка» и Показывать указатели изображений.
  5. В разделе «Общие» нажмите Автоматически обновлять ссылки при открытии, затем нажмите OK и закройте Word.

Шаг 2. Откройте поврежденный документ

  1. Запустите приложение Word.
  2. В Word откройте меню Файл и выберите пункт Открыть.
  3. Щелкните поврежденный документ, затем выберите Открыть.
Если документ открыть невозможно, закройте его, затем снова откройте с помощью способа 6 и восстановите документ. В противном случае перейдите к способу 2.

Способ 2. Вставьте документ как файл в новый документ.

Шаг 1. Создание нового документа

  1. В Word 2010 откройте меню Файл и выберите пункт Создать.
  2. Выберите Новый документ, а затем — Создать.
Примечание. Может потребоваться повторно применить форматирование к последнему разделу нового документа.

Шаг 2. Вставьте поврежденный документ в новый документ

  1. На вкладке Вставка нажмите кнопку Вставка объекта, а затем выберите Текст из файла.
  2. В диалоговом окне Вставка файла найдите и выберите поврежденный документ. Нажмите кнопку Вставить.
Примечание. Может потребоваться повторно применить форматирование к последнему разделу нового документа.

Способ 3. Создание ссылки на поврежденный документ

Шаг 1. Создание нового документа

  1. В Word откройте меню Файл и щелкните пункт Создать..
  2. Выберите Новый документ, а затем — Создать.
  3. В новом документе введите Это проверка.
  4. В Word откройте меню Файл и выберите пункт Сохранить.
  5. Введите Ссылка спасения, затем выберите Сохранить.

Шаг 2. Создание ссылки

  1. Выберите текст, введенный в шаге 1c.
  2. На вкладке Домашняя страница в группе Буфер обмена щелкните Копировать.
  3. В Word откройте меню Файл и щелкните пункт Создать..
  4. Выберите Новый документ, а затем — Создать.
  5. На вкладке Домашняя страница в группе Буфер обмена щелкните стрелку рядом с кнопкой Вставить, а затем выберите Специальная вставка.
  6. Щелкните Вставка связи, затем Форматированный текст (RTF).
  7. Нажмите кнопку ОК.

Шаг 3. Изменение ссылки на поврежденный документ

  1. Щелкните связанный текст правой кнопкой мыши, выберите команду Связанный объект документа, а затем — Связи.
  2. В диалоговом окне Связи выберите имя файла связываемого документа и нажмите кнопку Сменить источник.
  3. В диалоговом окне Смена источника выберите документ, который не удавалось открыть, и нажмите кнопку Открыть.
  4. Нажмите кнопку OK, чтобы закрыть окно Связи.

    Примечание. В новом документе должны появиться сведения из поврежденного документа (если в нем находились данные или текст, которые можно было восстановить).
  5. Щелкните связанный текст правой кнопкой мыши, выберите команду Связанный объект документа и выберите Связи.
  6. В диалоговом окне Связи нажмите кнопку Разорвать связь.
  7. Нажмите кнопку Да в следующем сообщении:
    «Разорвать указанные связи?»

Способ 4. Использовать конвертер «Восстановление текста из любого файла»

Примечание. Конвертер «Восстановление текста из любого файла» имеет ограничения. Например, он не сохраняет форматирование документа. Кроме того, теряются все нетекстовые данные (рисунки, поля, графические объекты и прочие элементы). Поэтому верхние и нижние колонтитулы, сноски и текст полей сохраняются в виде обычного текста.
  1. В Word откройте меню Файл и выберите пункт Открыть.
  2. В поле Тип файлов выберите значение Восстановление текста из любого файла (*.*).
  3. Выберите документ, текст которого необходимо восстановить.
  4. Нажмите кнопку Открыть.
После восстановления документа с помощью конвертера «Восстановление текста из любого файла» некоторые двоичные данные не преобразовались. В основном это текст начала и конца документа. Необходимо удалить эти двоичные данные перед сохранения файла в качестве документа Word.

Примечание. В пользовательском интерфейсе Word 2007 отсутствует кнопка Файл. Вместо нее используйте кнопку Office и затем выполняйте необходимые указания.
Свойства

Номер статьи: 918429 — последний просмотр: 22 февр. 2017 г. — редакция: 3

Microsoft Office Word 2007, русская версия, Microsoft Word 2010, Microsoft Word 2013, Word 2016

Отзывы и предложения