Сообщение об ошибке при запуске пользовательского отчета Crystal Reports в Microsoft Dynamics SL: «Ошибка модуля Crystal печать: 709 не удалось найти таблицу»


Симптомы


Рассмотрим следующий сценарий:
  • На компьютере Microsoft Dynamics SL 7.0 или Microsoft Dynamics SL 2011.
  • Использовать пользовательский отчет Crystal Reports.
  • Войдите в систему с помощью проверки подлинности Windows.
В этом случае появляется следующее сообщение об ошибке:
Вспомогательное приложение отчетов Crystal для Solomon IV
Получение отчетов произошла ошибка запроса SQL: Dynamics создаваемую C:\Program SL\Usr_Rpts\03730DET. RPT
Ошибка модуля Crystal печать: 709 - Ошибка в создаваемую Dynamics файл C:\Program SL\Usr_Rpts\03730DET. RPT:

Не удалось найти таблицу.

Причина


Причина 1

Эта ошибка возникает, если выполняются следующие условия:
  • Отчет Crystal Reports использует настраиваемые таблицы или представления.
  • E7F575915A2E4897A517779C0DD7CE Microsoft SQL Server пользователь или роль приложения MSDSL SQL Server не имеет необходимых разрешений для пользовательской таблицы или представление. В разделе Разрешение 1 в разделе «Решение».

Причина 2

Подключение к Open Database Connectivity (ODBC) настроено неправильно использовать проверку подлинности Windows вместо проверки подлинности SQL Server. При первом запуске отчета Crystal Reports на новую рабочую станцию, подключение ODBC создается для базы данных Microsoft Dynamics SL системы и базы данных приложения Microsoft Dynamics SL. Это подключение следует настроить для использования проверки подлинности SQL Server, даже при использовании проверки подлинности Windows для входа в Microsoft Dynamics SL. Решение 2 в разделе «Решение» см.

Решение


Решение 1

Назначьте соответствующие права для пользовательских таблиц или пользовательское представление. Чтобы сделать это, выполните следующие действия.
  1. Запустите Microsoft SQL Server Management Studio.
  2. Разверните узел базы данных, разверните базу данных Dynamics SL и разверните таблицы или представления.
  3. Найдите в списке пользовательские таблицы или представления.
  4. Щелкните правой кнопкой мыши пользовательские таблицы или представления. Затем выберите Свойства.
  5. В области выбрать страницу нажмите кнопку разрешения.
  6. Нажмите кнопку Добавить, введите MSDSLи нажмите кнопку ОК.
  7. , Выберите разрешениевыберите флажок гранта .
  8. Нажмите кнопку Добавить.
  9. Нажмите кнопку Обзор. Щелкните флажок рядом с пользователем, E7F575915A2E4897A517779C0DD7CE .
  10. Два раза нажмите кнопку ОК .
  11. Для управления разрешениямищелкните флажок Grant .

Решение 2

Для решения этой проблемы удалите подключения ODBC и позволить Microsoft Dynamics SL повторного создания соединения. Чтобы сделать это, выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт Параметрыи выберите пункт Панель управления.
  2. Щелкните значок Администрирование.
  3. Щелкните Источники данных (ODBC).
  4. Удалите все записи в базе данных Microsoft Dynamics SL системы и базы данных приложения Microsoft Dynamics SL на вкладке « Пользовательское DSN ».
  5. Удалите все записи в базе данных Microsoft Dynamics SL системы и базы данных приложения Microsoft Dynamics SL на вкладке Системный DSN .
  6. Снова войдите в Microsoft Dynamics SL и попытайтесь снова использовать в отчете. Элементы DSN пользователя должны создаваться повторно автоматически.