WD97: Удаление метаданных в документах Microsoft Word

ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.

Эта статья на английском языке: 223790
Эта статья помещена в архив. Она предлагается "как есть" и обновляться не будет.
Аннотация
Каждый раз при создании, открытии или сохранении документа в Microsoft Word 97, документ может содержать содержимое, которое не следует использовать совместно с другие при распространении документа в электронном виде. Эта информация известный как «метаданными». Метаданные используются для различных целей для улучшения редактирования, просмотра, хранения и извлечения документов Microsoft Office.

Некоторые метаданные, доступный через пользователя Microsoft Word интерфейс; другие метаданные только получить доступ гораздо сложнее, такие как открыть документ в редакторе низкого уровня двоичных файлов. Ниже приведены некоторые примеры метаданных, которые могут храниться в документах:
  • Ваше имя
  • Инициалы
  • Название компании или организации
  • Имя компьютера
  • Имя сетевого сервера или жесткого диска, где сохранен документ
  • Другие свойства и сводные сведения о файлах
  • Невидимые элементы внедренных объектов OLE
  • Имена Предыдущие авторы документа
  • Версий документа
  • Версии документа
  • Сведения о шаблоне
  • Скрытый текст
  • Комментарии
В данной статье описываются различные методы, которые можно использовать для свести к минимуму объем метаданных, содержащихся в документах Word.
Дополнительная информация
Метаданные создаются в различными способами в Word документы. Таким образом это не единственный метод, который можно использовать для устранения все такие содержимое документов. В следующих разделах описаны области где в документах Word могут храниться метаданные.

Как удалить имя пользователя из программы

Можно просмотреть или изменить имя пользователя. Чтобы сделать это, выполните следующие действия:
  1. В меню Сервис выберите команду Параметры . Перейдите на вкладку Сведения о пользователе .
    Вы должны увидеть следующие поля:
    Имя
    Инициалы
    Почтовый адрес
  2. Если вы не хотите, эта информация появится в Введите документы, содержащие идентификационной строки или пробелы в соответствующие изменения диалоговые окна и нажмите кнопку ОК , чтобы принять изменения.
Это будет содержать все новые документы, создаваемые сведения, а не значения по умолчанию, введенное при установке Office. Тем не менее существующие документы уже может содержать эту информацию.

Удаление кратких личных сведений

При создании или сохранении документа в Microsoft Word, сведения могут быть сохранены в документе. Существует несколько методов, которые можно использовать для доступ к этим сведениям:
  • Откройте документ. В меню файл выберите команду Свойства. Документ, Статистика, содержимоеи Прочие вкладки могут быть заданы различные свойства, такие как ваше имя, ваш Имя руководителя и название организации.
  • В проводнике Windows щелкните правой кнопкой мыши документ, и в контекстном меню выберите команду Свойства . Как выше, вкладки в диалоговом окне Свойства могут содержать информацию.
  • Можно использовать Visual Basic для приложений макроса или другой программный код для чтения свойств, отображаемых в диалоговом окне Свойства .
Можно удалить краткие личные сведения из существующего документа или шаблон. Чтобы сделать это, выполните следующие действия.
  1. Откройте документ или шаблон.
  2. В меню файл выберите команду Свойства.
  3. На вкладке Сводка снимите автора, Диспетчер, компаниии все другие поля, которые необходимо распространять.
  4. На вкладке настраиваемые удалите все свойства, содержащие сведения, которые не будут распространяться.
  5. Когда закончите, нажмите кнопку ОК. В меню файл нажмите кнопку Сохранить . В меню файл выберите команду Закрыть .
После выполнения этих действий документ не должен содержат сводные свойства.

Удаление кратких личных сведений, при подключении к сети

Если вы вошли в сеть, сетевое имя пользователя может При сохранении документа отображаются в поле автора на вкладке « Сводка » и в поле Автор на вкладке « Статистика ». Это может произойти даже при наличии все личные данные удаляются с вашего компьютера.

Чтобы удалить Сводные данные из документа при работе в сети, выполните следующие действия:
  1. Если документ хранится на сетевом сервере, скопируйте его в каталог локальный жесткий диск.
  2. Запустите компьютер, но не входите в систему к сети. Когда появится диалоговое окно входа сети, нажмите кнопку Отмена или нажмите клавишу ESCAPE.

    Примечание Если не удается запустить Windows, нажав клавишу ESCAPE (например, в компьютер работает под управлением Windows NT), не может продолжить выполнение процедуры.
  3. Откройте документ.
  4. В меню файл выберите команду Свойства.
  5. На вкладке « Сводка » снимите Автор, Руководитель, компаниии все остальные поля, содержащие данные, которые не будут распространяться.
  6. На вкладке Настройка удалите все свойства, содержащие сведения, можно сделать не будут распространяться.
  7. Когда закончите, нажмите кнопку ОК. В меню файл нажмите кнопку Сохранить . В меню файл выберите команду Закрыть .
При входе в сеть, не открывайте этот файл. В противном случае сетевое имя пользователя может быть записан в файл. Тем не менее можно использовать проводник Windows для копирования файла к любой сети сервер или на дискету.

Как удалить комментарии в документах

В Microsoft Word существует возможность добавления комментариев к документам. Обычно примечания содержат имя пользователя, создавшего их, таким образом, чтобы можно сказать, кто написал их.

Примечания обычно отображаются как выделенный текст; Щелкните правой кнопкой мыши в поле комментарий и нажмите кнопку Удалить комментарий.

Все новые комментарии, созданные не должны содержать имя пользователя, поскольку удалено из диалогового окна Параметры , как показано выше.

Удаление верхних и нижних колонтитулов из документов

Верхние и нижние колонтитулы в документах могут содержать определение информация. Чтобы удалить сведения из верхних и нижних колонтитулов, выполните следующие действия:
  1. В меню Вид выберите команду Колонтитулы .
  2. Верхний и нижний колонтитулы отображаются в верхней и нижней части каждой страницы в документе; Измените их, как требуется.
  3. Когда вы закончите, нажмите кнопку Закрыть на панели инструментов Колонтитулы .

Удаление записанных исправлений

Документы могут содержать записанные исправления, которые позволяют вам для узнать, кто внес изменения в документ. Если принять или отклонить записанные исправления, измененный текст сохраняется в документе, а также редакции пометки были удалены.

Отключение FastSave

Функция быстром ускоряет процесс сохранения документа Сохранение только изменения, внесенные в документ.

Из-за Дизайн функция быстром, текст, который необходимо удалить из документа может остаются в документе, даже после сохранения документа. Если имеются опасения о удаленного текста в документах выполните следующие действия.
  1. В меню Сервис выберите пункт Параметры.
  2. Выберите вкладку Сохранение .
  3. Снимите флажок "Быстрое сохранение". Нажмите кнопку ОК.
Примечание В Microsoft Word 97 SR-1 и более поздних версиях функция, быстром по умолчанию отключено.

Для дополнительной сведения, щелкните следующий номер статьи в Microsoft Knowledge Base:
71999WD97: Как отключить параметр «быстрое сохранение»
190733 WD97: Открытие документа в текстовом редакторе отображается удаленный текст
192480 WD97: Часто задаваемые вопросы о "Быстрое сохранение

Как найти и удалить текст отформатирован как скрытый

В документах Word имеется возможность форматирования текста как скрытые. Поскольку скрытый текст может содержать сведения, не следует распространять, вы Возможно, потребуется отобразить и удалите его. Чтобы удалить весь текст в документе, форматируется как скрытый, выполните следующие действия:
  1. В меню Сервис выберите пункт Параметры. Выберите вкладку Вид .
  2. Установите флажок скрытый текст и нажмите кнопку ОК.
  3. В меню Правка выберите команду Заменить.
  4. Чтобы развернуть диалоговое окно, нажмите кнопку Дополнительные .
  5. Выберите в текстовом поле рядом с кнопкой Найти.
  6. Нажмите кнопку Формат и выберите команду Шрифт. Установите флажок скрытый и нажмите кнопку ОК.
  7. Нажмите кнопку Заменить все.
Весь скрытый текст удаляется из документа. Чтобы отключить Отображение скрытого текста, выполните следующие действия:
  1. В меню Сервис выберите пункт Параметры. Выберите вкладку Вид .
  2. Снимите флажок скрытый текст . Нажмите кнопку ОК.

Удаление гиперссылок из документов

Документы могут содержать гиперссылки на другие документы или веб-страниц в интрасети или в Интернете. Гиперссылки обычно отображаются как синий подчеркнутый текстовые строки.

Можно вручную удалить одну гиперссылку из документ, щелкнув правой кнопкой мыши гиперссылку, выбрав команду Гиперссылка в контекстном меню и выберите команду Удалить гиперссылку.

Если вы хотите удалить все гиперссылки в документе для этого можно использовать Visual Basic для приложений макроса. Для получения дополнительных сведений щелкните следующие статьи номер статьи базы знаний Майкрософт:
156353XL97: Нет выбора меню для выбора всех гиперссылок

Удаление стилей из документов

Документы могут включать стили, содержащие метаданные. Вы можете удалить эти стили или переименовать их. Чтобы сделать это, выполните следующие действия.
  1. Откройте документ, содержащий стили.
  2. В меню Формат выберите команду стиль.
  3. Выберите стиль, который нужно удалить или переименовать. Щелкните Удалить , чтобы удалить стиль или Изменить его.

Удаление старых версий файлов из документов

Word включает в себя компонент версии файла, который позволяет сохранить несколько версий одного документа в одном файле. Может потребоваться Удалите старые версии документа обмениваться с другими пользователями.

Чтобы удалить один или несколько версий документа, выполните следующие действия.
  1. В меню файл выберите команду версии.
  2. Выберите версию документа, которую требуется удалить. Можно выбрать более одной версии, нажав клавишу CTRL при выделении версии.
  3. Нажмите кнопку Удалить.
  4. Завершив удаление старых версий документ, нажмите кнопку Сохранить в меню файл .

Удаление связей из кодов полей

Связанные изображения и другие объекты в документах Word могут содержать информацию о связи, например путь к связанному изображению или объекту. Вы можете Удалите информацию о связи из документа, изменив коды полей.

Чтобы отобразить коды полей, выполните следующие действия.
  1. В меню Сервис выберите пункт Параметры. Выберите вкладку Вид .
  2. Установите флажок коды полей . Нажмите кнопку ОК.
После коды полей отображаются, можно проверить для просмотра ли какая-либо из них содержат подробные сведения.

Чтобы удалить связь данные из связанного изображения или другого объекта, выполните следующие действия.
  1. Выберите связанный рисунок или объект. Или выделите код поля для изображения или объекта, если коды полей отображаются.
  2. Нажмите сочетание клавиш CTRL + SHIFT + F9.
Изображения или объекта теперь является несвязанным. Обратите внимание, что отмена связи изображения или объекта может вызвать быть недоступный для редактирования.

Удаление шаблона имя и расположение

Все документы, созданные в Word основаны на шаблоне. По по умолчанию, это файл шаблона Normal.dot, расположенные в папке «Шаблоны». Тем не менее можно создать документ, основанный на основе другого шаблона другое место. Путь и имя этого шаблона, хранятся в свойства документа.

Чтобы просмотреть имя шаблона и расположение, нажмите кнопку Свойства в меню файл и выберите вкладку Сводка .

Даже если вы не отправите шаблон с документ, документ сохраняет имя и расположение шаблона. Чтобы изменить имя и расположение шаблона не содержащими идентификационных значений, выполните следующие действия:
  1. В меню Сервис выберите команду Шаблоны и надстройки.
  2. Нажмите кнопку присоединить.
  3. Выберите шаблон, который имеет имя и расположение, не важные и уникальным. Например так как каждый компьютер с Microsoft Установлен Word имеется файл Normal.dot, может возникнуть необходимость выбрать Normal.dot.
  4. Нажмите кнопку Открыть. Нажмите кнопку ОК.
Примечание Шаблон может содержать макросы, элементы автотекста, настраиваемые стили и пользовательские панели инструментов. Изменение шаблонов может сделать некоторые из этих элементов недоступно в документ.

Удаление сведений о маршруте

Если отправить документ по электронной почте, используя маршрут рассылки сведения о маршрутизации могут быть присоединены к документу. Чтобы удалить эти сведения из документа необходимо сохранить документ в формате, который не содержит сведений о маршруте.

В Microsoft Word сохраните документ в RTF (формат RTF) или в формате HTML. Закройте документ, а затем Откройте новый файл. Так как сведений о маршруте теперь отсутствует, Теперь можно сохранить документ в формате Microsoft Word.

Вы можете также выполните следующие действия.
  1. Отключите быстром с помощью инструкциям, приведенным выше.
  2. В меню файл выберите пункт Отправитьи нажмите кнопку Другой адресат.
  3. Нажмите кнопку Очистить для удаления маршрута. Нажмите кнопку ОК.
  4. В меню файл выберите команду Сохранить.
Документ будет сохранен без любых сведений о маршруте.

Как удалить имена Предыдущие авторы

Microsoft Word хранит имена последних 10 человек, которые работали документ в документе. Это автоматическая функция, не может быть отключен.

Тем не менее, можно удалить имена последних 10 авторов из При сохранении документа в формате, который не содержит таких документов информация. Например, если при сохранении документа в любом формате RTF (Rich Text Формат) или в формате HTML, разработки информация будет потеряна. После этого можно закрыть и снова откройте RTF или HTML-документ и сохранить его в формате Microsoft Word.

Как удалить свое имя из кода Visual Basic

При записи макроса Visual Basic в Word, записанный макрос начинается с заголовка, подобное приведенному ниже:

   ' Macro1 Macro   ' Macro recorded 3/11/1999 by <User Name>				


Чтобы удалить свое имя из макросов, записанные, выполните следующие действия.
  1. Откройте документ, содержащий макросы.
  2. В меню Сервис укажите на пункт макроси выберите команду Редактор Visual Basic. Или нажмите клавиши ALT + F11.
  3. В окне проекта дважды щелкните модуль, содержит макросы.
  4. Удаление имени из записанного макроса.
По завершении удаления своего имени, нажмите клавишу ALT + Q, чтобы вернуться в программу. Нажмите кнопку Сохранить в меню файл .

Как удалить Visual Basic ссылки на другие файлы

В редакторе Visual Basic имеется возможность создать ссылку в другой файл. При открытии документа, содержащего ссылки на другие файлы, он может просматривать имена файлов, на которые имеются ссылки.

Чтобы удалить Эти ссылки, выполните следующие действия.
  1. Откройте документ, содержащий ссылки.
  2. В меню Сервис укажите на пункт макроси выберите команду Редактор Visual Basic. Или нажмите клавиши ALT + F11.
  3. В меню Сервис выберите команду ссылки.
  4. Снимите флажок рядом с указанного файла или файлов. Когда закончите, нажмите кнопку ОК.
  5. Нажмите клавиши ALT + Q.
  6. В меню файл выберите команду Сохранить.
Примечание Удаление ссылки на другие файлы может нарушить способность макросы в документе работать правильно.

Как удалить сведения о жестком диске или сети

При сохранении документа на локальном жестком диске или сети сервер может информацию, определяющую локальный жесткий диск или сетевой сервер записи в документ.

Можно удалить эту информацию из документ. Чтобы сделать это, выполните следующие действия.
  1. Откройте документ.
  2. В меню файл выберите команду Сохранить как. Сохраните документ для дисковода гибких дисков (как правило, A:).
  3. В меню файл выберите команду Закрыть.
  4. Выньте дискету из дисковода гибких дисков.
Теперь можно использовать проводник Windows для копирования документа дискета, на любой жесткий диск или сетевой сервер.

Примечание: из-за ограниченности места на дискете (обычно 1,44 МБ), Этот метод не может использоваться, если размер файла превышает объем свободного места на дискете.

Внедренные объекты в документы могут содержать метаданные

При создании внедренного объекта в документе, по-прежнему объекта сохраняет свои свойства, независимо от того, что сделать для документа. Для Например, если внедрить в документ Word, книгу Microsoft Excel документ и книга имеет собственные свойства.

Вы можете Удалите метаданные из внедренного объекта путем активации объекта, удалением Повторная активация контейнера документа метаданных как описано выше, (с помощью выше примере это будет документ Word) и затем сохранение контейнера документ.

Примечание При активации объекта, внедренного в документ, только часть внедренный объект отображается в документе; объект может содержать Дополнительные сведения, не отображается. Если требуется, чтобы документ содержал Вырезать только визуальные параметры внедренного объекта, а не фактическое содержимое объект и воспользуйтесь Специальная вставка элемента в меню Правка , вставить объект в документ, с помощью метафайл формат. После этого можно больше не изменить внедренный объект; Тем не менее, он не содержит все метаданные.

Как удалить уникальные идентификаторы из документов Office

Из-за разработки программы, включенные в Microsoft Документы, созданные или сохранен в программах Office 97 может Office 97 содержит уникальный идентификатор.
Дополнительные сведения об этих идентификаторов и как удалить их, щелкните следующий номер статьи в в Microsoft Knowledge Base:
222180OFF97: Как и почему уникальные идентификаторы, создаются в документах Office

Общие рекомендации, касающиеся безопасности

Ниже приведены некоторые общие предложения, которые можно использовать для увеличения уровень безопасности рабочей среды:
  • Всякий раз, когда вы не за компьютером, защитить его с защищенную паролем экранную заставку, пароль при включении питания или блокировки Windows NT функция.
  • Если на компьютере есть общие папки, убедитесь, что Применение паролей для их таким образом, чтобы доступ к ним только авторизованным пользователям. Усовершенствовании безопасности с помощью управления доступом на уровне пользователей, таким образом, вы можете управлять точно кто имеет доступ к общим ресурсам на компьютере.
  • При удалении файла немедленно очистите корзину. Возможно, потребуется настроить программу, которая полностью стирает или перезаписывает файлы когда они будут удалены.
  • При создании резервной копии данных, хранения резервной копии файлов безопасное расположение, такое как сейф, банковская ячейка или запирающийся шкаф. Храните одну копию в надежном расположении резервных копий в случае вашего Размещение основного непригодна для использования.
  • Важные документы должна быть защищена паролем, чтобы обеспечить что только авторизованные пользователи могут открывать их. Пароль должен храниться в безопасность отдельных месте. Обратите внимание, что если вы не помните пароль, Невозможно восстановить содержимое документа, защищенного паролем.
  • Не распространяйте документы в электронной форме. Вместо этого распечатывайте их. Не используйте идентификационные элементы как отдельные шрифты водяные знаки, логотипы или Специальная бумага, если необходимости (например, презентации).
  • Электронная почта не является анонимным. Не электронной почты документ, если вы беспокоятся о ваши личные каким-либо образом в документ.
  • Не пересылайте документы через Интернет с помощью Протокол HTTP или FTP. Информация, передаваемая через эти протоколы отправляется в "Очистить текст", что означает, что это технически возможно (Однако маловероятно) для того чтобы Допускается перехват.

Дополнительные сведения

Для Дополнительные сведения по темам, описанных в этой статье щелкните следующие номера статей в Microsoft База знаний:
195005WD97: Некоторые свойства документа заполняется автоматически
216866 WD97: Сводные данные в разделе свойства не шифруется
178121 WD97: Не выводится запрос пароля для «Изменить» в почтовом клиенте
194494 WD97: Защита паролем потеряны при сохранении в формате предыдущих версий
170940 WD97: Пароль не запрос с первого расширения sub-document
223396 OFF: Удаление метаданных в документах Microsoft Office
223789 XL: Удаление метаданных в книгах Microsoft Excel
223793 PPT97: Удаление метаданных в презентации Microsoft PowerPoint
PP97 OFF97 конфиденциальности конфиденциальность идентификации анонимность мета данных

Внимание! Эта статья переведена автоматически

Свойства

Номер статьи: 223790 — последний просмотр: 12/05/2015 13:38:05 — редакция: 8.0

Microsoft Word 97 Standard Edition

  • kbnosurvey kbarchive kbdownload kbhowto kbmt KB223790 KbMtru
Отзывы и предложения