Низкая производительность при закреплении представлений в Microsoft Dynamics CRM

Эта статья поможет устранить проблему, возникающую при закреплении представлений в Microsoft Dynamics CRM Client для Microsoft Office Outlook.

Область применения: Microsoft Dynamics CRM 2011 г.
Исходный номер базы знаний: 2741514

Симптомы

Microsoft Dynamics CRM клиент для Microsoft Office Outlook может работать медленно при закреплении представлений.

Причина

При закреплении представления записи в представлении извлекаются в локальную базу данных SQL CE в {orgid.sdf} и кэшируются. При закреплении представлений они отображаются пользователю в представлении списка , а не в представлениях с страницами. При каждом обращении к закрепленное представление возвращает результаты из локальных SDF-файлов.

Эти данные периодически обновляются в фоновом режиме. Если у пользователя есть несколько закрепленных представлений или на компьютерах, на которых не много ресурсов, это может привести к снижению производительности и проблем с загрузкой.

Решение

Чтобы предотвратить включение сведений в локальные кэши CE SQL, раздел реестра можно задать на клиентах Outlook Microsoft Dynamics CRM 2011. Это также может помочь уменьшить общий сетевой трафик, отправляемый с сервера Microsoft Dynamics CRM 2011 на клиентский компьютер Outlook Microsoft Dynamics CRM 2011.

Если для этого значения задано значение 1, пользователи по-прежнему могут закреплять представления; однако запрос отправляется на сервер CRM Для получения результатов, а не из локального кэша.

Важно!

В этот раздел, описание метода или задачи включены действия, содержащие указания по изменению параметров реестра. Однако неправильное изменение параметров реестра может привести к возникновению серьезных проблем. Поэтому следует в точности выполнять приведенные инструкции. Для дополнительной защиты создайте резервную копию реестра, прежде чем редактировать его. Так вы сможете восстановить реестр, если возникнет проблема. Для получения дополнительной информации о том, как создать резервную копию и восстановить реестр, см. статью Сведения о резервном копировании и восстановлении реестра Windows.

Чтобы решить данную проблему, выполните следующие действия.

  1. Войдите на клиентские компьютеры Outlook Microsoft Dynamics CRM 2011 в качестве пользователя, который установил клиент Outlook Microsoft Dynamics CRM 2011.
  2. Щелкните Пуск, затем Выполнить и введите regedit. Затем нажмите ОК. Перейдите к разделу HKEY_CURRENT_USER\Software\Microsoft\MSCRMClientреестра . В меню Правка наведите указатель мыши на пункт Создать, а затем выберите DWORD (32-разрядное) Значение.
  3. Введите DisableMapiCaching и нажмите клавишу ВВОД.
  4. Щелкните правой кнопкой мыши команду ОтключитьMapiCaching, наведите указатель на пункт Создать, а затем выберите значение DWORD.
  5. Щелкните правой кнопкой мыши отключитьMapiCaching и выберите команду Изменить.
  6. В поле Значение введите 1 и нажмите кнопку ОК.
  7. Закройте редактор реестра.

Дополнительная информация

Чтобы раздел реестра DisableMapiCaching работал, необходимо установить накопительный пакет обновления 6 или более поздней версии. Дополнительные сведения о накопительном пакете обновления 6 см. в статье Kb Microsoft Dynamics CRM 2011 Update Rollup 6.

Примечание.

Этот раздел реестра недопустим после применения накопительного пакета обновления 14. Его необходимо обновить с помощью средства OrgDbOrgSettings.

Средство OrgDBOrgSettings для Microsoft Dynamics CRM 2011 г.