Как использовать Блокнот XML для создания XML-документа

ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.

Эта статья на английском языке: 296560
Аннотация
Блокнот XML является приложением, которое позволяет легко и быстро создавать и изменять XML-документы. С помощью этого инструмента структуры XML-данных отображаются графически в виде древовидной структуры. Интерфейс предоставляет две панели: один для структуры и один для значения. Можно добавить элементы, атрибуты, комментарии и текста в XML-документ, создание структуры дерева на левой панели и ввод значений в соответствующих текстовых полях правой панели.
Дополнительная информация
Чтобы создать редактор XML Notepad корректный XML-документ, выполните следующие действия.
  1. Чтобы открыть редактор XML Notepad, нажмите Пуск, выберите пункт Программы, выберите пункт Блокнот Microsoft XML, а затем нажмите кнопку Блокнот Microsoft XML. Интерфейс отображается две области. «Структура» на начало структуру дерева XML с уже создан andChild_Element Root_Element leftpresents. Пустые текстовые поля в области acceptcorresponding значения.
  2. Изменение каталога и Child_Element книгу Root_Element и добавьте атрибут и трех дочерних элементов дочернего элемента книги.ПРИМЕЧАНИЕ: При вставке следующие значения этого не includeapostrophes. Редактор XML Notepad вставляет их вам нужно для XML-документа.

    1. Чтобы вставить атрибут для книги, щелкните правой кнопкой мыши Книги, выберите пункт Вставкаи нажмите кнопку Атрибут. Рядом со значком куба введите ИДЕНТИФИКАТОР. Чтобы вставить значения для данного атрибута, выделите ИДЕНТИФИКАТОР и тип Bk101 в соответствующем текстовом поле в области значения.
    2. Чтобы добавить дочерний элемент для книги, щелкните правой кнопкой мыши значок папки рядом с книгой, выберите команду Вставкаи нажмите кнопку Дочерний элемент. Появится значок листа. Тип Автор Далее, чтобы этот значок, а затем введите Gambardella, Мэтью в соответствующем текстовом поле в области значения.
    3. Добавьте несколько дочерних элементов: Название и Жанр. Тип Руководство для разработчиков XML и Компьютер в соответствующие текстовые поля в области значений.
  3. Чтобы добавить другой книги дочерний элемент корневого узла, щелкните правой клавишей существующий элемент книги и нажмите кнопку Дублирование. Заполните значения при необходимости.
  4. Чтобы добавить существующие элементы текста, выделите узел forwhich, вы бы хотели добавить текстовый узел. На Вставка меню, нажмите кнопку Текст.
  5. Чтобы добавить комментарии в существующих элементов, выделите nodeafter какие или в который требуется вставить комментарий. На Вставка меню, нажмите кнопку Комментарий. Если выделенный узел развернут, комментарий является выделенный узел insertedwithin. Если выделенный узел свернут, commentis вставляется после выделенного узла.
  6. Чтобы изменить тип узла, выделите узел, wantto можно изменить. На Tools Выберите пункт Изменить на и выберите нужный тип.

    ПРИМЕЧАНИЕ: Невозможно изменить тип корневого узла или узлов withchildren.
  7. Для просмотра исходного текста документа XML Просмотр меню, нажмите кнопку Source. Пример выходных данных будет выглядеть примерно так:
    <catalog>   <book id="bk101">      <author>Gambardella, Matthew</author>      <title>XML Developer's Guide</title>      <genre>Computer</genre>      text1   </book>   <!--Comment1-->   <book id="bk102">      <!--Comment2-->      <author>Ralls, Kim</author>      <title>Midnight Rain</title>      <genre>Fantasy</genre>   </book></catalog>					
    Обратите внимание на следующее сообщение в нижней части окна:
    The current XML definition is well formed.					
    Обратите внимание, что instructionsmust объявление или обработки XML дополняется внешний редактор, например Блокнот.

  8. Сохранение XML-документа на Файл меню, нажмите кнопку Сохранить. Чтобы закрыть редактор XML Notepad на Файл меню, нажмите кнопку Выход.
Ссылки
Дополнительные сведения см. ниже веб-узлов:
Центр разработчика XML сети Microsoft
http://MSDN.Microsoft.com/XML

Консорциум W3c
http://www.w3.org

Внимание! Эта статья переведена автоматически

Свойства

Номер статьи: 296560 — последний просмотр: 07/03/2016 19:13:00 — редакция: 6.0

  • kbhowto kbmt KB296560 KbMtru
Отзывы и предложения