ИСПРАВИТЬ: Enterprise Single Sign-On вызывает событие 10536 и код ошибки 0x80090005

ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.

Эта статья на английском языке: 3000847

Обновленные рекомендации

После применить исправление, описанное в разделе «Решение», службы корпоративного единого входа (ENTSSO) происходит утечка памяти. Таким образом мы рекомендуем устанавливатьболее поздние исправления Вместо этого.
Проблема
Рассмотрим следующий сценарий:
  • Был установлен компонент версии 5 корпоративного единого входа (SSO), includedin Microsoft BizTalk Server 2013 R2 или узла Integration Server 2013.
  • В одном из следующих сценариев восстановления главного ключа из файла резервной копии:
    • При установке кластера SSO в сети предприятия
    • Во время корпоративного единого входа аварийного восстановления
    • Когда повышение роли сервер корпоративного единого входа для сервера главный секрет (MSS)
    • Во время миграции с более ранней версии SSO в сети предприятия
    • Во время обновления на месте с более ранней версии SSO в сети предприятия
    • При выполнении нескольких V5 единого входа предприятия восстановления и резервного копирования последовательности
После восстановления главного ключа в любой из этих сценариев, SSO в сети предприятия не удается расшифровать данные, содержащиеся в базе данных SSO в сети предприятия. В этой ситуации SSO в сети предприятия регистрирует следующие события в журнале приложений:
Код события: 10536
Источник: ENTSSO
Уровень: предупреждение
АУДИТА функция единого входа: Идентификатор трассировки GetConfigInfo ({11111111-6055-4cda-89CD-389E8A2B1640}): b084f15b-43fd-474e-a075-398943753c91 клиентский компьютер: имя компьютера (имя: PID исполняемый) пользователь клиента: имя пользователя имя приложения: имя приложения код ошибки: 0x80090005, неверные данные.

Кроме того может быть зарегистрировано следующее всплывающее сообщение об ошибке, при открытии оснастки MMC администрирования BizTalk Server:
Администрирования BizTalk Server
Неверные данные.
(WinMgmt)
Кнопки:
OK
Причина
V5 единого входа предприятия добавляет метку времени главный секретный ключ для ограничения продолжительности использования ключа. Кроме того проверка была добавлена для определения, содержит ли главный секретный ключ штамп времени. Служба единого входа предприятия неправильно определяет, что отсутствует отметка времени при восстановлении главного ключа возникает проблема, описанная в разделе «Проблема». Так как восстановленный главный секретный ключ был добавлен штамп времени, восстановленный ключ не соответствует ключ, используемый для шифрования данных в базе данных единого входа предприятия. Поэтому не удается расшифровать данные, и это вызывает сообщения об ошибках, описанные выше.
Решение

Сведения об исправлении

Существует исправление от корпорации Майкрософт. Однако данное исправление предназначено для устранения только проблемы, описанной в этой статье. Это исправление ко всем системам V5 единого входа предприятия для предотвращения этой проблемы, а также для всех систем, которые уже испытывают проблемы. Для установки исправления требуется не дополнительных действий для предотвращения и устранения проблемы.

Если исправление доступно для загрузки, имеется раздел «Исправление загрузки доступно» в верхней части этой статьи базы знаний. Если этого раздела нет, отправьте запрос в службу технической поддержки для получения исправления.

Примечание Если наблюдаются другие проблемы или необходимо устранить неполадки, вам может понадобиться создать отдельный запрос на обслуживание. Обычные затраты на поддержку будет применяться к дополнительные вопросы и проблемы, которые не соответствуют требованиям конкретного исправления. Для получения полного списка телефонов поддержки и обслуживания клиентов корпорации Майкрософт, или для создания отдельного запроса на обслуживание, посетите следующий веб-сайт Майкрософт:

http://support.microsoft.com/contactus/?ws=support

Примечание В форме «Доступна загрузка исправления» отображаются языки, для которых доступно исправление. Если нужный язык не отображается, это потому, что исправление для данного языка отсутствует.

Предварительные условия

Для установки этого исправления необходимо иметь корпоративного единого входа V5 (9.0.2096) установлен.

Сведения о перезагрузке компьютера

Может потребоваться перезагрузить компьютер после установки данного исправления.

Сведения о файлах

Английская версия данного исправления содержит атрибуты файла (или более поздние атрибуты файлов), приведенные в следующей таблице. Дата и время для этих файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, откройте вкладку часовой пояс элемента Дата и время панели управления.

32-разрядный (x 86) версии
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Infocache.dll9.0.2187.0130,53601 октября 2014 г.22:00x86
Microsoft.enterprisesinglesignon.systemmmc.dll9.0.2187.0198,63201 октября 2014 г.22:00x86
Ssoss.dll9.0.2187.0113,12801 октября 2014 г.22:00x86
64-разрядный (x 64) версии
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Infocache.dll9.0.2187.0130,53601 октября 2014 г.22:00x86
Microsoft.enterprisesinglesignon.systemmmc.dll9.0.2187.0198,63201 октября 2014 г.22:00x86
Ssoss.dll9.0.2187.0113,12801 октября 2014 г.22:00x86
Infocache.dll9.0.2187.0151,52801 октября 2014 г.22:00x64
Microsoft.enterprisesinglesignon.systemmmc.dll9.0.2187.0198,63201 октября 2014 г.22:00x86
Ssoss.dll9.0.2187.0124,39201 октября 2014 г.22:00x64

Примечание
из-за зависимостей между файлами, последние исправления, содержит эти файлы могут содержать дополнительные файлы.
Статус
Корпорация Майкрософт подтверждает, что это проблема продуктов Майкрософт, перечисленных в разделе "Относится к".
Дополнительная информация
Это обновление можно применить для любого сервера предприятия единого входа, не требуя дополнительных изменений возникли неполадки. Кроме того это обновление следует применять ко всем системам корпоративного единого входа V5 для предотвращения проблемы при выполнении операции восстановления главной секретного ключа.

Внимание! Эта статья переведена автоматически

Свойства

Номер статьи: 3000847 — последний просмотр: 02/18/2016 21:28:00 — редакция: 3.0

Microsoft Host Integration Server 2013, Microsoft BizTalk Server 2013 R2 Branch, Microsoft BizTalk Server 2013 R2 Developer, Microsoft BizTalk Server 2013 R2 Enterprise, Microsoft BizTalk Server 2013 R2 Standard

  • kbautohotfix kbqfe kbhotfixserver kbfix kbmt KB3000847 KbMtru
Отзывы и предложения