В настоящее время вы работаете в автономном режиме; ожидается повторное подключение к Интернету

Как создать перекрестный запрос в Microsoft Access 2002

Данная статья была ранее опубликована под номером RU304349
Материал, изложенный в данной статье, требует навыков работы с графическим интерфейсом пользователя в однопользовательской среде.

Данная статья применима только к базам данных Microsoft Access (.mdb).

За соответствующей информацией по Microsoft Access 2000 обращайтесь к статье 304348.

Содержание

Аннотация
Используя перекрестные запросы, Вы можете создавать отчеты на основе Ваших данных для упрощения их анализа. В данной статье описывается, как создать перекрестный запрос, используя Мастер создания перекрестных запросов и без его использования.

Предупреждение: Выполнение действий, описанных в данном примере, приведет к изменению учебной базы данных Борей.mdb. Следует создать копию данной базы данных и выполнять описанные действия, используя копию.

К началу статьи

Создание перекрестного запроса, используя Мастер создания перекрестных запросов

  1. Запустите Microsoft Access.
  2. В меню "Справка" откройте подменю "Примеры баз данных" и выберите пункт "Учебная база данных "Борей". Нажмите кнопку "ОК" в открывшемся окне заставки и закройте Главную кнопочную форму при её появлении.
  3. В меню "Вставка" выберите пункт "Запрос".
  4. В диалоговом окне "Новый запрос" выберите "Мастер создания перекрестных запросов" и нажмите кнопку "ОК".
  5. На первой странице Мастера создания перекрестных запросов в списке таблиц выберите таблицу "Заказы" и нажмите кнопку "Далее".
  6. Из списка "Доступные поля" двойным щелчком мыши выберите поле "КодСотрудника" для добавления его в список "Выбранные поля" и нажмите кнопку "Далее". Данное действие добавит в запрос столбцы для каждого года, в котором содержатся даты заказов.
  7. В списке полей выберите поле "ДатаРазмещения" и нажмите кнопку "Далее".
  8. В качестве периода времени выберите "Год" и нажмите кнопку "Далее". Данное действие создаст запрос для дат заказов, содержащий по одной колонке для каждого года.
  9. В списке полей выберите поле "КодЗаказа", затем в списке "Функции", выберите "Счетчик" и нажмите кнопку "Далее".
  10. На последней странице мастера нажмите кнопку "Готово".Обратите внимание, что создан запрос, показывающий количество заказов сотрудников по годам.
К началу статьи

Создание перекрестного запроса без использования Мастера создания перекрестных запросов

  1. Запустите Microsoft Access.
  2. В меню "Справка" откройте в подменю "Примеры баз данных" и выберите пункт "Учебная база данных "Борей". Нажмите кнопку "ОК" в открывшемся окне заставки и закройте Главную кнопочную форму при её появлении.
  3. В меню "Вид" откройте подменю "Объекты базы данных" и выберите команду "Запросы".
  4. В меню "Вставка" выберите команду "Запрос".
  5. В диалоговом окне "Новый запрос" выберите "Конструктор" и нажмите кнопку "ОК".
  6. В диалоговом окне "Добавление таблицы" выберите таблицу "Заказы" и нажмите кнопку "Добавить", затем нажмите кнопку "ОК".
  7. В списке полей из таблицы "Заказы" в верхней половине сетки конструктора запроса дважды щелкните на следующих полях для добавления их в сетку конструктора запроса: "СтранаПолучателя", "ГородПолучателя", "ИндексПолучателя", "Доставка".
  8. В меню "Запрос" выберите команду "Перекрестный". Обратите внимание, что в сетку запроса при этом добавится строка с именем "Перекрестная таблица".
  9. Выберите ячейку в строке "Перекрестная таблица" в колонке "СтранаПолучателя" и щелкните по появившейся стрелочке, затем выберите параметр "Заголовки строк".
  10. Выберите ячейку в строке "Перекрестная таблица" в колонке "ГородПолучателя" и щелкните по появившейся стрелочке, затем выберите параметр "Заголовки строк".
  11. Выберите ячейку в строке "Перекрестная таблица" в колонке "ИндексПолучателя" и щелкните по появившейся стрелочке, затем выберите параметр "Заголовки столбцов".
  12. Выберите ячейку в строке "Перекрестная таблица" в колонке "Доставка" и щелкните по появившейся стрелочке, затем выберите параметр "Значение".
  13. В строке "Групповые операции" выберите ячейку в колонке "Доставка" и щелкните по появившейся стрелочке, затем выберите команду "Sum".
  14. В меню "Запрос" выберите команду "Запуск" для просмотра результатов перекрестного запроса.
К началу статьи


Ссылки
Для получения дополнительной информации о создании запросов выберите пункт "Справка по Microsoft Access" в меню "Справка" и введите строку "создать перекрестный запрос" (без кавычек) в поле Мастера ответов и нажмите кнопку "Найти" для просмотра статей.

Для получения дополнительной информации по созданию перекрестных запросов с несколькими полями значений обратитесь к следующей статье Microsoft Knowledge Base:
304458 ACC2002: Creating a Crosstab Query with Multiple Value Fields
Для получения дополнительной информации по созданию запросов обратитесь к следующей статье Microsoft Knowledge Base:
304325 ACC2002: How to Create a Select Query in Microsoft Access
Для получения дополнительной информации по созданию запроса с параметрами обратитесь к следующей статье Microsoft Knowledge Base:
304352 ACC2002: How to Create a Parameter Query in Microsoft Access
Для получения дополнительной информации по конвертированию запроса в запрос на изменение обратитесь к следующей статье Microsoft Knowledge Base:
304354 ACC2002: How to Convert a Select Query to an Action Query
Для получения дополнительной информации по изменению свойств запроса обратитесь к следующей статье Microsoft Knowledge Base:
304356 ACC2002: How to Modify Query Properties in Microsoft Access


К началу статьи







OfficeKBHowTo inf
Свойства

Номер статьи: 304349 — последний просмотр: 11/11/2003 14:20:00 — редакция: 1.0

  • Microsoft Access 2002 Standard Edition
  • kbhowto kbhowtomaster kbdta KB304349
Отзывы и предложения