В настоящее время вы работаете в автономном режиме; ожидается повторное подключение к Интернету

Добавление полей подстановки в таблицу Microsoft Access

Поддержка Office 2003 завершена

8 апреля 2014 г. корпорация Майкрософт прекратила поддержку Office 2003. Это повлияло на обновления программного обеспечения и параметры безопасности. Узнайте, что это значит для вас и какие меры по безопасности можно предпринять.

Малоопытным пользователям. Материал, изложенный в этой статье, требует знания пользовательского интерфейса на компьютерах с одним пользователем.

Версия данной статьи для Microsoft Access 2000: 304463 (Эта ссылка может указывать на содержимое полностью или частично на английском языке).
Версия данной статьи для Microsoft Access 97: 304464 (Эта ссылка может указывать на содержимое полностью или частично на английском языке).
Аннотация
В Microsoft Access существует возможность добавить в таблицу поле, позволяющее искать данные в другой таблице. Обычно этот метод используется для создания связей между таблицами. Например, в таблице "Товары" есть поле "Категория", название категории для которого выбирается из таблицы "Категории". При использовании данного метода значение основного ключа можно хранить только в таблице "Категории" и показывать при этом более наглядное название категории.

В статье объясняется, как добавить в таблицу Microsoft Access поле подстановки. Сначала показывается, как можно сделать это с помощью мастера, а затем описан процесс добавления поля подстановки вручную.
Дополнительная информация

Использование мастера для создания поля подстановки

  1. Запустите Access.
  2. В меню Справка последовательно выберите пункты Примеры баз данных и Учебная база данных "Борей". Когда появится главная кнопочная форма, закройте ее.

    Примечание В Access 2007 выберите пункт Образец на панели Категории шаблонов, затем выберите пункты Борей 2007 и Загрузить.
  3. В меню Вид последовательно выберите пункты Объекты базы данных и Таблицы.

    Примечание В Access 2007 нажмите кнопку Конструктор таблиц в группе Таблицы на вкладке Создание.
  4. Чтобы создать таблицу, дважды щелкните пункт Создать таблицу в режиме конструктора.

    Примечание В Access 2007 пропустите это действие.
  5. Введите ПоискСотрудников в первую строку столбца Имя поля.
  6. В столбце Тип данных выберите пункт Мастер подстановок.
  7. На первой странице мастера подстановок установите флажок Объект "столбец подстановки" будет использовать значения из таблицы или запроса и нажмите кнопку Далее.
  8. Выберите из списка таблиц таблицу Сотрудники и нажмите кнопку Далее.
  9. Дважды щелкните поля КодСотрудника, Фамилия и Имя, чтобы добавить их в список выбранных полей, после чего два раза нажмите кнопку Далее.
  10. Убедитесь, что установлен флажок Скрыть ключевой столбец, и нажмите кнопку Далее.
  11. На последней странице мастера подстановок нажмите кнопку Готово.
  12. Подтвердите сохранение таблицы, нажав кнопку Да, после чего введите название "ПроверкаМастераПодстановок".
  13. Чтобы добавить в таблицу основной ключ, нажмите кнопку Да при появлении соответствующего запроса.

    Обратите внимание, что мастер создаст связь между новой таблицей и таблицей "Сотрудники" учебной базы данных "Борей".
  14. В меню Вид выберите команду Режим таблицы.

    Примечание В Access 2007 откройте таблицу в режиме таблицы.
  15. Щелкните стрелку раскрывающегося списка в поле ПоискСотрудников.

    Обратите внимание, что в поле со списком появилось два столбца.

Создание поля подстановки вручную

  1. Запустите Access.
  2. В меню Справка последовательно выберите пункты Примеры баз данных и Учебная база данных "Борей". Когда появится главная кнопочная форма, закройте ее.

    Примечание В Access 2007 выберите пункт Образец на панели Категории шаблонов, затем выберите пункты Борей 2007 и Загрузить.
  3. В меню Вид последовательно выберите пункты Объекты базы данных и Таблицы.

    Примечание В Access 2007 нажмите кнопку Конструктор таблиц в группе Таблицы на вкладке Создание.
  4. Чтобы создать таблицу, дважды щелкните пункт Создать таблицу в режиме конструктора.

    Примечание В Access 2007 пропустите это действие.
  5. Введите ПоискСотрудников в первую строку столбца Имя поля.
  6. В столбце Тип данных выберите пункт Числовой.
  7. В окне Свойства поля перейдите на вкладку Подстановка.
  8. В списке Тип элемента управления выберите пункт Поле со списком.
  9. В поле свойств ИсточникСтрок, щелкните появившуюся стрелку, выберите в списке пункт Сотрудники, а затем нажмите кнопку Построить, чтобы открыть построитель запросов.
  10. Дважды щелкните поля КодСотрудника, Фамилия и Имя, чтобы добавить их в сетку запроса.
  11. Чтобы выйти из построителя запросов, на вкладке Конструктор нажмите кнопку Закрыть в группе Закрыть.
  12. При появлении запроса на сохранение изменений в инструкции SQL нажмите кнопку Да.
  13. Убедитесь, что для свойства ПрисоединенныйCтолбец установлено значение 1.

    Примечание Это свойство соответствует полю источника строк, сохраненному в поле. В данном примере в поле ПоискСотрудников хранится значение КодСотрудника таблицы Сотрудники.
  14. Установите значение параметра Число столбцов равным 3.

    Примечание Данное значение соответствует числу полей, выбранных в источнике строк.
  15. Введите значение 0см;1см;1см в поле ШиринаСтолбцов.

    Примечание Свойство ШиринаСтолбцов содержит значения ширины каждого из столбцов источника строк, разделенные точкой с запятой. Чтобы скрыть столбец, установите его ширину равной 0 см.
  16. Введите значение 2см в поле Ширина списка.
  17. В меню Вид выберите команду Режим таблицы.

    Примечание В Access 2007 откройте таблицу в режиме таблицы.
  18. Подтвердите сохранение таблицы, нажав кнопку Да, после чего введите название "ПроверкаМастераПодстановок2".
  19. Чтобы добавить в таблицу основной ключ, нажмите кнопку Да при появлении соответствующего запроса.
  20. Щелкните стрелку раскрывающегося списка в поле ПоискСотрудников.

    Обратите внимание, что в поле со списком появилось два столбца.
OfficeKBHowTo inf Acc2002 Acc2003 ACC2007
Свойства

Номер статьи: 304462 — последний просмотр: 02/21/2008 17:20:22 — редакция: 5.1

Microsoft Office Access 2007, Microsoft Office Access 2003, Microsoft Access 2002 Standard Edition

  • kbinfo kbexpertisebeginner kbdesign kbdatabase kbhowto KB304462
Отзывы и предложения