В настоящее время вы работаете в автономном режиме; ожидается повторное подключение к Интернету

Как записать двоичный файл в обозреватель используя ASP.NET и Microsoft Visual C# .NET

Данная статья была ранее опубликована под номером RU306654

Данная статья содержит информацию о бета-версии программного продукта Microsoft. Информация в данной статье не является официальной и может быть изменена без предварительного уведомления.

Бета-версия продукта не обслуживается через каналы технической поддержки Microsoft. За информацией о получении технической поддержки бета-версии программного обеспечения обратитесь к документации, содержащейся в поставке, или на веб-сайте, с которого был загружен продукт.

За соответствующей информацией по Microsoft Visual Basic .NET обратитесь к статье 307603.
Аннотация
Данная статья описывает шаги создания страницы-примера, демонстрирующей загрузку двоичных данных из файла и запись этих данных в обозреватель при помощи ASP.NET и Visual C#. Хотя этот пример использует файл Adobe Acrobat (.pdf) (который часто используют разработчики Web) вы можете применить эту процедуру к другим бвоичным файлам.

К началу статьи

Требования

  • Microsoft .NET Framework
  • Microsoft Windows 2000 или Windows XP
  • Microsoft Internet Information Server (IIS)
К началу статьи

Создание веб-приложения ASP.NET при помощи Visual C#

В данном разделе приводится пример создания нового веб-приложения ASP.NET с именем BinaryDemo:
  1. Запустите Microsoft Visual Studio .NET
  2. В меню "File" выберите пункт "New" и запустите команду "Project".
  3. В списке "Project Types" выберите "Visual C# Projects". В списке "Templates" выберите "ASP.NET Web Application".
  4. В поле "Name" введите строку "BinaryDemo"(без кавычек). В поле "Location" введите имя сервера. Если вы используете локальный сервер, то следует оставить значение по умолчанию http://localhost.
К началу статьи

Добавление файла PDF в проект

Для настройки вашего проекта для запуска кода, приведенного в разделеСоздание страницы ASPX,вам необходимо сначала добавить файл Adobe Acrobat (.pdf) в ваш текущий проект. Чтобы сделать это в Visual Studio .NET, выполните следующие действия:
  1. В окне "Solution Explorer" правой кнопкой мыши щелкните по узлу проекта и выберите пункт "Add" и затем "Add Existing Item".
  2. Укажите местоположение вашего .pdf файла в системе.
  3. Выделите файл и нажмите кнопку "Open".
  4. В Visual Studio .NET Solution Explorer щелкните правой кнопкой мыши по файлу и выберите "Rename". Переименуйте файл .pdf в файл с именем Acrobat.pdf, который используется нижеследующем примере кода.
Убедитесь, что приложение "Adobe Acrobat Reader" установлено на компьютере клиента, с которого просматривается страница .aspx, чтобы обозреватель мог читать и интерпретировать двоичные данные. Вы можете загрузить "Adobe Acrobat Reader" со следующего веб-сервера компании Adobe:К началу статьи

Создание страницы ASPX

  1. Добавьте новую страницу .aspx с именем BinaryData.aspx в текущий проект, выполнив следующие шаги:
    1. В окне "Solution Explorer" правой кнопкой мыши щелкните на узле проекта и выберите пункт "Add" и затем выберите пункт "Add Web Form".
    2. Задайте странице имя BinaryData.aspx и нажмите кнопку "Open".

      Примечание: Убедитесь, что ваша страница добавлена в проект на одном уровне с файлом .pdf, который был добавлен в предыдущем разделе. Это очень важно, так как в коде используются связанные пути для начальной установки ссылок на .pdf файл.
  2. В редакторе правой кнопкой мыши щелкните на файле "BinaryData.aspx" и выберите пункт меню "View Code".
  3. Выделите следующий код и скопируйте его в буфер обмена. В окне события "Page_Load" вставьте скопированный фрагмент кода:
    private void Page_Load(object sender, System.EventArgs e){             // Установить подходящий тип содержимого.    Response.ContentType = "Application/pdf";             // Получить физический путь к файлу.    string FilePath = MapPath("acrobat.pdf");             // Запись файла напрямую в поток HTTP.    Response.WriteFile(FilePath);            Response.End(); }
  4. В меню "File" выберите команду "Save All".
  5. В меню "Build" выберите команду "Build".
  6. Чтобы запустить код на исполнение, в окне "Solution Explorer" правой кнопкой мыши щелкните на файле "BinaryData.aspx" и выберите пункт меню "View In Browser". На появившийся запрос выберите команду "Open", чтобы открыть и выполнить файл в обозревателе.
Примечание: Если вы хотите использовать приведенный код для поддержки других двоичных типов файлов, вы должны изменить значение строки "ContentType" таким образом, чтобы определить соответствующий тип файла. Синтакс этой строки обычно имеет формат "type/subtype," где "type" это основное качество содержимого, а "subtype" - это конкретный тип данных. За полным списком поддерживаемых типов следует обращаться к документации по Вашему веб-обозревателю или текущей спецификации HTTP. В следующем списке показаны некоторые значения строки "ContentType":
  • "text/HTML"
  • "image/GIF"
  • "image/JPEG"
  • "text/plain"
  • "Application/msword" (для файлов Microsoft Word)
  • "Application/x-msexcel" (для файлов Microsoft Excel)
К началу статьи

Ссылки

За дополнительной информацией следует обращаться к следующим разделам в документации по .NET Framework Software Development Kit (SDK):За дополнительной информацией о том, как выполнить описанную задачу, используя Microsoft Active Server Pages (ASP), обратитесь к следующей статье в Microsoft Knowledge Base:
276488 HOWTO: Use the ADODB.Stream Object to Send Binary Files to the Browser through ASP
Контактная информация о независимых производителях предоставлена в данной статье с целью помочь пользователям в получении необходимой технической поддержки. Данная информация может быть изменена без предварительного уведомления. Корпорация Microsoft не дает никаких явных или подразумеваемых гарантий относительно корректности приведенной контактной информации о независимых производителях.

В данной статье упомянуты программные продукты, разработанные независимыми производителями. Корпорация Microsoft не дает никаких явных или подразумеваемых гарантий относительно корректной работы или надежности данных продуктов.

К началу статьи
Свойства

Номер статьи: 306654 — последний просмотр: 05/16/2006 09:34:00 — редакция: 3.0

Microsoft ASP .NET Beta 2, Microsoft Visual C# .NET 2002 Standard Edition

  • kbhowto kbhowtomaster kbgrpdsasp KB306654
Отзывы и предложения