Перейти к основному контенту
Поддержка
Войдите с помощью учетной записи Майкрософт
Войдите или создайте учетную запись.
Здравствуйте,
Выберите другую учетную запись.
У вас несколько учетных записей
Выберите учетную запись, с помощью которой нужно войти.

Проблемы

При попытке установить приложение из System Center 2012 Configuration Manager Корпоративный портал на устройство происходит сбой установки. Эта проблема возникает, если администратор сайта попытался повторно распространить приложение Manage.Microsoft.com точке распространения или попытался обновить содержимое.

Ошибки, похожие на следующие, записываются в файл outgoingcontentmanager.log на сервере сайта:

Get SAS on Intune package XXX011D6 Intune Id {guid}/file_name
ERROR: Failed to get SAS location for package_id as result is empty
ERROR: Caught exception in GetSasUrl for package package_id: System.InvalidOperationException - Failed to upload as result is empty.

Причина

Эта проблема возникает из-за того, что компонент диспетчера исходящего содержимого передает уже отправленное содержимое, используя то же значение SHA, которое было ранее вычислино на основе имени файла. В этом случае повторное распространение завершается сбоем. Процесс распространения также удаляет данные из таблицы MDM Content в базе Configuration Manager сайта и реплицирует удаление в Microsoft Intune.

Решение

После установки этого исправления приложения, которые находятся в состоянии повтора, должны автоматически обновляться на Manage.Microsoft.com распространения. Приложения, которые показывают сбой доставки содержимого, можно обновить, выбрав "Обновить содержимое" на вкладке "Типы развертывания" свойств приложения.

Сведения об исправлении

Поддерживаемое исправление доступно в служба поддержки Майкрософт. Однако это исправление предназначено только для устранения проблемы, описанной в этой статье. Примените это исправление только к системам, в которых возникла проблема, описанная в этой статье. Это исправление может получить дополнительное тестирование. Поэтому, если эта проблема серьезно не затрагивает вас, рекомендуется дождаться следующего обновления программного обеспечения, содержащего это исправление.

Если исправление доступно для скачивания, в верхней части этой статьи базы знаний есть раздел "Доступно скачивание исправлений". Если этот раздел не отображается, обратитесь в службу поддержки клиентов Майкрософт, чтобы получить исправление.

Обратите внимание, что при возникновении дополнительных проблем или необходимости устранения неполадок может потребоваться создать отдельный запрос на обслуживание. Обычные затраты на поддержку будут применяться к дополнительным вопросам поддержки и вопросам, которые не подходят для этого исправления. Полный список номеров телефонов службы поддержки и обслуживания майкрософт или создания отдельного запроса на обслуживание см. на следующем веб-сайте Майкрософт:

http://support.microsoft.com/contactus/?ws=supportОбратите внимание, что в форме "Доступно скачивание исправлений" отображаются языки, для которых доступно исправление. Если язык не отображается, исправление недоступно для этого языка.

Предварительные условия

Чтобы применить это исправление, необходимо установить накопительный пакет обновления 2 для System Center 2012 Configuration Manager с пакетом обновления 2 (SP2) и System Center 2012 R2 Configuration Manager с пакетом обновления 1 (SP1).

Необходимость перезагрузки

После применения этого исправления не нужно перезапускать компьютер.

Сведения о замене исправлений

Это исправление не заменяет ранее выпущенное исправление.

Английская версия исправления содержит файлы с атрибутами, указанными в следующей таблице, или более поздние. Даты и время для файлов указаны в формате времени UTC. При просмотре сведений о файлах выполняется перевод соответствующих значений в местное время. Чтобы узнать разницу между временем UTC и местным временем, откройте вкладку Часовой пояс элемента Дата и время панели управления.

Имя файла

Версия файла

Размер

дата

Время

Платформа

Microsoft.configurationmanager.intunecontentmanager.dll

5.0.8239.1308

81,072

5 октября 2015 г.

01:40

x86


Статус

Корпорация Майкрософт подтверждает наличие этой проблемы в своих продуктах, которые перечислены в разделе "Применяется к".

Ссылки

Сведения о терминологии, используемой корпорацией Майкрософт для описания обновлений программного обеспечения.

Нужна дополнительная помощь?

Нужны дополнительные параметры?

Изучите преимущества подписки, просмотрите учебные курсы, узнайте, как защитить свое устройство и т. д.

В сообществах можно задавать вопросы и отвечать на них, отправлять отзывы и консультироваться с экспертами разных профилей.

Были ли сведения полезными?

Насколько вы удовлетворены качеством перевода?
Что повлияло на вашу оценку?
После нажатия кнопки "Отправить" ваш отзыв будет использован для улучшения продуктов и служб Майкрософт. Эти данные будут доступны для сбора ИТ-администратору. Заявление о конфиденциальности.

Спасибо за ваш отзыв!

×