Таблица HTML вставляется в документ OneNote в виде одиночного столбца

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Эта статья помещена в архив. Она предлагается "как есть" и обновляться не будет.
Проблема
При вставке таблицы, скопированной с веб-страницы, в документ Microsoft Office OneNote 2003 таблица может быть вставлена как одиночный столбец текста.

Примечание. Это может произойти вне зависимости от параметров вставки, выбранных при вставке таблицы. Например, проблема может возникнуть, если для параметра Paste Options установлено значение, равное любому из перечисленных ниже значений:
  • Keep Source Formatting
  • Match Destination Formatting
  • Keep Text Only
Причина
Это происходит потому, что OneNote не сохраняет стандартное форматирование HTML-таблицы. Приложение OneNote разработано таким образом, что для отображения структуры таблицы используются горизонтальные уровни структуры.

Для получения дополнительной информации о структуре таблиц, используемой в OneNote, выберите команду Microsoft Office OneNote Help в меню Help, введите create a table structure в поле Search for на панели Assistance, нажмите кнопку Search for и просмотрите найденные разделы.
Временное решение
В качестве временного решения для сохранения внешнего вида таблицы можно использовать следующий способ. Вставьте таблицу в документ Microsoft Word, а затем скопируйте ее из документа Microsoft Word и вставьте в документ OneNote. Для этого выполните следующие действия.
  1. Выделите на веб-странице небходимую таблицу и скопируйте ее.
  2. Запустите Microsoft Word.
  3. В новом документе выберите в меню Правка команду Вставить.
  4. Выделите в документе Microsoft Word вставленную таблицу.

    Для этого выполните следующие действия.
    1. Щелкните область внутри таблицы.
    2. В меню Таблица выберите последовательно команды Выделить и Таблица.
  5. В меню Правка выберите команду Копировать.
  6. Запустите OneNote.
  7. Откройте необходимую страницу документа OneNote и выберите в меню Edit команду Paste.
on2003 htm mht mhtl
Свойства

Номер статьи: 822513 — последний просмотр: 01/12/2015 21:58:17 — редакция: 4.1

  • Microsoft Office OneNote 2003
  • Microsoft Office OneNote 2003 Service Pack 1
  • kbnosurvey kbarchive kbbug kbconvert kbpending KB822513
Отзывы и предложения