Как включить или отключить предупреждения гиперссылок в приложениях Office 2007 и Office 2010

ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.

Эта статья на английском языке: 925757
ВВЕДЕНИЕ
Эта статья содержит пошаговые инструкции для включения или отключения отображения предупреждающего сообщения каждый раз при щелчке гиперссылки в приложении Microsoft Office 2007 или Microsoft Office 2010.
Дополнительная информация
Важно: Этот раздел, метод или задача содержит действия, содержащие указания по изменению реестра. Однако, при некорректных изменениях реестра могут возникнуть серьезные проблемы. Поэтому выполняйте следующие действия внимательно. Для дополнительной защиты сделайте резервную копию реестра перед внесением изменений. В таком случае при возникновении неполадок можно будет восстановить реестр. Чтобы узнать дополнительные сведения о резервном копировании и восстановлении реестра, щелкните следующий номер статьи базы знаний Майкрософт:
322756 Как сделать резервное копирование и восстановление реестра Windows


В 2007 Office и Office 2010 при щелчке гиперссылки или объект, который ссылается на исполняемый файл, появляется следующее предупреждение:
Открытие "путь/имя_файла".
Гиперссылки могут представлять опасность для компьютера и данных. Чтобы защитить компьютер, нажмите кнопку только гиперссылки, полученные из надежных источников. Вы действительно хотите продолжить?
Это происходит независимо от настройки уровня безопасности.

Примечание Чтобы найти параметры уровня безопасности, в меню Сервис выберите пункт макрос и щелкните Безопасность.

Кроме того при открытии изображения TIFF или файлы Microsoft Document Imaging (MDI), появляется следующее предупреждение:
Открывая путь и имя файла.
Некоторые файлы могут содержать вирусы или представлять иную опасность для вашего компьютера. Важно быть уверенным в том, что этот файл получен из надежного источника. Вы действительно хотите открыть этот файл?
Сообщение предупреждения даже в том случае, если уже был реализован раздел реестра, в данной статье. Это предупреждающее сообщение поступает из файла HLINK.dll при обработке ссылки навигации. 2007 Office или Office 2010 предупреждающие сообщения можно отличить от предупреждающее сообщение HLINK ищет путь к файлу в окне предупреждения в кавычки. Сообщение 2007 Office или Office 2010 содержит кавычки. Сообщение HLINK не содержит кавычки. 2007 office и Office 2010 пытается определить, является ли тип файла сам небезопасных путем проверки расширения, идентификатор progid, classid и MIME-тип документа.

Как глобально включить или отключить предупреждения гиперссылок

Требуется помощь включить предупреждения гиперссылок для 2007 Office программы и программы для Office 2010 для вас, перейдите к»Вот простой исправления"раздел. Если вы предпочитаете включить параметр самостоятельно, перейдите к»Самостоятельное решение проблемы"раздел.

Вот простой исправления

Чтобы устранить проблему автоматически, нажмите кнопку Загрузить. В диалоговом окне Загрузка файла нажмите кнопку выполнить или Открыть, а затем следуйте указаниям мастера простого решения.
  • Этот мастер может быть только на английском языке. Однако автоматическое исправление также работает для других языковых версий Windows.
  • Если вы не на компьютере, который имеет проблемы, сохраните решение легкого исправления на флэш-накопитель или компакт-диск и запустите его на нужном компьютере.
Включить предупреждения гиперссылок

Самостоятельное решение проблемы

Простой fix20189

Чтобы включить или отключить предупреждения гиперссылок в 2007 Office программ и программ в Office 2010 при адрес http:// заметки: / / адрес или ftp: / / адрес используется, необходимо создать новый раздел реестра. Чтобы сделать это, выполните следующие действия.
  1. Нажмите кнопку Пуск и выберите команду Выполнить.
  2. В поле Открыть введите команду regeditи нажмите кнопку ОК.

    Заметки
    • Необходимо изменить только один из этих подразделов реестра. Нет необходимости менять оба поля.
    • Если подраздел безопасности уже существует, перейдите к шагу 6 после выберите вкладку Безопасность.
  3. В редакторе реестра найдите один из указанных ниже подразделов реестра для 2007 Office:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common
    Или в редакторе реестра выберите один из следующих подразделов реестра для Office 2010:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\Common
  4. Выделите раздел реестра, в меню Правка выберите пункт Создать и выберите раздел.
  5. Тип Безопасность, и нажмите клавишу ВВОД, чтобы присвоить имя ключа.
  6. В меню Правка выберите пункт Создатьи затем щелкните Значение DWORD.
  7. Тип DisableHyperlinkWarning, и нажмите клавишу ВВОД, чтобы переименовать запись.
  8. В правой области щелкните правой кнопкой мыши DisableHyperlinkWarningи выберите команду Изменить.
  9. В диалоговом окне Изменение параметра DWORD нажмите десятичный, а затем введите 1 или 0 в поле значение.

    Примечание Значение 0 позволяет предупреждающие сообщения. Значение 1 отключает предупреждающие сообщения.
  10. Нажмите кнопку ОК.
  11. Закройте редактор реестра.

Как включить или отключить предупреждения гиперссылок одного протокола

Чтобы отключить отображение предупреждений системы безопасности для определенного протокола, выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт выполнить, тип regedit, а затем нажмите кнопку ОК.
  2. Найдите следующий подраздел реестра:
    HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\xx.0\Common\Security\Trusted Protocols\All Applications
    Примечание В этом подразделе замените «xx.0» 12.0 для Outlook 2007 и с 14.0 для Outlook 2010.
  3. Перейдите на вкладку все приложения.
  4. В меню Правка выберите пункт Создатьи выберите раздел.
  5. Введите имя протокола, который требуется исключить. Например, чтобы отключить отображение предупреждений системы безопасности для "заметки:" протокола, введите Примечания:.

    Примечание
    убедитесь, что знак двоеточия (:).
  6. Нажмите клавишу ВВОД.
  7. Закройте редактор реестра.

Если по-прежнему получаю сообщение об ошибке

После отключения предупреждений, по-прежнему может появиться предупреждающее сообщение от Microsoft Windows. Если вы продолжаете получать сообщение после выполните действия, описанные в данной статье, используйте один из следующих методов для решения этой проблемы.

Примечание Способ 1 применяется только для Windows XP и более ранних версий Windows. Windows Vista и более поздних версиях Windows используйте способ 2.

Метод 1: Отключите параметр «Подтверждать открытие после загрузки» для типа файла, который вы пытаетесь открыть

  1. Дважды щелкните значок Мой компьютер.
  2. В меню Сервис выберите Свойства папки
  3. На вкладке « Типы файлов » выберите расширение имени файла (например, WMV) в поле Зарегистрированные типы файлов и нажмите кнопку Дополнительно.
  4. Снимите флажок Подтверждать открытие после загрузки , а затем нажмите кнопку ОК.
  5. В диалоговом окне Свойств папки нажмите кнопку Закрыть.

Метод 2: Измените HKEY_CLASSES_ROOT\<CLSID>раздел реестра \EditFlags</CLSID>

Используйте этот метод, если предупреждение влияет на нескольких компьютерах.

Чтобы отключить предупреждение, выполните следующие действия.
  1. Нажмите кнопку Пуск, выберите пункт выполнить, тип regedit, а затем нажмите кнопку ОК.
  2. Найдите следующий подраздел реестра:
    HKEY_CLASSES_ROOT\<CLSID>\EditFlags
    Например если расширение имени файла WMV, выберите HKEY_CLASSES_ROOT\WMVFile\EditFlags
  3. Выберите EditFlagsи в меню Правка выберите команду Переименовать .
  4. Тип OldEditFlags, а затем нажмите клавишу ВВОД.
  5. В меню Правка выберите пункт Создатьи затем щелкните значение DWORD.
  6. Тип EditFlags, а затем нажмите клавишу ВВОД.
  7. В меню Правка выберите команду Изменить.
  8. В диалоговом окне Изменение параметра DWORD пункт ШестнадцатеричныйBase.
  9. Тип 10000, а затем нажмите кнопку ОК.
Чтобы повторно включить предупреждающие сообщения, выполните следующие действия:
  1. Нажмите кнопку Пуск, выберите пункт выполнить, тип regedit, а затем нажмите кнопку ОК.
  2. Найдите следующий подраздел реестра:
    HKEY_CLASSES_ROOT\<CLSID>\EditFlags
  3. Выберите EditFlagsи выберите команду Изменить в меню Правка .
  4. Тип 0, а затем нажмите кнопку ОК.

Примечание Даже после выполнения этих действий вы получите предупреждающее сообщение при открытии файлов в Office 2010 в Режиме защищенного просмотра.

"Устранена ли неполадка?"

Проверьте, устранена ли проблема. Если проблема устранена, дальше можно не читать. Если проблема не устранена, можнообратитесь в службу поддержки.
PPT2007 PowerPoint2007 XL2007 Excel2007 WD2007 Word2007 Office2007 OFF2007 Office 2007 ACC2007 Access 2007 PUB2007 Publisher2007 SPD2007 SharePointDesigner2007 OL2007 Outlook2007 решить устранить

Внимание! Эта статья переведена автоматически

Vlastnosti

ID článku: 925757 – Posledná kontrola: 03/03/2016 05:12:00 – Revízia: 8.0

Microsoft Office Basic 2007, Microsoft Office Enterprise 2007, Microsoft Office Home and Student 2007, Microsoft Office Professional 2007, Microsoft Office Professional Plus 2007, Microsoft Office Standard 2007, Microsoft Office Ultimate 2007, Microsoft Office Access 2007, русская версия, Microsoft Office Excel 2007, русская версия, Microsoft Office Outlook 2007, русская версия, Microsoft Office PowerPoint 2007, русская версия, Microsoft Office Publisher 2007, русская версия, Microsoft Office SharePoint Designer 2007, русская версия, Microsoft Office Word 2007, русская версия, Microsoft Excel 2010, Microsoft Word 2010, Microsoft PowerPoint 2010, Microsoft Publisher 2010, русская версия, Microsoft Visio Professional 2010, Microsoft Visio Standard 2010, Microsoft Outlook 2010, Microsoft OneNote 2010, русская версия, Microsoft Office Home and Business 2010, Microsoft Office Home and Student 2010, Microsoft Office Professional 2010

  • kbexpertisebeginner kbhowto kbfixme kbmsifixme kbmt KB925757 KbMtru
Pripomienky