Войти

Сообщение об ошибке при попытке добавить пользователя из доверенного домена для Microsoft Dynamics CRM 4.0: "произошла ошибка"

ВНИМАНИЕ! Данная статья переведена с использованием программного обеспечения Майкрософт для машинного перевода и, возможно, отредактирована посредством технологии Community Translation Framework (CTF). Корпорация Майкрософт предлагает вам статьи, обработанные средствами машинного перевода, отредактированные членами сообщества Майкрософт и переведенные профессиональными переводчиками, чтобы вы могли ознакомиться со всеми статьями нашей базы знаний на нескольких языках. Статьи, переведенные с использованием средств машинного перевода и отредактированные сообществом, могут содержать смысловое, синтаксические и (или) грамматические ошибки. Корпорация Майкрософт не несет ответственности за любые неточности, ошибки или ущерб, вызванные неправильным переводом контента или его использованием нашими клиентами. Подробнее об CTF можно узнать по адресу http://support.microsoft.com/gp/machine-translation-corrections/ru.

958791
Эта статья помещена в архив. Она предлагается "как есть" и обновляться не будет.
Проблема
При попытке добавить пользователя из доверенного домена для Microsoft Dynamics CRM 4.0, появляется следующее сообщение об ошибке:
Произошла ошибка.
Повторите это действие. Если проблема сохранится, проверьте сообщества Microsoft Dynamics для решений, или обратитесь к администратора организации Microsoft Dynamics CRM. Наконец можно обратиться в службу технической поддержки корпорации Майкрософт.
Кроме того Если DevErrors значения в файле Web.config устанавливается значениеНа, появляется сообщение об ошибке следующего вида:
Ошибка: Ли исключение, адресат вызова.
Сообщение об ошибке: Ли исключение, адресат вызова.
Исходный файл: Недоступно
Номер строки: Недоступно
Запросить URL-адрес: http://MYCRMURL/MYORG/biz/users/edit.aspx?_CreateFromType=10&_CreateFromId={5BE7F527-076E-DC11-9739-02BF0FFF781B}
Причина
Данная проблема возникает в Microsoft Dynamics CRM 4.0 выполняет процесс поиска, чтобы найти пользователя в списке глобального каталога. Если процесс пытается подключиться к nonfunctioning глобального каталога или автономного глобального каталога, появляется сообщение об ошибке, описанное в разделе «Проблема».
Решение
Эта проблема исправлена в последний накопительный пакет обновления для Microsoft Dynamics CRM 4.0. Для получения дополнительных сведений обратитесь к следующей статье Базы Знаний Майкрософт::
949256Microsoft Dynamics CRM 4.0 обновлений и исправлений
Статус
Корпорация Майкрософт подтверждает, что это проблема в продуктах Майкрософт, перечисленных в разделе «Применяется к»..
Дополнительная информация
При возникновении этой проблемы в журнале платформы регистрируется сообщение об ошибке следующего вида:
Ошибка: Ли исключение, адресат вызова.
Сообщение об ошибке: Ли исключение, адресат вызова.
Исходный файл: Недоступно
Номер строки: Недоступно
Запросить URL-адрес: http://MYCRMURL/MYORG/biz/users/edit.aspx?_CreateFromType=10&_CreateFromId={5BE7F527-076E-DC11-9739-02BF0FFF781B}
Информация трассировки стека: [COMException: сервер неработоспособен.]
в System.DirectoryServices.DirectoryEntry.Bind (типа Boolean throwIfFail)
в System.DirectoryServices.DirectoryEntry.Bind()
в System.DirectoryServices.DirectoryEntry.get_AdsObject()
в System.DirectoryServices.DirectorySearcher.FindAll (типа Boolean findMoreThanOne)
в System.DirectoryServices.DirectorySearcher.FindAll()
в Microsoft.Crm.BusinessEntities.SecurityUtils.GetGuidFromSid (домен String, Byte [] ИД безопасности)
в Microsoft.Crm.BusinessEntities.SecurityUtils.GetUserId (ИмяДомена строка)
в Microsoft.Crm.BusinessEntities.SecurityLibrary.GetUserId (NTName строка)
в Microsoft.Crm.ObjectModel.SystemUserServiceInternal`1.CreateInternal (organizationId Guid, IBusinessEntity systemuser контекста ExecutionContext)
в Microsoft.Crm.ObjectModel.SystemUserServiceInternal`1.Create (IBusinessEntity systemuser, контекст ExecutionContext)
Дополнительные сведения о терминах, используемых при описании обновлений программного обеспечения, см. в следующей статье базы знаний Майкрософт::
824684Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт
Для получения дополнительных сведений о Microsoft Business Solutions CRM программное обеспечение исправления и обновления пакета терминологии, щелкните следующий номер статьи базы знаний Майкрософт:
887283Стандарты именования исправлений и обновлений для Microsoft Business Solutions CRM (эта ссылка может указывать на содержимое полностью или частично на английском языке)

Предупреждение: эта статья переведена автоматически

Свойства

Номер статьи: 958791 — последний просмотр: 01/16/2015 03:19:46 — редакция: 3.0

  • Microsoft Dynamics CRM 4.0
  • kbnosurvey kbarchive kberrmsg kbfix kbautohotfix kbexpertiseinter kbsurveynew kbmbsmigrate kbqfe kbHotfixServer kbmt KB958791 KbMtru
Отзывы и предложения